X
Tap here to go to the mobile version of the site.

Support Forum

Aggressive Ad Content layered onto Firefox Browser. Stop it!

Posted

A new cluster of ads are layered onto the Yahoo Browser on opening. Loud videos for Viagra and pulsing, flashing anti-Obama propaganda are smeared all over the page. Beneath the ads is a line that says "Site Not Responsible for Ad Content". I am not the only user getting this crap! How do I fix it? Otherwise I am going to delete Firefox.

I have a screenshot of this I can upload IF you had the good sense to provide an attachment link on this help screen.

I apologize for my harsh tone--FRUSTRATED by your lack of contact information other than your static 'help' FAQ-type pages, which are largely useless. No email to send info to! Phone loops back into the FAQs. WTF, People!!!

A new cluster of ads are layered onto the Yahoo Browser on opening. Loud videos for Viagra and pulsing, flashing anti-Obama propaganda are smeared all over the page. Beneath the ads is a line that says "Site Not Responsible for Ad Content". I am not the only user getting this crap! How do I fix it? Otherwise I am going to delete Firefox. I have a screenshot of this I can upload IF you had the good sense to provide an attachment link on this help screen. I apologize for my harsh tone--FRUSTRATED by your lack of contact information other than your static 'help' FAQ-type pages, which are largely useless. No email to send info to! Phone loops back into the FAQs. WTF, People!!!

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36

More Information

user830406 17 solutions 209 answers

I think the ads are caused by some add-on you installed by accident, the ads are coming on Yahoo alone or on every website, test the below mentioned technique and report back what happened.

It is possible to attach screenshots and links in Support forums, check the bottom of the editor in the left side and above post reply button.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

I think the ads are caused by some add-on you installed by accident, the ads are coming on Yahoo alone or on every website, test the below mentioned technique and report back what happened. It is possible to attach screenshots and links in Support forums, check the bottom of the editor in the left side and above '''post reply''' button. '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
the-edmeister
  • Top 10 Contributor
  • Moderator
3904 solutions 29469 answers

Helpful Reply

Yahoo Browser ??

Is that a 3rd party version of Firefox which is optimized for Yahoo?
IMO, that may install what many users feel is malware, and be the cause of your problems.

Please install the official version of Firefox which can be downloaded directly from Mozilla.
http://www.mozilla.com/en-US/firefox/all.html

Yahoo Browser ?? Is that a 3rd party version of Firefox which is optimized for Yahoo? <br /> IMO, that may install what many users feel is '''malware''', and be the cause of your problems. Please install the '''official''' version of Firefox which can be downloaded directly from Mozilla. <br /> http://www.mozilla.com/en-US/firefox/all.html
user830406 17 solutions 209 answers

the-edmeister thanks for the info even i forgot to notice that he said it was yahoo browser, i thought it was due to some add on.

the-edmeister thanks for the info even i forgot to notice that he said it was yahoo browser, i thought it was due to some add on.
jscher2000
  • Top 10 Contributor
3145 solutions 28942 answers

While in Safe Mode, you can manually mark extensions as disabled, and you can extract a list if you have questions about individual extensions.

  • Add-ons page: orange Firefox button (or Tools menu) > Add-ons > on the left side click Extensions
  • Extension list: Help > Troubleshooting Information, button in the upper left corner labeled "Copy Text to Clipboard"
While in Safe Mode, you can manually mark extensions as disabled, and you can extract a list if you have questions about individual extensions. * Add-ons page: orange Firefox button (or Tools menu) > Add-ons > ''on the left side click'' Extensions * Extension list: Help > Troubleshooting Information, button in the upper left corner labeled "Copy Text to Clipboard"
Sir.Mayo 5 solutions 26 answers

SO what they are sayign about reseting firedox is the right way to go about this but in the future I would recommend an add-on called ad-blocker it blocks all ads give it a try! on sites like:

  • youtube
  • facebook
  • search results
SO what they are sayign about reseting firedox is the right way to go about this but in the future I would recommend an add-on called ad-blocker it blocks all ads give it a try! on sites like: * youtube * facebook * search results

Modified by Sir.Mayo

the-edmeister
  • Top 10 Contributor
  • Moderator
3904 solutions 29469 answers

Who mentioned anything about doing a reset for Firefox?

Who mentioned anything about doing a '''reset''' for Firefox?
cor-el
  • Top 10 Contributor
  • Moderator
12151 solutions 112820 answers

Did you do a malware check?

Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Did you do a malware check? Do a malware check with some malware scanning programs on the Windows computer.<br> Please scan with all programs because each program detects different malware.<br> All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender: Home Page:<br>http://www.microsoft.com/windows/products/winfamily/defender/default.mspx *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked