X
Tap here to go to the mobile version of the site.

Support Forum

PDF wont open

Posted

i have been with Firefox since the start... it "was" the best... now PDF wont display in filefox.. you have to save them to view ... i have tried everything!!! i have read every thread about it, tried every solution.... but still cant get it to view pdf files ... i know all about the new inhouse PDF viewer, disabling it etc

then i found the answer .... i switched to Google chrome!.. it works fine in there

i'll keep looking back, and updating firefox.. but until it can display a PDF file without saving it... i'll use chrome

the best solution

i have been with Firefox since the start... it "was" the best... now PDF wont display in filefox.. you have to save them to view ... i have tried everything!!! i have read every thread about it, tried every solution.... but still cant get it to view pdf files ... i know all about the new inhouse PDF viewer, disabling it etc then i found the answer .... i switched to Google chrome!.. it works fine in there i'll keep looking back, and updating firefox.. but until it can display a PDF file without saving it... i'll use chrome the best solution

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Google Update
  • Shockwave Flash 11.5 r502
  • Shockwave Flash 11.4 r402
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

John99
  • Top 25 Contributor
  • Moderator
755 solutions 10296 answers

Firefox should be able to display pdf files. You obviously are aware of the fact that it has a built-in pdf viewer. I also see from the system details that you have the Adobe pdf plugin installed.

I guess you tried everything except what works !!

I have Firefox installs both with and without the Adobe plugin and can see pdf files without needing to save them.

You did not provide the full troubleshooting information, but I assume you have set preferences incorrectly.

See

Firefox should be able to display pdf files. You obviously are aware of the fact that it has a built-in pdf viewer. I also see from the system details that you have the Adobe pdf plugin installed. I guess you tried everything except what works !! I have Firefox installs both with and without the Adobe plugin and can see pdf files without needing to save them. You did not provide the full troubleshooting information, but I assume you have set preferences incorrectly. See *[[Use the Adobe Reader plugin to view or download PDF files]] *[[View PDF files in Firefox without downloading them]]

Helpful Reply

looked at them both ... done everything in there.. both Firefox's own plug in is installed, and adobes... tried both in all possible configurations..

my point is... i was happily using Firefox... it updated, and then i was left spending endless hours trying to find a solution to a problem i didn't cause...

and the best solution i came up with.. and by far the least time consuming was to switch to a different browser.

i wonder how many other people around the world had the same problem (judging by the amount of questions and forums set-up to deal with this issue - i would say millions) ... and simply couldn't be bothered or didnt have the expertise to re-configure firefox .... simply choose to easiest option .. which was to switch browsers.

i feel Mozilla has just shot themselves in the foot .. i have to work for a living, and just haven't got anymore time to spend on a problem i didn't cause in the first place

sad but true

looked at them both ... done everything in there.. both Firefox's own plug in is installed, and adobes... tried both in all possible configurations.. my point is... i was happily using Firefox... it updated, and then i was left spending endless hours trying to find a solution to a problem i didn't cause... and the best solution i came up with.. and by far the least time consuming was to switch to a different browser. i wonder how many other people around the world had the same problem (judging by the amount of questions and forums set-up to deal with this issue - i would say millions) ... and simply couldn't be bothered or didnt have the expertise to re-configure firefox .... simply choose to easiest option .. which was to switch browsers. i feel Mozilla has just shot themselves in the foot .. i have to work for a living, and just haven't got anymore time to spend on a problem i didn't cause in the first place sad but true
cor-el
  • Top 10 Contributor
  • Moderator
13046 solutions 119473 answers

Note that your System Details List shows multiple (3) Flash plugins.

  • Shockwave Flash 11.8 r800
  • Shockwave Flash 11.5 r502
  • Shockwave Flash 11.4 r402

You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32).

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
Note that your System Details List shows multiple (3) Flash plugins. * Shockwave Flash 11.8 r800 * Shockwave Flash 11.5 r502 * Shockwave Flash 11.4 r402 You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32). *(32 bit Windows) C:\Windows\System32\Macromed\Flash\ *(64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\
jscher2000
  • Top 10 Contributor
3973 solutions 34706 answers

Hi PDFwontopen, did this problem recently with the release of Firefox 24 (i.e., no problem in Firefox 23 and earlier)?

You might already have tried the following, but you didn't mention it specifically, so:

If you have been using the same Firefox settings for years, sometimes confusion can develop in the preferences file between multiple applications that seek to handle the same content types. You can rename or delete the file that stores these associations and have Firefox regenerate it. If the file is corrupted, this might be the only solution.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to the Adobe plugin as described in this article: How to disable the built-in PDF viewer and use another viewer.

Hi PDFwontopen, did this problem recently with the release of Firefox 24 (i.e., no problem in Firefox 23 and earlier)? You might already have tried the following, but you didn't mention it specifically, so: If you have been using the same Firefox settings for years, sometimes confusion can develop in the preferences file between multiple applications that seek to handle the same content types. You can rename or delete the file that stores these associations and have Firefox regenerate it. If the file is corrupted, this might be the only solution. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show Folder" button Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit) Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to the Adobe plugin as described in this article: [[How to disable the built-in PDF viewer and use another viewer]].
jscher2000
  • Top 10 Contributor
3973 solutions 34706 answers

Also, if you use any extensions related to downloading, try updating them and perhaps disabling them on the Add-ons page in case there is a glitch specific to Firefox 24:

orange Firefox button (or Tools menu) > Addons

  • "gear" button > Check for Updates
  • Extensions category

Alternately, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Also, if you use any extensions related to downloading, try updating them and perhaps disabling them on the Add-ons page in case there is a glitch specific to Firefox 24: orange Firefox button (or Tools menu) > Addons * "gear" button > Check for Updates * Extensions category Alternately, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
phruby 0 solutions 1 answers

I had a similar problem caused by the fact that the default action for Portable Document Format (PDF) was set to "Save file".

So in my case, the solution was to go to Tools/Options/Applications tab. In the Content type locate "Portable Document Format (PDF)" and change the Action to "Always ask", "Use Adobe reader", or "Preview in Firefox".

I had a similar problem caused by the fact that the default action for Portable Document Format (PDF) was set to "Save file". So in my case, the solution was to go to Tools/Options/Applications tab. In the Content type locate "Portable Document Format (PDF)" and change the Action to "Always ask", "Use Adobe reader", or "Preview in Firefox".