X
Tap here to go to the mobile version of the site.

Support Forum

the "show my windows and tabs from last time" brings up my home page instead

Posted

Configuring the option to "show my windows....." does not work no matter how I exit Firefox. I always get my home page when I reopen Firefox. The History menu item "Restore previous session" does work.

Windows 7, svc. pk. 1

Configuring the option to "show my windows....." does not work no matter how I exit Firefox. I always get my home page when I reopen Firefox. The History menu item "Restore previous session" does work. Windows 7, svc. pk. 1

Chosen solution

Please see the How to fix preferences that won't save article, if you have not already.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Waka_Flocka_Flame 441 solutions 5048 answers

Chosen Solution

Please see the How to fix preferences that won't save article, if you have not already.

Please see the [[How to fix preferences that won't save]] article, if you have not already.
cor-el
  • Top 10 Contributor
  • Moderator
12006 solutions 111551 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

In case you are using "Clear history when Firefox closes":

  • do not clear the Browsing History

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" ---- In case you are using "Clear history when Firefox closes": *do not clear the Browsing History *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/Clear+Recent+History Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.