X
Tap here to go to the mobile version of the site.

Support Forum

plugins.click_to_play false doesn't work

Posted

I followed the instructions below:

If you'd like to Disable Firefox's Click-to-Play feature,

   Type about:config in the address bar and press Enter.
   Press the big button to bypass the warning.
   In the search box, paste plugins.click_to_play
   In the search results, double-click plugins.click_to_play to set its value to false 

And it made absolutely NO difference. I'm so sick of having to click to play on everything I want to scream. Does anyone have any other ideas? This is the only one I've found and it's not working.

I followed the instructions below: If you'd like to Disable Firefox's Click-to-Play feature, Type about:config in the address bar and press Enter. Press the big button to bypass the warning. In the search box, paste plugins.click_to_play In the search results, double-click plugins.click_to_play to set its value to false And it made absolutely NO difference. I'm so sick of having to click to play on everything I want to scream. Does anyone have any other ideas? This is the only one I've found and it's not working.

Additional System Details

Installed Plug-ins

  • Plug-in for Workspace Webmail
  • Plug-in for Workspace utilities
  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Nitro PDF Plug-in for Firefox and Chrome
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Boomerang for GMail 1.2.1 ({65e41d20-f092-41b7-bb83-c6e8a9ab0f57})
  • Clip to OneNote 5.0 ({966762eb-7132-4081-ac70-20d20161ad96})
  • CoolPreviews 3.9 ({CE6E6E3B-84DD-4cac-9F63-8D2AE4F30A4B})
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • eBay Sidebar for Firefox 3.0.0.3 ({62760FD6-B943-48C9-AB09-F99C6FE96088})
  • Evernote Web Clipper 5.7 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • Firebug 1.12.2 (firebug@software.joehewitt.com)
  • Forecastfox 2.2.2 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3})
  • goo.gl lite 1.8.1 (goo.gl_lite@matthew.flaschen.gatech.edu)
  • Greasemonkey 1.11 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • LastPass 2.0.20 (support@lastpass.com)
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • Personas Plus 1.7.2.1 (personas@christopher.beard)
  • RSS Icon In Awesombar 1.4 (rssicon@jasnapaka.com)
  • Tab Mix Plus 0.4.1.1.01 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Element Hiding Helper for Adblock Plus 1.2.3 (elemhidehelper@adblockplus.org) (Inactive)
  • Gmail Notifier (restartless) 0.3.4 (jid0-GjwrPchS3Ugt7xydvqVK4DQk8Ls@jetpack) (Inactive)
  • Restore Your Gmail Settings 0.1 (old.compose@gmail.com) (Inactive)
  • WBE Paste 1.3 (wbepaste@starfield) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Mobility Radeon HD 4200 Series
  • adapterDescription2:
  • adapterDeviceID: 0x9712
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 3-15-2010
  • driverDate2:
  • driverVersion: 8.712.2.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4200 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow.override.external: 3
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.resume_from_crash: False
  • browser.sessionstore.resume_session_once: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20130823004003
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.loadInBackground: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: False
  • network.cookie.prefsMigrated: True
  • permissions.default.image: 0
  • places.database.lastMaintenance: 1380233900
  • places.history.expiration.transient_current_max_pages: 100530
  • plugin.disable_full_page_plugin_for_types: application/pdf,audio/mid,audio/midi,audio/x-midi,audio/mpeg,audio/x-mpeg,video/mpeg,video/x-mpeg,audio/mp4,audio/x-m4a,audio/x-m4b,audio/3gpp,video/3gpp,video/mp4,image/png,image/x-png
  • plugin.importedState: True
  • plugin.state.flash: 1
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1379766002

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

You can modify the settings of the plugins in Firefox/Tools > Add-ons > Plugins to always activate.
That should work with click-to-play disabled unless you have plugins that are blocklisted (outdated or for security reasons).

You can modify the settings of the plugins in Firefox/Tools > Add-ons > Plugins to always activate.<br /> That should work with click-to-play disabled unless you have plugins that are blocklisted (outdated or for security reasons).

Question owner

The window always says Activate Adobe Flash on each page that it appears and it's not listed as such in the plugins. Also, the Java Deployment Toolkit either gives me 'ask to activate' or 'disable' but no other option.

This is very frustrating.

The window always says Activate Adobe Flash on each page that it appears and it's not listed as such in the plugins. Also, the Java Deployment Toolkit either gives me 'ask to activate' or 'disable' but no other option. This is very frustrating.
LordChilde 1 solutions 32 answers

Same here.

I opened about:config to set 'plugins click to play' to false, and it was already false! The relevant plugins are all set to 'always activate' except for Java (because there's no such option). So it's impossible to disable click to play - perhaps Mozilla should've considered the apparent impossibility of disabling this feature.

Same here. I opened about:config to set 'plugins click to play' to false, and it was already false! The relevant plugins are all set to 'always activate' except for Java (because there's no such option). So it's impossible to disable click to play - perhaps Mozilla should've considered the apparent impossibility of disabling this feature.

Modified by LordChilde

cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

You can find the Adobe Flash player as Shockwave Flash 11.8 r800

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can find the Adobe Flash player as Shockwave Flash 11.8 r800 If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Hi LordChilde, if you cannot choose Always Activate on the Plugins section of the Add-ons page, it is because the plugin is blocked as insecure. Usually this can be resolved with an update, but not always. Regarding Java:

  • Java Platform SE: You should be able to find an update to resolve the issue with this plugin (this is the standard Java plugin).
  • Java Deployment Toolkit: right now, it appears there is no update for this plugin.
Hi LordChilde, if you cannot choose Always Activate on the Plugins section of the Add-ons page, it is because the plugin is blocked as insecure. Usually this can be resolved with an update, but not always. Regarding Java: * Java Platform SE: You should be able to find an update to resolve the issue with this plugin (this is the standard Java plugin). * Java Deployment Toolkit: right now, it appears there is no update for this plugin.
LordChilde 1 solutions 32 answers

Helpful Reply

I use Flashblock and Adblock Plus - Flashblock is off, and just to make sure I disabled Adblock on a couple of pages that run Flash.

No Problem with Java platform. For Java Deployment I've set extensions.blocklist.enabled to false - now this plugin is 'always activate'. So all plugins are set to always activate. I restarted FF, yet the plugin icon still appears in the address bar and I still have to manually choose.

btw, Is there a page detailing ALL the things that can be done via about:config? Because at the moment it's piece-meal - tedious search and answer.

I use Flashblock and Adblock Plus - Flashblock is off, and just to make sure I disabled Adblock on a couple of pages that run Flash. No Problem with Java platform. For Java Deployment I've set extensions.blocklist.enabled to false - now this plugin is 'always activate'. So all plugins are set to always activate. I restarted FF, yet the plugin icon still appears in the address bar and I still have to manually choose. btw, Is there a page detailing ALL the things that can be done via about:config? Because at the moment it's piece-meal - tedious search and answer.
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Hi LordChilde, you wrote:

I restarted FF, yet the plugin icon still appears in the address bar and I still have to manually choose.

If you have Always Activate, the icon should be informing you that the plugin is running and lets you block it if you want. If you don't want to block it, just ignore it.

btw, Is there a page detailing ALL the things that can be done via about:config?

I have not seen one. The mozillaZine Knowledge Base covers many of the settings, but new ones are introduced regularly, and some of them are for internal use and not meant to be modified by users.

Hi LordChilde, you wrote: <blockquote>I restarted FF, yet the plugin icon still appears in the address bar and I still have to manually choose.</blockquote> If you have Always Activate, the icon should be informing you that the plugin is running and lets you block it if you want. If you don't want to block it, just ignore it. <blockquote>btw, Is there a page detailing ALL the things that can be done via about:config?</blockquote> I have not seen one. The mozillaZine Knowledge Base covers many of the settings, but new ones are introduced regularly, and some of them are for internal use and not meant to be modified by users.

Question owner

Java is set to always activate. It is also up to date.

Java toolkit is Always Ask and I can't change it nor can I disable or uninstall it.

So, unless Mozilla addresses this in the future, I'm stuck with having to always click to activate which is a really sucky thing to do to their consumers (yes, I know sucky is an immature word, but really, I'm so tired of this)

Java is set to always activate. It is also up to date. Java toolkit is Always Ask and I can't change it nor can I disable or uninstall it. So, unless Mozilla addresses this in the future, I'm stuck with having to always click to activate which is a really sucky thing to do to their consumers (yes, I know sucky is an immature word, but really, I'm so tired of this)
LordChilde 1 solutions 32 answers

"If you have Always Activate, the icon should be informing you that the plugin is running and lets you block it if you want. If you don't want to block it, just ignore it."

Sorry, but it doesn't work like that! I've just accessed Youtube and Flash is blocked unless I allow Flash to run. I've jumped through all the hoops that are supposed to prevent this - to actually disable 'click to play' and allow Flash to run wherever (if I don't want Flash I use Flashblock), yet I'm still having to 'click' in order to 'play'.

It's no big deal... a minor irritation ("allow and remember" will resolve the issue when I view every single website that runs Flash). But it becomes an annoyance when I spend time trying to disable the damn thing without success.

"If you have Always Activate, the icon should be informing you that the plugin is running and lets you block it if you want. If you don't want to block it, just ignore it." Sorry, but it doesn't work like that! I've just accessed Youtube and Flash is blocked unless I allow Flash to run. I've jumped through all the hoops that are supposed to prevent this - to actually disable 'click to play' and allow Flash to run wherever (if I don't want Flash I use Flashblock), yet I'm still having to 'click' in order to 'play'. It's no big deal... a minor irritation ("allow and remember" will resolve the issue when I view every single website that runs Flash). But it becomes an annoyance when I spend time trying to disable the damn thing without success.
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Hi LordChilde, I wonder whether Firefox has stored a different site-specific preference. The next time you find a page with Flash blocked, could you check the Permissions tab of the Page Info dialog. You can access this using:

  • click the padlock or globe to the left of the address > More Information
  • right-click the page > View Page Info
  • Tools menu > Page Info

I've attached a sample screen shot for what I see on this site. Is there a site-specific block, or is the page using what it thinks is the default setting?

Hi LordChilde, I wonder whether Firefox has stored a different site-specific preference. The next time you find a page with Flash blocked, could you check the Permissions tab of the Page Info dialog. You can access this using: * click the padlock or globe to the left of the address > More Information * right-click the page > View Page Info * Tools menu > Page Info I've attached a sample screen shot for what I see on this site. Is there a site-specific block, or is the page using what it thinks is the default setting?
LordChilde 1 solutions 32 answers

In Permissions (when Flash is running) it's set as 'allow'. When Flash is blocked it switches to 'always ask'... (Flash is also blocked when 'use default' is manually checked).

In Permissions (when Flash is running) it's set as 'allow'. When Flash is blocked it switches to 'always ask'... (Flash is also blocked when 'use default' is manually checked).
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Helpful Reply

Hi LordChilde, I think your scenario has uncovered a bug. I think it's a bug in the UI, but arguably it's also a departure from what users would expect. I can replicate it by doing the following:

(1) In about:config, set plugins.click_to_play = true. Keep this tab open.

(2) Open the Add-ons page (Ctrl+Shift+a) to the Plugins section, set Shockwave Flash to Ask to Activate. Then close this tab.

(3) Open a page with Flash media to confirm that it worked (this assumes it is a site for which you have not previously set the "Allow" permission). Then close this tab.

(4) In about:config, reset plugins.click_to_play = false.

(5) Open the Add-ons page (Ctrl+Shift+a) to the Plugins section, and observe that Shockwave Flash is now shown as being set to Always Activate. Then close this tab.

(6) Open a page with Flash media and observe the click-to-play UI in place of the media. Open the Page Info dialog and observe that the Flash permission for the page is "Use default." Obviously this is inconsistent with #5. Then close this tab.

(7) In about:config, set plugins.click_to_play = true.

(8) Open the Add-ons page (Ctrl+Shift+a) to the Plugins section. Observe that Shockwave Flash is set to Ask to Activate.

From this, it is clear that toggling the setting in about:config does not actually change the permission Firefox is applying. It does, however, change the choices on the drop-down control so the true permission is misreported on this page. To correct the actual default permission, you have to do one of the following:

  • Re-enable click-to-play so the Add-ons page shows all 3 choices, and manually change "Ask to Activate" to "Always Activate" before disabling click-to-play again.
  • Force an update by changing to "Never Activate" first, then changing to "Always Activate".

Maybe someone has already filed a bug on this, I haven't searched.

Hi LordChilde, I think your scenario has uncovered a bug. I think it's a bug in the UI, but arguably it's also a departure from what users would expect. I can replicate it by doing the following: (1) In about:config, set plugins.click_to_play = true. Keep this tab open. (2) Open the Add-ons page (Ctrl+Shift+a) to the Plugins section, set Shockwave Flash to Ask to Activate. Then close this tab. (3) Open a page with Flash media to confirm that it worked (this assumes it is a site for which you have not previously set the "Allow" permission). Then close this tab. (4) In about:config, reset plugins.click_to_play = false. (5) Open the Add-ons page (Ctrl+Shift+a) to the Plugins section, and observe that Shockwave Flash is now shown as being set to Always Activate. Then close this tab. (6) Open a page with Flash media and observe the click-to-play UI in place of the media. Open the Page Info dialog and observe that the Flash permission for the page is "Use default." Obviously this is inconsistent with #5. Then close this tab. (7) In about:config, set plugins.click_to_play = true. (8) Open the Add-ons page (Ctrl+Shift+a) to the Plugins section. Observe that Shockwave Flash is set to Ask to Activate. From this, it is clear that toggling the setting in about:config does not actually change the permission Firefox is applying. It does, however, change the choices on the drop-down control so the true permission is misreported on this page. To correct the actual default permission, you have to do one of the following: * Re-enable click-to-play so the Add-ons page shows all 3 choices, and manually change "Ask to Activate" to "Always Activate" before disabling click-to-play again. * Force an update by changing to "Never Activate" first, then changing to "Always Activate". Maybe someone has already filed a bug on this, I haven't searched.
LordChilde 1 solutions 32 answers

Must be a bug if the only way to disable ‘click to play’ is to disable Flash itself. Flashblock disables Flash - and the plugin icon disappears, but as soon as FB is “off” it comes back again.

Interestingly, ‘click to play’ is also disabled when I use a mobile agent in User Agent Switcher.

Must be a bug if the only way to disable ‘click to play’ is to disable Flash itself. Flashblock disables Flash - and the plugin icon disappears, but as soon as FB is “off” it comes back again. Interestingly, ‘click to play’ is also disabled when I use a mobile agent in User Agent Switcher.

Modified by LordChilde

jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Hi LordChilde, did either of the methods toward the end of my post (the two bullets) work for you? (With Flashblock disabled.)

Hi LordChilde, did either of the methods toward the end of my post (the two bullets) work for you? (With Flashblock disabled.)
LordChilde 1 solutions 32 answers

Ah, Yes! I assumed nothing changed because I still could not disable 'click to play'. However, I tried Flash in daily motion and huffingdon post (two sites I've not accessed since updating to FF24) - videos played automatically bypassing 'click to play', so problem solved.

I've done a copy/paste job of your fix for future reference.

Many thanks for your help.

Ah, Yes! I assumed nothing changed because I still could not disable 'click to play'. However, I tried Flash in daily motion and huffingdon post (two sites I've not accessed since updating to FF24) - videos played automatically bypassing 'click to play', so problem solved. I've done a copy/paste job of your fix for future reference. Many thanks for your help.