Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox automatically adds port number in address bar when it should not.

  • 4 replies
  • 2 have this problem
  • 504 views
  • Last reply by iggy05

more options

I work for an ISP company that regularly sets up routers for customer locations. One of the things that I have to change on it is to set the management port to 8080. For instance 192.168.0.1:8080. Once I try to setup a new router Firefox automatically assumes that I want to go to the same 8080 port and automatically enters it in for me. Since the new router has not been setup with 8080 yet I can not get in. So basically I would like to see if I can stop Firefox from automatically entering this bit of information in. It is very annoying and even more annoying that I have to use a different browser to make the changes since Firefox can not. I did find a similar fix posted when Firefox automatically enters in ".www" but that did not fix my problem.

Chosen solution

Consider disabling the URL bar autofill feature. You still can select a previously used address by arrowing down on the autocomplete drop-down, but Firefox won't add characters to the URL while you're typing. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste fill and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch its value from true to false.

Does that help?

Read this answer in context 👍 0

All Replies (4)

more options
more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Chosen Solution

Consider disabling the URL bar autofill feature. You still can select a previously used address by arrowing down on the autocomplete drop-down, but Firefox won't add characters to the URL while you're typing. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste fill and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch its value from true to false.

Does that help?

more options

Thanks all for your help but jscher2000 definately did the trick and to what I wanted to have done for sure. I did what you said and it is exactly what I wanted. The autofill feature is nice but I also find it anoying at times anyway as it often times takes me to the wrong website. I hope this helps someone in the future that is looking at the same issue.

Thanks!