X
Tap here to go to the mobile version of the site.

Support Forum

How to disable a new FF feature

Posted

https://blog.mozilla.org/futurereleases/2013/09/24/plugin-activation-in-firefox/

Firefox stable release, not aurora, as in the photo. about:config. click to play false.

Since I hate this new plugin warning (I am using Noscript), I would be very grateful to you if you may want to suggest me how to root out definitely this "plugin enabled window in the url bar (plugins-notification-icon?)". There are some keys in about:config to be setted to false or what else? (this feature requires one more click if I want to opend a pdf, very annoying).

Thank you in advance. Regards

https://blog.mozilla.org/futurereleases/2013/09/24/plugin-activation-in-firefox/ Firefox stable release, not aurora, as in the photo. about:config. click to play false. Since I hate this new plugin warning (I am using Noscript), I would be very grateful to you if you may want to suggest me how to root out definitely this "plugin enabled window in the url bar (plugins-notification-icon?)". There are some keys in about:config to be setted to false or what else? (this feature requires one more click if I want to opend a pdf, very annoying). Thank you in advance. Regards

Modified by anuswara

Chosen solution

Hi anuswara, you can hide the gray "lego" icon using a custom style rule. You can implement the rule using either (1) Stylish extension or (2) userChrome.css file. This is simply hiding the icon you do not need, and does not require click-to-play on or off.

Style rule (may need to change left or right margin to -6px depending on your specific toolbar layout):

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* Gray icon saying plugin is active and providing option to block */
#plugins-notification-icon{
  width: 0px !important;
  margin-left: -5px !important;
  margin-right: -5px !important;
}

This should not affect other notifications in that area of the address bar.

If you decide you want to remove a site's permission to run a plugin but still allow scripts, you can block the plugin on the Permissions tab of the Page Info dialog. To call up that dialog, you can choose one of these methods:

  • Click the site identity icon (globe or padlock) > More Information
  • Right-click the page > View Page Info
  • Tools menu > Page Info

Related discussion: How to get rid of plugin in use lego icon?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • 5.1.20513.0
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Waka_Flocka_Flame 441 solutions 5048 answers

If you read the whole thing, there is a addon listed to get back the old behavior.

"We redesigned the click-to-play feature to focus on enabling plugins per-site, rather than enabling individual plugin instances on the page. Advanced users who want to activate individual instances may still do so by installing a Firefox extension. "

If you read the whole thing, there is a addon listed to get back the old behavior. * https://addons.mozilla.org/en-US/firefox/addon/click-to-play-per-element/ "We redesigned the click-to-play feature to focus on enabling plugins per-site, rather than enabling individual plugin instances on the page. Advanced users who want to activate individual instances may still do so by installing a Firefox extension. "
philipp
  • Top 10 Contributor
  • Moderator
2928 solutions 13676 answers

hello, in the current stable release where plugins.click_to_play is set to false this should only be happening for outdated/vulnerable plugins (i don't know if/how noscript may play into that matter though) - so please check that all of them are up-to-date: https://www.mozilla.org/plugincheck/

in case plugins.click_to_play is set to true you could also set different settings (always activate/always ask/never activate) for different plugins in the firefox addons manager...

hello, in the current stable release where ''plugins.click_to_play'' is set to ''false'' this should only be happening for outdated/vulnerable plugins (i don't know if/how noscript may play into that matter though) - so please check that all of them are up-to-date: https://www.mozilla.org/plugincheck/ in case plugins.click_to_play is set to true you could also set different settings (always activate/always ask/never activate) for different plugins in the firefox addons manager...

Helpful Reply

Hi, its crazy that I have to install an addon to get the firefox behaviour as until the version 23 :( I dont understand why it cannot be disabled via about:config.

I be sure: all the plugins are up to date ;)

why Mozilla "encouirages" users to install addon to get the "old" behaviour?

(we will wait for ff25 where noscript+plugin notifications+ click ti play enabled by default: too many and conflicting warnings).

I want to leave cli to play to false.

Did Mozilla try this feature with acrobat reader plugin too? this requires an additional click (page reload otherwise the pdf is blank).

from the link above: "To give people a better Firefox experience" I dont agrre whit this statement.

I guess that, after 5 years, its now time to switch to another browser.

Thank you both users for their answer (I appreciate your help) but I am astonished about this behaviour: addon addon addon....and new feauture that canno tbe removed via about:config.

Hi, its crazy that I have to install an addon to get the firefox behaviour as until the version 23 :( I dont understand why it cannot be disabled via about:config. I be sure: all the plugins are up to date ;) why Mozilla "encouirages" users to install addon to get the "old" behaviour? (we will wait for ff25 where noscript+plugin notifications+ click ti play enabled by default: too many and conflicting warnings). I want to leave cli to play to false. Did Mozilla try this feature with acrobat reader plugin too? this requires an additional click (page reload otherwise the pdf is blank). from the link above: "To give people a better Firefox experience" I dont agrre whit this statement. I guess that, after 5 years, its now time to switch to another browser. Thank you both users for their answer (I appreciate your help) but I am astonished about this behaviour: addon addon addon....and new feauture that canno tbe removed via about:config.
Waka_Flocka_Flame 441 solutions 5048 answers

Also, so how is it interfering with NoScript?

Also, so how is it interfering with NoScript?

Helpful Reply

1) if I am watching a youtube video, I konw that flash is running, I dont want to see a notification for allow o deny flash. 2) if I am watching a silverlight video, I think that I want to watch the video and I dont like the notification allow or deny silverlight on the site....

3) if I am watching a pdf, I want to make what I made until ff23: click on the pdf link > click OK in Noscript > I watch the pdf. now this is conflicting: blank page, I have to reload the page.

I consider this new feature like a malware (an unwanted toolbar).

If a dev adds a feature, I guess that he is able to remove the feature he added. on-off. on-off. so...this is my question: there are a key on about:config to set to false to get the same behaviour as in ff23, or its compulsory to accept this (crazy) choice of the dev?

regarding the click to play I am fine because I found the key in about:config, regarding the dxva I fount it, nowhow to remove this Plugin notification introduced in ff24?

1) if I am watching a youtube video, I konw that flash is running, I dont want to see a notification for allow o deny flash. 2) if I am watching a silverlight video, I think that I want to watch the video and I dont like the notification allow or deny silverlight on the site.... 3) if I am watching a pdf, I want to make what I made until ff23: click on the pdf link > click OK in Noscript > I watch the pdf. now this is conflicting: blank page, I have to reload the page. I consider this new feature like a malware (an unwanted toolbar). If a dev adds a feature, I guess that he is able to remove the feature he added. on-off. on-off. so...this is my question: there are a key on about:config to set to false to get the same behaviour as in ff23, or its compulsory to accept this (crazy) choice of the dev? regarding the click to play I am fine because I found the key in about:config, regarding the dxva I fount it, nowhow to remove this Plugin notification introduced in ff24?

Modified by anuswara

Waka_Flocka_Flame 441 solutions 5048 answers

I do use NoScript, but I just reinstalled my system, so i dont even have any plugins to test this with.

I do use NoScript, but I just reinstalled my system, so i dont even have any plugins to test this with.

Question owner

the problem is not if this feature is working or not, my problem is how to remove this feature. I will try the german forum now.

the problem is not if this feature is working or not, my problem is how to remove this feature. I will try the german forum now.
Georg Fritzsche 4 solutions 14 answers

If you go to about:config, check if there are any "plugin.state.XXX" entries. If there are, reset them in the context menu. Does that fix it?

If you go to about:config, check if there are any "plugin.state.XXX" entries. If there are, reset them in the context menu. Does that fix it?

Question owner

hi, thanks. the same behaviour. (plugin.state.java = 0) does this icon depends really from java?

I wrote to moz dev, bugzilla, other mozilla forum: it seems that this is a tabù.

no one was able to tell me how to disable this new feature (and they are professional people regarding firefox things) very strange, I am worried. therefore I guess that its compulsory to mantain this strange behaviour: new icon in url bar, if you watch youtube, the window tells "allow or deny flash?" (but if I watch youtube its understable that I want to get flash running!!), the same with silverlight, and one additional click for watching a pdf (as said, with this feature I have to reload the pdf page).

Are other users (with noscript) happy with this new feature?

hi, thanks. the same behaviour. (plugin.state.java = 0) does this icon depends really from java? I wrote to moz dev, bugzilla, other mozilla forum: it seems that this is a tabù. no one was able to tell me how to disable this new feature (and they are professional people regarding firefox things) very strange, I am worried. therefore I guess that its compulsory to mantain this strange behaviour: new icon in url bar, if you watch youtube, the window tells "allow or deny flash?" (but if I watch youtube its understable that I want to get flash running!!), the same with silverlight, and one additional click for watching a pdf (as said, with this feature I have to reload the pdf page). Are other users (with noscript) happy with this new feature?

Question owner

did you install in the meantime some plugin, like flash?

did you install in the meantime some plugin, like flash?
Waka_Flocka_Flame 441 solutions 5048 answers

"I wrote to moz dev, bugzilla, other mozilla forum: it seems that this is a tabù."

Could you link to those?

"I wrote to moz dev, bugzilla, other mozilla forum: it seems that this is a tabù." Could you link to those?

Question owner

i wrote via PM, because I know some of them since years. but I linked them this 3d.

and you? did you install in the meantime some plugin, like flash?

i wrote via PM, because I know some of them since years. but I linked them this 3d. and you? did you install in the meantime some plugin, like flash?

Modified by anuswara

Waka_Flocka_Flame 441 solutions 5048 answers

Installing flash now on my system, didnt have very much time to deal with Adobe.

Installing flash now on my system, didnt have very much time to deal with Adobe.
philipp
  • Top 10 Contributor
  • Moderator
2928 solutions 13676 answers

is it just the presence of the plugin indicator that is bugging you? that's just providing a quick way to enable/disable plugin content running on the page & should do no harm...

is it just the presence of the plugin indicator that is bugging you? that's just providing a quick way to enable/disable plugin content running on the page & should do no harm...

Question owner

You will need one additional click for pdf.

this not tremendous, but I dont understand the reason for this feature, very annoying. perhaps mozilla want that we refuse using noscript.

hmmm if an italian dev of firefox did not eply to me, this means that its very hard the question. hopeless I thinks. otherwise he resolve all the question, even the hardest.

You will need one additional click for pdf. this not tremendous, but I dont understand the reason for this feature, very annoying. perhaps mozilla want that we refuse using noscript. hmmm if an italian dev of firefox did not eply to me, this means that its very hard the question. hopeless I thinks. otherwise he resolve all the question, even the hardest.

Modified by anuswara

Question owner

philipp:

"is it just the presence of the plugin indicator that is bugging you? "

my desire is to eradicate this indicator because it doesnt work fine with noscript. and because for me its unuseful and very annoying.

the bad: for the first time noscript developer did not reply.

philipp: "is it just the presence of the plugin indicator that is bugging you? " my desire is to eradicate this indicator because it doesnt work fine with noscript. and because for me its unuseful and very annoying. the bad: for the first time noscript developer did not reply.

Modified by anuswara

Question owner

"that's just providing a quick way to enable/disable plugin content running on the page & should do no harm... "

should I unistall noscript? an example: noscript abe tab: deny always flash, except flash from youtube.com. this is fine.


also noscript is more powerful than mozilla plugin indicator... I dont understand why on my pc I am allowed to fill free to disable click to play (or dxva acceleration...) but I am not allowed to disable plugin indicator, this is a "philosophical" question  ;)

"that's just providing a quick way to enable/disable plugin content running on the page & should do no harm... " should I unistall noscript? an example: noscript abe tab: deny always flash, except flash from youtube.com. this is fine. also noscript is more powerful than mozilla plugin indicator... I dont understand why on my pc I am allowed to fill free to disable click to play (or dxva acceleration...) but I am not allowed to disable plugin indicator, this is a "philosophical" question ;)

Modified by anuswara

Question owner

"hello, in the current stable release where plugins.click_to_play is set to false this should only be happening for outdated/vulnerable plugins"

is set to false. this happens with acrobat reader plugin 11.0.4 too, and flash ....800.168.

"hello, in the current stable release where plugins.click_to_play is set to false this should only be happening for outdated/vulnerable plugins" is set to false. this happens with acrobat reader plugin 11.0.4 too, and flash ....800.168.
philipp
  • Top 10 Contributor
  • Moderator
2928 solutions 13676 answers

just to be sure what is happening - do you just see the indicator (which is the new default now) or the expanded" doorhanger" panel and do plugins run without any further interaction?

just to be sure what is happening - do you just see the indicator (which is the new default now) or the expanded" doorhanger" panel and do plugins run without any further interaction?

Question owner

finally, another philosophic question: I dont understand why I have to install additional addons to get the ff23 behaviour...adding addons to adjust the choice of moz dev. addons are good but bad too: continuing adding addons the startup becomes slow. if you consider that ff (9tabs, default theme) need 4-4,5 seconds on the first startup.

finally, another philosophic question: I dont understand why I have to install additional addons to get the ff23 behaviour...adding addons to adjust the choice of moz dev. addons are good but bad too: continuing adding addons the startup becomes slow. if you consider that ff (9tabs, default theme) need 4-4,5 seconds on the first startup.