X
Tap here to go to the mobile version of the site.

Support Forum

pdf save file open file

Posted

Since firefox just recently updated, .pdf files when clicked, either on email or the web would pop open a box that says save file or open file. Firefox updated and it no longer ask this anymore, it just immediately tries to download it. I don't use any .pdf add on through Firefox, I tried one today but it still doesn't help. Is there a way to turn this basic function back on without a add-on. It has never needed one before.

Thanks.

Since firefox just recently updated, .pdf files when clicked, either on email or the web would pop open a box that says save file or open file. Firefox updated and it no longer ask this anymore, it just immediately tries to download it. I don't use any .pdf add on through Firefox, I tried one today but it still doesn't help. Is there a way to turn this basic function back on without a add-on. It has never needed one before. Thanks.

Chosen solution

Hi Matt, sometimes the application preferences end up with multiple entries, some under "Adobe Acrobat..." and one under "Portable Document Format (PDF)".

If you've fiddled with all of those without success, the settings file that stores these associations might have become corrupted. You can rename or delete it and have Firefox regenerate it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to "Always Ask".

Any improvement?

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • GEPlugin
  • 5.1.20513.0
  • IE Tab plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Garmin Communicator Plug-In 4.0.4.0
  • iTunes Detector Plug-in
  • NPWLPG
  • DivX VOD Helper Plug-in
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • CANON iMAGE GATEWAY Mycamera Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.46

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Nellus 68 solutions 634 answers
Try to [[Set how Firefox handles different types of files]]

Question owner

I did try that, and I tried changing it to every option they offered for .pdf's and they all operate/act the same when clicked.

Matt

I did try that, and I tried changing it to every option they offered for .pdf's and they all operate/act the same when clicked. Matt
jscher2000
  • Top 10 Contributor
3747 solutions 33251 answers

Chosen Solution

Hi Matt, sometimes the application preferences end up with multiple entries, some under "Adobe Acrobat..." and one under "Portable Document Format (PDF)".

If you've fiddled with all of those without success, the settings file that stores these associations might have become corrupted. You can rename or delete it and have Firefox regenerate it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to "Always Ask".

Any improvement?

Hi Matt, sometimes the application preferences end up with multiple entries, some under "Adobe Acrobat..." and one under "Portable Document Format (PDF)". If you've fiddled with all of those without success, the settings file that stores these associations might have become corrupted. You can rename or delete it and have Firefox regenerate it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show Folder" button Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit) Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to "Always Ask". Any improvement?

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
12895 solutions 118296 answers

Try to check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

Try to check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu. *http://kb.mozillazine.org/about:config

Helpful Reply

I was making all the changes to the Adobe Acrobat files and didn't see the one lower down called portable document format, once I changed it to ask first it now operates how it should. Thanks for the help everyone.

Matt

I was making all the changes to the Adobe Acrobat files and didn't see the one lower down called portable document format, once I changed it to ask first it now operates how it should. Thanks for the help everyone. Matt