X
Tap here to go to the mobile version of the site.

Support Forum

Firefox horribly slow loading the first time

Posted

this has been going on for a while and i am considering the previously unthinkable and switching to Chrome, i don't want to but waiting five minutes for firefox to open is getting on my last never. the thing is, it only is this slow the first time. after that it is fast as usual. i have tried disabling all addons and plug ins, nothing works. as i said, it only does this when i try to open it up first thing in the morning after booting up the computer. i have a fast computer too, an intel i7 3770 processor and 16 gigs of ram so that is not an issue. i am running windows 8 by the way. i click on the firefox icon and it does nothing for at least a few minutes, then opens. very frustrating. also, i have disabled prefetch as well, no good. attached are screenshots of my addons and plug ins. yes, i have uninstalled it completely and reinstalled, no luck.

this has been going on for a while and i am considering the previously unthinkable and switching to Chrome, i don't want to but waiting five minutes for firefox to open is getting on my last never. the thing is, it only is this slow the first time. after that it is fast as usual. i have tried disabling all addons and plug ins, nothing works. as i said, it only does this when i try to open it up first thing in the morning after booting up the computer. i have a fast computer too, an intel i7 3770 processor and 16 gigs of ram so that is not an issue. i am running windows 8 by the way. i click on the firefox icon and it does nothing for at least a few minutes, then opens. very frustrating. also, i have disabled prefetch as well, no good. attached are screenshots of my addons and plug ins. yes, i have uninstalled it completely and reinstalled, no luck.

Modified by Historywriter

Additional System Details

Installed Plug-ins

  • Bitdefender QuickScan Web Netscape Plugin
  • Shockwave Flash 11.8 r800

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

eyzi 0 solutions 1 answers

It might be the case that firefox waits for a windows service to start on and then starts itself. Usually when a service in windows starts, it takes a while to load for the first time and after that whenever you apply for that service it'll be much faster since the service is still there ready.

I saw this problem on my brother's laptop but I couldn't fix it anyway.

I suggest you reboot your computer then without doing anything just open firefox. After that go to windows services and look for services that are manual and started and make them all automatic start. Then reset your computer and see if there would be any change. I hope it works :)

It might be the case that firefox waits for a windows service to start on and then starts itself. Usually when a service in windows starts, it takes a while to load for the first time and after that whenever you apply for that service it'll be much faster since the service is still there ready. I saw this problem on my brother's laptop but I couldn't fix it anyway. I suggest you reboot your computer then without doing anything just open firefox. After that go to windows services and look for services that are manual and started and make them all automatic start. Then reset your computer and see if there would be any change. I hope it works :)

Modified by eyzi

greekgeek1977 0 solutions 1 answers

I just started experiencing this problem a few days ago and just realized today, for me, where it stemmed from. Recently my firewall was enabled (this was only happening with Firefox on my work laptop since they pushed through a new policy enabling the firewall) and that's what was holding up Firefox. I went into the windows firewall and allowed Firefox through. For those of you not sure how to do this, follow these steps: 1. Start -> Control Panel -> Windows Firewall (if you don't see firewall, in the top right corner change your view from category to icon.) 2. Top left, click "Allow a program or feature..." 3. If the "Allow another program..." button is greyed out at the bottom, in the top right click "Change Settings" and it should be clickable now. 4. Find Firefox in the list and add it (or browse to the executable if it's not; should be there though!) 5. Click OK and you should be good from there.

This may or may not work for everyone, but for me it solved a VERY annoying problem.

- J.J.

I just started experiencing this problem a few days ago and just realized today, for me, where it stemmed from. Recently my firewall was enabled (this was only happening with Firefox on my work laptop since they pushed through a new policy enabling the firewall) and that's what was holding up Firefox. I went into the windows firewall and allowed Firefox through. For those of you not sure how to do this, follow these steps: 1. Start -> Control Panel -> Windows Firewall (if you don't see firewall, in the top right corner change your view from category to icon.) 2. Top left, click "Allow a program or feature..." 3. If the "Allow another program..." button is greyed out at the bottom, in the top right click "Change Settings" and it should be clickable now. 4. Find Firefox in the list and add it (or browse to the executable if it's not; should be there though!) 5. Click OK and you should be good from there. This may or may not work for everyone, but for me it solved a VERY annoying problem. - J.J.
Jgor01 0 solutions 7 answers

The last couple of Firefox updates have really downgraded performance. When I click a website, the circle just keeps spinning until I click stop and then reload, at which point the site loads. Turning off add-ons didn't help. Tweaking with FasterFox helps for a short while, then the behavior returns. It's gotten so bad in 27.0.1 that at times I've loaded Chrome, clicked the page I wanted, and finished reading the article before Firefox finally loads the page! I don't like Chrome, but this is disgraceful performance from the one-time leading browser. Judging by the number of others with the same problem, it isn't just my computer, and so far the only response I've seen from Mozilla is archiving threads to stop further comments.

The last couple of Firefox updates have really downgraded performance. When I click a website, the circle just keeps spinning until I click stop and then reload, at which point the site loads. Turning off add-ons didn't help. Tweaking with FasterFox helps for a short while, then the behavior returns. It's gotten so bad in 27.0.1 that at times I've loaded Chrome, clicked the page I wanted, and finished reading the article before Firefox finally loads the page! I don't like Chrome, but this is disgraceful performance from the one-time leading browser. Judging by the number of others with the same problem, it isn't just my computer, and so far the only response I've seen from Mozilla is archiving threads to stop further comments.
Jgor01 0 solutions 7 answers

I looked at this. Mozilla Firefox is checked; Chrome is not, but Chrome has no problem accessing any site and Firefox has to be beaten into submission to load the same pages.

I looked at this. Mozilla Firefox is checked; Chrome is not, but Chrome has no problem accessing any site and Firefox has to be beaten into submission to load the same pages.
Jgor01 0 solutions 7 answers

One more thing - a lot of pages that finally come up are not opening correctly. Many news sites, for instance, now have a long list of links on the left, such as headings and what should be the right-hand sidebar, and the article far down the page. Reloading again (usually fast this time) brings up the page correctly. So two issues - slow loading and incorrectly loading pages. This far into the internet age, these sort of things shouldn't be happening. Chrome doesn't do this. Even worse, Internet Explorer doesn't have these problems either. Firefox may be biting the dust here ....

One more thing - a lot of pages that finally come up are not opening correctly. Many news sites, for instance, now have a long list of links on the left, such as headings and what should be the right-hand sidebar, and the article far down the page. Reloading again (usually fast this time) brings up the page correctly. So two issues - slow loading and incorrectly loading pages. This far into the internet age, these sort of things shouldn't be happening. Chrome doesn't do this. Even worse, Internet Explorer doesn't have these problems either. Firefox may be biting the dust here ....

Modified by Jgor01