X
Tap here to go to the mobile version of the site.

Support Forum

Firefox horribly slow loading the first time

Posted

this has been going on for a while and i am considering the previously unthinkable and switching to Chrome, i don't want to but waiting five minutes for firefox to open is getting on my last never. the thing is, it only is this slow the first time. after that it is fast as usual. i have tried disabling all addons and plug ins, nothing works. as i said, it only does this when i try to open it up first thing in the morning after booting up the computer. i have a fast computer too, an intel i7 3770 processor and 16 gigs of ram so that is not an issue. i am running windows 8 by the way. i click on the firefox icon and it does nothing for at least a few minutes, then opens. very frustrating. also, i have disabled prefetch as well, no good. attached are screenshots of my addons and plug ins. yes, i have uninstalled it completely and reinstalled, no luck.

this has been going on for a while and i am considering the previously unthinkable and switching to Chrome, i don't want to but waiting five minutes for firefox to open is getting on my last never. the thing is, it only is this slow the first time. after that it is fast as usual. i have tried disabling all addons and plug ins, nothing works. as i said, it only does this when i try to open it up first thing in the morning after booting up the computer. i have a fast computer too, an intel i7 3770 processor and 16 gigs of ram so that is not an issue. i am running windows 8 by the way. i click on the firefox icon and it does nothing for at least a few minutes, then opens. very frustrating. also, i have disabled prefetch as well, no good. attached are screenshots of my addons and plug ins. yes, i have uninstalled it completely and reinstalled, no luck.

Modified by Historywriter

Additional System Details

Installed Plug-ins

  • Bitdefender QuickScan Web Netscape Plugin
  • Shockwave Flash 11.8 r800

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Ed 82 solutions 595 answers

Hello,

Please try starting Firefox in Safe Mode and see if that makes a difference. This disables all your add-ons but also makes some other changes to basic Firefox settings:

Troubleshoot Firefox issues using Safe Mode

For your testing purposes the best option will probably be to launch Firefox directly into safe mode by holding down shift as you launch Firefox.

If the problem doesn't occur in Safe Mode then most likely one of your add-ons or a setting is causing the issue. Follow the instructions in the article above to troubleshoot.

If the problem still occurs in Safe Mode then check all of the suggestions in the help article here:

Firefox takes a long time to start up

If none of that helps then I suggest doing a Firefox Reset. This will return Firefox to its basic, default settings. Your personal data (bookmarks etc) will be saved but you will need to reinstall all your add-ons.

Refresh Firefox - reset add-ons and settings

I hope that helps. Let me know if not.

Hello, Please try starting Firefox in Safe Mode and see if that makes a difference. This disables all your add-ons but also makes some other changes to basic Firefox settings: [[Troubleshoot Firefox issues using Safe Mode]] For your testing purposes the best option will probably be to launch Firefox directly into safe mode by holding down shift as you launch Firefox. If the problem doesn't occur in Safe Mode then most likely one of your add-ons or a setting is causing the issue. Follow the instructions in the article above to troubleshoot. If the problem still occurs in Safe Mode then check all of the suggestions in the help article here: [[Firefox takes a long time to start up]] If none of that helps then I suggest doing a Firefox Reset. This will return Firefox to its basic, default settings. Your personal data (bookmarks etc) will be saved but you will need to reinstall all your add-ons. [[Reset Firefox – easily fix most problems]] I hope that helps. Let me know if not.

Helpful Reply

unreal! i disabled ALL plug ins, and removed all ADD ONS and it still took almost two minutes to open. i am at my wits end here!

unreal! i disabled ALL plug ins, and removed all ADD ONS and it still took almost two minutes to open. i am at my wits end here!
kobe 441 solutions 5048 answers

Does disabling hardware acceleration work, seems like doing this decreases startup time, and 2 mins is not how long Firefox should start up (starts in about 6s, looking at FHR).

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Does disabling hardware acceleration work, seems like doing this decreases startup time, and 2 mins is not how long Firefox should start up (starts in about 6s, looking at FHR). You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Question owner

i disabled hardware acceleration, no good, still took as long as ever to open. i am wondering if this possibly could be a windows 8 glitch? i do not recall having this issue on my other computer which is windows 7

i disabled hardware acceleration, no good, still took as long as ever to open. i am wondering if this possibly could be a windows 8 glitch? i do not recall having this issue on my other computer which is windows 7
Ed 82 solutions 595 answers

Have you done a Firefox Reset yet?

Have you done a Firefox Reset yet?
kobe 441 solutions 5048 answers

Not trying to drive you from chrome but I've heard it starts slowly with that too. Can you post a screenshot of the task manager after firefox is clicked and after it has launched.

SOURCES: http://www.pcadvisor.co.uk/how-to/windows/3422276/how-use-windows-8-task-manager/

  • Show the processes tab in the task manager under more information (that is whats vital).

AND: How do I create a screenshot of my problem?

Why I am doing this is because I think there is some junkware involved (comes with computer).

Not trying to drive you from chrome but I've heard it starts slowly with that too. Can you post a screenshot of the task manager after firefox is clicked and after it has launched. SOURCES: http://www.pcadvisor.co.uk/how-to/windows/3422276/how-use-windows-8-task-manager/ * Show the processes tab in the task manager under more information (that is whats vital). AND: [[How do I create a screenshot of my problem?]] Why I am doing this is because I think there is some junkware involved (comes with computer).

Question owner

attached are the screenshots of my task manager processes, Chrome starts up lightning fast, less than 2 seconds usually...

attached are the screenshots of my task manager processes, Chrome starts up lightning fast, less than 2 seconds usually...
kobe 441 solutions 5048 answers

Kinda weird, not a lot of memory being used, so no problems there, have you tried a new profile? as a test?

If the new profile works, I'd suggest if you want to (may corrupt startup again) is to move some from the old profile to the new one.

Kinda weird, not a lot of memory being used, so no problems there, have you tried a new profile? as a test? * [[Use the Profile Manager to create and remove Firefox profiles]] If the new profile works, I'd suggest if you want to (may corrupt startup again) is to move some from the old profile to the new one. * [[Recovering important data from an old profile]]

Question owner

i just did that, deleted the old profile and created a new one. it essentially was the same as a fresh reinstall. no good, still slow. i am using chrome until this is resolved. it opened it 3 seconds flat. its not what i want to do but its better than waiting for firefox to open for an hour

i just did that, deleted the old profile and created a new one. it essentially was the same as a fresh reinstall. no good, still slow. i am using chrome until this is resolved. it opened it 3 seconds flat. its not what i want to do but its better than waiting for firefox to open for an hour
kobe 441 solutions 5048 answers

Can you disable the javascript compiler (IonMonkey) and see if firefox starts faster there.

Disable these two prefs in about:config (type about:config in the adress bar)

  • javascript.options.methodjit.chrome
  • javascript.options.methodjit.content

For help with using about:config, refer to http://kb.mozillazine.org/about:config .

Can you disable the javascript compiler (IonMonkey) and see if firefox starts faster there. Disable these two prefs in about:config (type about:config in the adress bar) * javascript.options.methodjit.chrome * javascript.options.methodjit.content For help with using about:config, refer to http://kb.mozillazine.org/about:config .

Question owner

i went to about:config and neither one of those prefs were in there. there were javascript options but none with those exact descriptions

i went to about:config and neither one of those prefs were in there. there were javascript options but none with those exact descriptions

Question owner

here is what i saw

here is what i saw
kobe 441 solutions 5048 answers

Turn off the ion settings...

Turn off the ion settings...

Question owner

no good. the odd thing is, it only does it after windows has been either shut down or restarted. in other words, the initial startup. if there were an internal issue with FF you think it would be slow all the time.

no good. the odd thing is, it only does it after windows has been either shut down or restarted. in other words, the initial startup. if there were an internal issue with FF you think it would be slow all the time.
kobe 441 solutions 5048 answers

Do you have any programs in the control panel by your computer manufactuer?

can you use the junkware removal tool and see if firefox responds faster.

Do you have any programs in the control panel by your computer manufactuer? can you use the junkware removal tool and see if firefox responds faster. * http://thisisudax.org/
cor-el
  • Top 10 Contributor
  • Moderator
17528 solutions 158483 answers

Make sure that you fully allow Firefox in your security software.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.


It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Make sure that you fully allow Firefox in your security software. Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps. ---- It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls *https://support.mozilla.org/kb/fix-problems-connecting-websites-after-updating
kobe 441 solutions 5048 answers

Safe mode is different in Windows 8 (compared from other versions), and for some reason Microsoft wanted to make it harder to boot into safe mode.

SEE: http://www.howtogeek.com/107511/how-to-boot-into-safe-mode-on-windows-8-the-easy-way/

Safe mode is different in Windows 8 (compared from other versions), and for some reason Microsoft wanted to make it harder to boot into safe mode. SEE: http://www.howtogeek.com/107511/how-to-boot-into-safe-mode-on-windows-8-the-easy-way/
cor-el
  • Top 10 Contributor
  • Moderator
17528 solutions 158483 answers
See also: *http://windows.microsoft.com/en-US/windows-8/windows-startup-settings-including-safe-mode

Helpful Reply

well listen to this! on a hunch i uninstalled Comodo firewall, the latest version 6.3, shut down the computer, started it back up, firefox opened fast as normal. unreal. so i downgraded to Comodo 5.12, which i never had any issues with and firefox is still opening fine. obviously there is some issue with firefox and comodo 6.3. so i am sticking with this version for a while. thanks for all the help

well listen to this! on a hunch i uninstalled Comodo firewall, the latest version 6.3, shut down the computer, started it back up, firefox opened fast as normal. unreal. so i downgraded to Comodo 5.12, which i never had any issues with and firefox is still opening fine. obviously there is some issue with firefox and comodo 6.3. so i am sticking with this version for a while. thanks for all the help
gazzie 0 solutions 7 answers

I am having this exact problem and I am using Windows XP. I have AVG Internet Security and Firewall.

This has suddenly become an issue for me after years of using Firefox. This is my Forum post about the problem. https://support.mozilla.org/en-US/questions/978026

So far it is a complete mystery and nothing I have done makes any difference. I wonder what changed to cause this problem?

What I don't understand is that it is only on initial start up of pc and first click on my Firefox icon, or if I've been logged off the net for a while and then click on again. In all other instances it works fine, and Firefox works normally once I'm online. When I am online and I click on the desktop icon to open a new Firefox window it fires up straight away as it should.

I am having this exact problem and I am using Windows XP. I have AVG Internet Security and Firewall. This has suddenly become an issue for me after years of using Firefox. This is my Forum post about the problem. https://support.mozilla.org/en-US/questions/978026 So far it is a complete mystery and nothing I have done makes any difference. I wonder what changed to cause this problem? What I don't understand is that it is only on initial start up of pc and first click on my Firefox icon, or if I've been logged off the net for a while and then click on again. In all other instances it works fine, and Firefox works normally once I'm online. When I am online and I click on the desktop icon to open a new Firefox window it fires up straight away as it should.