X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox does not play any Flash even with the latest Flash installed

Posted

Hello,

My firefox cannot play any Flash for months.

Here are the issues: 1. If i want to watch videos on Youtube, it just turns out black (clicking on the video can trigger the pause icon though). 2. If i want to watch some website with Flash, it just loads the first 2 secs and then the Flash freezes.

I have read all the help information in the forum and tried many solutions (see below) but none of them worked:

- Uninstall and reinstall Firefox - Uninstall and reinstall Flash:

      1) when entered Youtube without Flash installed, the website asked me to install Flash but it somehow ended to a failure so I had to manually download and install
      2) after installing Flash, I also went to: http://www.adobe.com/software/flash/about/. I can see the version info but not the animation of the banner - it just shows a red box and then disappears after a few secs.

- Reset Firefox - Use the browser safe mode - Install the latest Realplayer - Scan the plugin status on the website: http://www.mozilla.org/en-US/plugincheck/ - Turn off the hardware acceleration in the Advanced option - Regenerate the "pluginreg.dat" file

I am using WIn 7 (64 bits), with Firefox 24.0 and Flash11_8_800_168. I have spent too much time on this issue and now I am using Chrome to watch the video.

Hope this can be solved with your help.

Thanks! -Jeffery

Chosen solution

Hi Jeffery, I am not familiar with many of your plugins. In case one of them could be affecting Flash content, could you disable any that you do not use on a regular basis? (Set to "Never Activate")

orange Firefox button (or Tools menu) > Add-ons > Plugins category

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • npalidcp
  • Alipay Security Control
  • Google Update
  • GEPlugin
  • 5.1.20513.0
  • npaliedit
  • QQ QuickLogin Helper
  • iTunes Detector Plug-in
  • Picasa plugin
  • QQ2013 Firefox Plugin
  • QQ2013 Chrome Plugin for Chrome V23.0.1271.64 or latest version
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 4.0.1f2
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • npwangwang
  • npAliSSOLogin Plugin
  • QQMusic
  • China Merchants Bank Edit
  • npalicdo
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom)
  • Firebug 1.12.1 (firebug@software.joehewitt.com)
  • FireGestures 1.7.12 (firegestures@xuldev.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Youdao Word Capturer 1.81 (dict@www.youdao.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 460
  • adapterDescription2:
  • adapterDeviceID: 0x0e22
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1023
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7600.16972
  • driverDate: 2-9-2013
  • driverDate2:
  • driverVersion: 9.18.13.1407
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379926019
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 2
  • plugin.state.npdeployjava: 0
  • plugin.state.npmmrwebplugin: 0
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0

Misc

  • User JS: No
  • Accessibility: Yes
HTML5Shark 0 solutions 5 answers

Helpful Reply

What hardware are you on? Flash is always a finicky beast, especially on older hardware. This is not an entirely uncommon problem. Try looking at this support article and see if that helps.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi Jeffery, it sounds as though you're halfway through my list of standard approaches to Flash problems.

(1) If you use any recorders/downloaders that interact with Flash media (either external software or Firefox add-ons), make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox -- un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash -- see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Question owner

Thank you for the suggestions. I have tried all of them but still not working :(

By the way, the Flash menu always appears in the right bottom when I tried to open it (see attached picture).

I cannot either enter the setting in Flash. I can right click to trigger the Flash menu but after clicking "Setting" it does nothing. The "Global Setting" can be opened somehow.

Question owner

I doubt but here are the specs:

CPU: Intel(R) Xeon(R) W3550 @3.07GHz Graphic Card: NIVIDIA GeForce GTX 460 (with the up-to-date driver) RAM: 8.00 GB

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

Did you disable hardware acceleration in Firefox and in the Flash plugin (you need to close and restart Firefox)?

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Chosen Solution

Hi Jeffery, I am not familiar with many of your plugins. In case one of them could be affecting Flash content, could you disable any that you do not use on a regular basis? (Set to "Never Activate")

orange Firefox button (or Tools menu) > Add-ons > Plugins category

Question owner

Hi, I disabled a few plugins and it did work! Now I can play all the Flash!

The wired part is when I activated all the plugins, Firefox can still play Flash, so I don't know which one caused the problem.

Anyways, I appreciate your help. I can finally use Firefox after months.

Cheers!