X
Tap here to go to the mobile version of the site.

Support Forum

How can I type in a http: address instead of doing a search with the search engine in the address bar?

Posted

I tried to do as this website suggested to change the preferences, but because the search engines were turned on I didn't get the Mozilla Firefox preferences page as I was supposed to. Instead I got googles or wikapedias articles on it. How can I turn this feature off so I can manually enter a http:// address/URL without using a stupid search engine. Sometimes I like that I can use google so easily, but other times I just need to be able to go to a site.

I tried to do as this website suggested to change the preferences, but because the search engines were turned on I didn't get the Mozilla Firefox preferences page as I was supposed to. Instead I got googles or wikapedias articles on it. How can I turn this feature off so I can manually enter a http:// address/URL without using a stupid search engine. Sometimes I like that I can use google so easily, but other times I just need to be able to go to a site.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Exent's browser plugin
  • Google Update
  • GEPlugin
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • McAfee MSS+ NPAPI Plugin
  • Amazon MP3 Downloader Plugin 1.0.17
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Exent® AOD Gecko Plugin

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • avast! Online Security 8.0.1497 (wrc@avast.com)
  • Awesome screenshot: Capture and Annotate 2.4.0.1 (jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack)
  • Easy YouTube Video Downloader 7.0 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • Ghostery 5.0.4 (firefox@ghostery.com)
  • Pocket 3.0.4 (isreaditlater@ideashower.com)
  • PopVideo 0.6.8 (lmnPopVideo@lshai.com)
  • Self-Destructing Cookies 0.4.1 (jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Video Downloader professional 1.97.18 (ffext_basicvideoext@startpage24)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-27-2011
  • driverDate2:
  • driverVersion: 8.15.10.2291
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.search.suggest.enabled: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379882134
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1377356588

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
3275 solutions 29866 answers

What's supposed to happen is:

Firefox will check whether your address bar entry has spaces. If it has spaces, it will automatically be run as a search. If it doesn't have spaces, it will be tried as a URL first. If the URL is not found, then you might get search results as a backup.

So, for example, about:config can't have any spaces.

But.. if you find that even a short URL like abc.com gives you search results, we'll have to dig deeper and see why. One thing to try would be Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

What's supposed to happen is: Firefox will check whether your address bar entry has spaces. If it has spaces, it will automatically be run as a search. If it doesn't have spaces, it will be tried as a URL first. If the URL is not found, then you might get search results as a backup. So, for example, '''about:config''' can't have any spaces. But.. if you find that even a short URL like abc.com gives you search results, we'll have to dig deeper and see why. One thing to try would be Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?

Question owner

Thanks. I got the popup that said "you could void your warranty" so I guess I can get to the about:config in Safe Mode. However, I did try the abc.com and just typing in about:config again in regular Firefox mode before I did the Safe Mode and it gave search results. I guess for some reason it thinks that there is a space when there isn't. Anyway to get this to work the way it is supposed to so I don't have to completely turn the searching function off? It's just annoying when I need to go directly to a URL because it keeps sending me to the search terms pages.

Thanks. I got the popup that said "you could void your warranty" so I guess I can get to the about:config in Safe Mode. However, I did try the abc.com and just typing in about:config again in regular Firefox mode before I did the Safe Mode and it gave search results. I guess for some reason it thinks that there is a space when there isn't. Anyway to get this to work the way it is supposed to so I don't have to completely turn the searching function off? It's just annoying when I need to go directly to a URL because it keeps sending me to the search terms pages.
jscher2000
  • Top 10 Contributor
3275 solutions 29866 answers

To turn off address bar search, disable the "keyword" service using the steps in this article: Search the web from the Address Bar (section entitled"Turning off the web search in the address bar"). Does that fix it?

To turn off address bar search, disable the "keyword" service using the steps in this article: [[Search the web from the Address Bar]] (section entitled"Turning off the web search in the address bar"). Does that fix it?

Helpful Reply

I tried to trouble shoot to see if it was some of my customization of Firefox that did it. Regardless if I go through and disable all my extensions, change my theme back to the default, it still gives search terms even when I type in a URL without spaces. I did try what was suggested in the article you referenced. I changed my preferences in safe mode and then exited and tried it. It still gave search terms so that didn't fix the problem. I'm wondering if this is some kind of setting on my Toshiba laptop because it does this for Google Chrome and Internet Explorer as well. Any other ideas?

I tried to trouble shoot to see if it was some of my customization of Firefox that did it. Regardless if I go through and disable all my extensions, change my theme back to the default, it still gives search terms even when I type in a URL without spaces. I did try what was suggested in the article you referenced. I changed my preferences in safe mode and then exited and tried it. It still gave search terms so that didn't fix the problem. I'm wondering if this is some kind of setting on my Toshiba laptop because it does this for Google Chrome and Internet Explorer as well. Any other ideas?
jscher2000
  • Top 10 Contributor
3275 solutions 29866 answers

When Firefox checks with your DNS provider whether an address is valid the DNS provider can dishonestly redirect Firefox to the site of its choice. You might consider changing from your current DNS provider (possibly your ISP?) to another one. Some free ones are OpenDNS and Google Public DNS.

However, first it's worth checking whether your ISP allows you to turn off this feature (some do, or at least say they do) and check whether this is actually your ISP's search results or possibly some malware/spyware that needs to be removed.

When Firefox checks with your DNS provider whether an address is valid the DNS provider can dishonestly redirect Firefox to the site of its choice. You might consider changing from your current DNS provider (possibly your ISP?) to another one. Some free ones are OpenDNS and Google Public DNS. However, first it's worth checking whether your ISP allows you to turn off this feature (some do, or at least say they do) and check whether this is actually your ISP's search results or possibly some malware/spyware that needs to be removed.

Modified by jscher2000

Helpful Reply

The ISP/DNS doesn't seem like the problem. My husband's laptop shares the same network and internet provider as my computer. His has never had this issue on Firefox, Chrome, or Internet Explorer....any browser. I will do a malware/spyware check asap to see if this fixes it.

The ISP/DNS doesn't seem like the problem. My husband's laptop shares the same network and internet provider as my computer. His has never had this issue on Firefox, Chrome, or Internet Explorer....any browser. I will do a malware/spyware check asap to see if this fixes it.