X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Hulu.com can't load Javascript in Firefox 24

Posted

It seems Javascript doesn't want to work on Hulu.com anymore. The site gives me an error saying Javascript is not enabled but it is. It worked fine last night and I haven't changed anything. I have tried many things to fix this: Disabling add-ons and plugins then turning them on one at a time after restarting, cleaned my cache and restarting, updating java, and checked about:config for javascript.enabled.

Chromo can play videos on Hulu.com but it's slow on buffing. So it's very annoying.

Please help.

Chosen solution

First I wanted to thank both of you for helping me out. I just turned my computer on today and Hulu is now works fine. So it might have been a simple restart of my computer. Still very weird that I even ran into the problem in the first place.

@ComputerWhiz - I marked you last suggestion as helpful because that is still good information to know.

Thank you both again.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • Shockwave Flash 11.8 r800
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • Google Update
  • GEPlugin
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! WebRep 8.0.1482 (wrc@avast.com)
  • InboxDollars 1.300.436.1 ({771f3037-9885-4423-b50f-a5ede4854e26})
  • NoScript 2.6.7.1 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Session Manager 0.8.0.8 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Contribute Toolbar 6.0 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)
  • Ask Toolbar 21.51433 (toolbar_ORJ-V7@apn.ask.com) (Inactive)
  • DVDVideoSoft YouTube MP3 and Video Download 4.2.1.9 ({ACAA314B-EEBA-48e4-AD47-84E31C44796C}) (Inactive)
  • Imageshack-Clickberry Browser Extension 1.0.16 (jid1-MA2AfbgHyjJd9g@jetpack) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • RealPlayer Browser Record Plugin 15.0.0 ({ABDE892B-13A8-4d1b-88E6-365A6E755758}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-30-2013
  • driverDate2:
  • driverVersion: 8.15.10.2993
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • accessibility.typeaheadfind.flashbar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.places.importbookmarkshtml: False
  • browser.places.importdefaults: False
  • browser.places.leftpanefolderid: -1
  • browser.places.migratepostdataannotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.smartbookmarksversion: 1
  • browser.places.updaterecenttagsuri: False
  • browser.search.param.yahoo-fr: chrf-ytbm
  • browser.search.param.yahoo-fr-cjkt: chrf-ytbm
  • browser.search.param.yahoo-type: ${8}
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://cm.my.yahoo.com/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: False
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379560679
  • places.history.expiration.transient_current_max_pages: 98743
  • places.last_vacuum: 1330545753
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 2
  • plugin.state.java: 2
  • plugin.state.np32dsw: 2
  • plugin.state.npauthz: 2
  • plugin.state.npctrl: 2
  • plugin.state.npdeployjava: 0
  • plugin.state.npezkeytecplugin: 0
  • plugin.state.npezkeytecplugins: 0
  • plugin.state.npgeplugin: 2
  • plugin.state.npgoogleupdate: 2
  • plugin.state.npitunes: 2
  • plugin.state.nppdf: 2
  • plugin.state.nppl: 0
  • plugin.state.npqtplugin: 2
  • plugin.state.nprjplug: 0
  • plugin.state.nprpchromebrowserrecordext: 0
  • plugin.state.nprphtml5videoshim: 0
  • plugin.state.nprpjplug: 0
  • plugin.state.npspwrap: 2
  • plugin.state.npwatweb: 2
  • plugin.state.npwlpg: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.extensions-sessionmanager: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1377639531

Misc

  • User JS: Yes
  • Accessibility: No
Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Helpful Reply

Try disabling hardware acceleration.

Unfortunately, I do not live in the United States and cannot try the site myself.

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Helpful Reply

@ComputerWhiz - I tried that but my Intel Graphics won't allow me to change the setting to disable hardware acceleration.

@cor-el - I actually did that before posting but it didn't work.

cor-el
  • Top 10 Contributor
  • Moderator
10759 solutions 96838 answers

Is this with a normal http connection or with a secure https connection?

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.

Question owner

It's with a normal http connection.

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Did you try disabling hardware acceleration using this method?

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Please report back soon.

Chosen Solution

First I wanted to thank both of you for helping me out. I just turned my computer on today and Hulu is now works fine. So it might have been a simple restart of my computer. Still very weird that I even ran into the problem in the first place.

@ComputerWhiz - I marked you last suggestion as helpful because that is still good information to know.

Thank you both again.

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Maybe it was because you restarted your computer or maybe it was a simple website server issue.

Oh well! As long as your problem is fixed, I am happy.