X
Tap here to go to the mobile version of the site.

Support Forum

On open the cursor does not automaticaly go to the search box ?

Posted

When Mozilla Firefox is opened I would have expected the cursor to be in the search box by default. It does not ant therefore it has to be located in the box before you can start entering search criteria.

When Mozilla Firefox is opened I would have expected the cursor to be in the search box by default. It does not ant therefore it has to be located in the box before you can start entering search criteria.

Chosen solution

I tried Resetting Firefox and it seems to have fixed the problem.

I will continue using it and see how it goes.

Many thanks Barry Stow

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Picasa plugin
  • Windows Activation Technologies Plugin for Mozilla
  • Nitro PDF plugin for Firefox and Chrome
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

jscher2000
  • Top 10 Contributor
8689 solutions 71031 answers

Are you using the "built-in" home page (about:home) or a search engine page on the web?

Does the same problem occur when you launch a new window using Ctrl+n (or Ctrl+Shift+p for a private window) or does it only occur at initial startup?

Could you test what happens in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Are you using the "built-in" home page (about:home) or a search engine page on the web? Does the same problem occur when you launch a new window using Ctrl+n (or Ctrl+Shift+p for a private window) or does it only occur at initial startup? Could you test what happens in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?

Question owner

Hi jsher,

Are you using the "built-in" home page (about:home) or a search engine page on the web? Answer Home Page and Google

Does the same problem occur when you launch a new window using Ctrl+n (or Ctrl+Shift+p for a private window) or does it only occur at initial startup? Answer Only at Startup

Could you test what happens in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (not Reset) Any difference?

Answer Starts Ok with cursor in search Box

Hi jsher, Are you using the "built-in" home page (about:home) or a search engine page on the web? Answer Home Page and Google Does the same problem occur when you launch a new window using Ctrl+n (or Ctrl+Shift+p for a private window) or does it only occur at initial startup? Answer Only at Startup Could you test what happens in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (not Reset) Any difference? Answer Starts Ok with cursor in search Box
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Helpful Reply

Did all this but it had no effect on the problem? B

Did all this but it had no effect on the problem? B
jscher2000
  • Top 10 Contributor
8689 solutions 71031 answers

Hi Barry, what element has the focus when this happens? You can use the Tab key and Shift+Tab to move focus from one element to the next in forward or reverse order. If the focus is on the page as a whole, you will see a dotted selection outline move among the links, form controls, and buttons. If it is in the address bar, you will see the vertical text cursor appear in the address bar and search bar before moving to the page.

Hi Barry, what element has the focus when this happens? You can use the Tab key and Shift+Tab to move focus from one element to the next in forward or reverse order. If the focus is on the page as a whole, you will see a dotted selection outline move among the links, form controls, and buttons. If it is in the address bar, you will see the vertical text cursor appear in the address bar and search bar before moving to the page.

Question owner

The Cursor appears in the search box when Firefox is opened but the box will not accept any typing. Tapping the Tab Key does not do anything, Alt and Tab moves the focus to the Search button. Moving the Focus back to the Search box enables data entry?

Barry Stow

The Cursor appears in the search box when Firefox is opened but the box will not accept any typing. Tapping the Tab Key does not do anything, Alt and Tab moves the focus to the Search button. Moving the Focus back to the Search box enables data entry? Barry Stow
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

So, it does work correctly in Firefox Safe Mode?

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • default toolbar layout is used (localstore-safe.rdf)
  • Javascript JIT compilers are disabled (javascript.options.*jit)
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
So, it does work correctly in Firefox Safe Mode? In Firefox Safe mode these changes are effective: *all extensions are disabled *default theme is used (no persona) *userChrome.css and userContent.css are ignored *default toolbar layout is used (localstore-safe.rdf) *Javascript JIT compilers are disabled (javascript.options.*jit) *hardware acceleration is disabled *plugins are not affected *preferences are not affected *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

It seems to be Ok when in safe mode.

Why am I having this problem all of a sudden, is it a glitch in the latest version of Firefox?

B

It seems to be Ok when in safe mode. Why am I having this problem all of a sudden, is it a glitch in the latest version of Firefox? B
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

Try to disable hardware acceleration in Firefox.


If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ----- If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

I have completed all the suggestions but the problem remains???

I have completed all the suggestions but the problem remains???
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

Try to disable hardware acceleration in Firefox.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
Mikenator 0 solutions 4 answers

I have exactly the same thing. The focus is in the search box but the problem is that after launcing Firefox the whole browser window loses focus and the focus goes to desktop.

Im using windows 7 32 bit & FF 26.0

I have exactly the same thing. The focus is in the search box but the problem is that after launcing Firefox the whole browser window loses focus and the focus goes to desktop. Im using windows 7 32 bit & FF 26.0
jscher2000
  • Top 10 Contributor
8689 solutions 71031 answers

Hi Mikenator, are you using the built-in Firefox home page, or the main Google home page, or the old Google/Firefox home page, or some different home page?

Did you get a chance to work through the various suggestions in the posts above yours?

Hi Mikenator, are you using the built-in Firefox home page, or the main Google home page, or the old Google/Firefox home page, or some different home page? Did you get a chance to work through the various suggestions in the posts above yours?
Mikenator 0 solutions 4 answers

Im new to Firefox, im using it for 1 week now. I have the default homepage that was there after installing. Its called Mozilla Firefox with in the bottom of the page various Firefox options and in the middle a google search engine.

However i dont think it matters which page i have as homepage. The problem is that the whole browser loses focus after launch.

I didnt follow all your steps yet. I did disable "Use hardware acceleration when available". I will try the other options you mentioned.

Im new to Firefox, im using it for 1 week now. I have the default homepage that was there after installing. Its called Mozilla Firefox with in the bottom of the page various Firefox options and in the middle a google search engine. However i dont think it matters which page i have as homepage. The problem is that the whole browser loses focus after launch. I didnt follow all your steps yet. I did disable "Use hardware acceleration when available". I will try the other options you mentioned.
Mikenator 0 solutions 4 answers

I found my problem. Im using ZoneAlarm and have to allow Firefox to use internet. After the Zonealarm message Firefox doesnt get focus back. Other programs that i use do get focus back after the Zonealarm message.

I found my problem. Im using ZoneAlarm and have to allow Firefox to use internet. After the Zonealarm message Firefox doesnt get focus back. Other programs that i use do get focus back after the Zonealarm message.
jscher2000
  • Top 10 Contributor
8689 solutions 71031 answers

Hi Mikenator, hopefully ZoneAlarm remembers your choice until the next time you update the program. If it asks every time you exit and restart Firefox, that seems dysfunctional, or maybe it is monitoring settings files???

Hi Mikenator, hopefully ZoneAlarm remembers your choice until the next time you update the program. If it asks every time you exit and restart Firefox, that seems dysfunctional, or maybe it is monitoring settings files???

Question owner

I have tried the solutions offered (thanks) to no effect.

I have noticed that now the cursor appears in a "search box" in the Toolbar??

I have tried the solutions offered (thanks) to no effect. I have noticed that now the cursor appears in a "search box" in the Toolbar??
Mikenator 0 solutions 4 answers

@jscher2000 I have ZoneAlarm setup that i have to manualy allow acces for some programmes. I did add Firefox to the allowlist now and the problem is gone. However i havent seen this behavior with other programs yet. Other programs that i use do get focus after i give manualy acces.

@BarryStow Is your problem maybe similar where the browser lost focus? When i read your comment from 30 sept 2013 then you say that the cursor is on the search box but it doesnt accept typing or tabbing. Only alt-tab does do something which gives the focus back to the browser.

@jscher2000 I have ZoneAlarm setup that i have to manualy allow acces for some programmes. I did add Firefox to the allowlist now and the problem is gone. However i havent seen this behavior with other programs yet. Other programs that i use do get focus after i give manualy acces. @BarryStow Is your problem maybe similar where the browser lost focus? When i read your comment from 30 sept 2013 then you say that the cursor is on the search box but it doesnt accept typing or tabbing. Only alt-tab does do something which gives the focus back to the browser.
jscher2000
  • Top 10 Contributor
8689 solutions 71031 answers

Hi BarryStow, if you are opening a blank page or a new tab, the cursor may appear in the address bar. I can't think of a reason for the cursor to automatically go to the search bar, or even a different search box in the toolbar area.

You mentioned that Firefox behaves normally in Safe Mode, so that suggests that one of your extensions could be modifying Firefox's behavior. I think it's time to take a hard look and disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable. Beware of innocuous sounding extensions such as "Default Tab" which, if I remember correctly, sticks its own search box on the tab bar and might also make other changes to how search works.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that restore the normal behavior?

Hi BarryStow, if you are opening a blank page or a new tab, the cursor may appear in the address bar. I can't think of a reason for the cursor to automatically go to the search bar, or even a different search box in the toolbar area. You mentioned that Firefox behaves normally in Safe Mode, so that suggests that one of your extensions could be modifying Firefox's behavior. I think it's time to take a hard look and disable ALL nonessential or unrecognized extensions on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions. Then, if in doubt, disable. Beware of innocuous sounding extensions such as "Default Tab" which, if I remember correctly, sticks its own search box on the tab bar and might also make other changes to how search works. Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Does that restore the normal behavior?

Question owner

I have tried all the suggestions to my questions without success.

In summary when I commence typing a 'question' in the Google screen I am immediately taken to the address Bar to complete it and the Google 'screen' disappears. Google works normally from there??

BS Melbourne, Australia

I have tried all the suggestions to my questions without success. In summary when I commence typing a 'question' in the Google screen I am immediately taken to the address Bar to complete it and the Google 'screen' disappears. Google works normally from there?? BS Melbourne, Australia