X
Tap here to go to the mobile version of the site.

Support Forum

how can i force a login password save

Posted

When I log into some sites, FF doesn't ask to save the password even though there is no entry for the site I'm logging in to.......

When I log into some sites, FF doesn't ask to save the password even though there is no entry for the site I'm logging in to.......

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • GEPlugin
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • ColorfulTabs 19.7 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • Configuration Mania 1.17.2013082001 ({c4d362ec-1cff-4ca0-9031-99a8fad7995a})
  • FireFTP 2.0.16 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • IE Tab 2 (FF 3.6+) 4.12.22.2 ({1BC9BA34-1EED-42ca-A505-6D2F1A935BBB})
  • NoScript 2.6.7.1 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Password Exporter 1.2.1 ({B17C1C5A-04B1-11DB-9804-B622A1EF5492})
  • PDF Download 3.0.0.2 ({37E4D8EA-8BDA-4831-8EA1-89053939A250})
  • Session Manager 0.8.0.8 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Tree Style Tab 0.14.2013082301 (treestyletab@piro.sakura.ne.jp) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon(TM) HD 6520G
  • adapterDescription2:
  • adapterDeviceID: 0x9647
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 10-13-2011
  • driverDate2:
  • driverVersion: 8.910.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon(TM) HD 6520G)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 0
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 640000
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 1
  • browser.link.open_newwindow.restriction: 1
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.update: False
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.insertRelatedAfterCurrent: False
  • browser.tabs.insertRelatedAfterCurrent.backup: True
  • browser.tabs.loadFolderAndReplace: False
  • browser.tabs.onTop: False
  • browser.tabs.opentabfor.middleclick: False
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.ipc.plugins.enabled.npmywebs.dll: False
  • dom.max_chrome_script_run_time: 0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: False
  • font.name.serif.x-western: Arial
  • font.size.variable.x-western: 18
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • image.animation_mode: once
  • mousewheel.withnokey.sysnumlines: True
  • network.cookie.lifetime.days: 7
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379431995
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 58992230
  • places.last_vacuum: 1293555234
  • plugin.disable_full_page_plugin_for_types: application/vnd.fdf,application/vnd.adobe.xfdf,application/vnd.adobe.xdp+xml,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
  • plugin.importedState: True
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.donottrackheader.enabled: True
  • privacy.item.downloads: False
  • privacy.item.formdata: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.default_personal_cert: Select Automatically
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378355389

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars 489 solutions 5951 answers
Check this article *https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved

Question owner

The site in question is directv.....all others work OK, so it must be that the site is doing the blocking.....thanks.

The site in question is directv.....all others work OK, so it must be that the site is doing the blocking.....thanks.
philipp
  • Top 25 Contributor
  • Moderator
5289 solutions 23366 answers

Helpful Reply

you could use an addon like the following to circumvent such restrictions: https://addons.mozilla.org/firefox/addon/remember-passwords

you could use an addon like the following to circumvent such restrictions: https://addons.mozilla.org/firefox/addon/remember-passwords
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40084 answers

Helpful Reply

There's also the Saved Passwords Editor extension - https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/ - which allows you to add a new username / password manually.

Direct TV uses type="password" autocomplete="off" in page source coding to tell web browsers not to save the user's password. Firefox respects those "instructions"; other browsers may ignore that.

There's also the Saved Passwords Editor extension - https://addons.mozilla.org/en-US/firefox/addon/saved-password-editor/ - which allows you to add a new username / password manually. Direct TV uses '''type="password" autocomplete="off" ''' in page source coding to tell web browsers not to save the user's password. Firefox respects those "instructions"; other browsers may ignore that.

Question owner

Thanks for the link to the editor......although it allows me to enter data for directv sucessfully, it still doesn't actually fill in the password....

I guess that'll have to be OK, as I can at least lookup the password in FF.

I can live with that, but I sure would like to be able to over-ride the autocomplete setting.....directv used to allow autocomplete previously.

Thanks for the link to the editor......although it allows me to enter data for directv sucessfully, it still doesn't actually fill in the password.... I guess that'll have to be OK, as I can at least lookup the password in FF. I can live with that, but I sure would like to be able to over-ride the autocomplete setting.....directv used to allow autocomplete previously.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers

That website uses autocomplete=off to prevent Firefox from saving and filling the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data.

That website uses autocomplete=off to prevent Firefox from saving and filling the name and password. You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data. *http://kb.mozillazine.org/User_name_and_password_not_remembered

Question owner

Nope.....it never asked to remember the password.....

I assumed that the bookmarklet specified was under the remember password on the page describing the function.....a box opened when i clicked on it.....

Nope.....it never asked to remember the password..... I assumed that the bookmarklet specified was under the remember password on the page describing the function.....a box opened when i clicked on it.....

Question owner

I got FF to ask to save the password, but it doesn't fill it in when I put the login the next time.....

I got FF to ask to save the password, but it doesn't fill it in when I put the login the next time.....
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers

You will have to double-click an empty user name field to make Firefox open a drop-down list and choose the name from that list if autocomplete=off is used for that form.

You will have to double-click an empty user name field to make Firefox open a drop-down list and choose the name from that list if autocomplete=off is used for that form.

Question owner

I did that.....I can select who I am, but no password is entered.

Sometimes it knows who I am (from cookies, I assume), so no drop down, and it still doesn't enter the password.....maybe has something to do with 'remember me' and cookies???

I did that.....I can select who I am, but no password is entered. Sometimes it knows who I am (from cookies, I assume), so no drop down, and it still doesn't enter the password.....maybe has something to do with 'remember me' and cookies???
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers

Is the password saved in the Password Manager?

You can try to use the tab key to go to the password field, that should make Firefox fill the password if one is saved.

Is the password saved in the Password Manager? You can try to use the tab key to go to the password field, that should make Firefox fill the password if one is saved.

Question owner

If I uncheck the remember me box at the site, it fills in the password correctly nexct time. So, the issue now appears to be cookie related......

If I forget, the next login doesn't fill it in......any way to get it to not check the box automatically? I would assume no, since it'd be a web site function, not a browser function.

If I uncheck the remember me box at the site, it fills in the password correctly nexct time. So, the issue now appears to be cookie related...... If I forget, the next login doesn't fill it in......any way to get it to not check the box automatically? I would assume no, since it'd be a web site function, not a browser function.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers

You shouldn't have to log in if you have saved a 'remember me' cookie.
If there is a problem with the cookies from that website then try to clear those cookies (click the globe/padlock on the location bar and click More Information > View Cookies).

You shouldn't have to log in if you have saved a 'remember me' cookie.<br /> If there is a problem with the cookies from that website then try to clear those cookies (click the globe/padlock on the location bar and click More Information > View Cookies).
mitrajoon 0 solutions 13 answers

Same problem with my SmugMug site. Works fine with IE. Checking or unchecking "remember me" makes no difference. It shouldn't need a work around since it is only affecting a minority of users. Since many other people with FF don't have this problem there has to be a setting that is causing it. This problem has been reported for years and still no one has come up with why it is happening.

Same problem with my SmugMug site. Works fine with IE. Checking or unchecking "remember me" makes no difference. It shouldn't need a work around since it is only affecting a minority of users. Since many other people with FF don't have this problem there has to be a setting that is causing it. This problem has been reported for years and still no one has come up with why it is happening.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers

Do you mean names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox?

There is a difference between remembering the name and password in the Password Manager and a "remember me" check box on a web page to log you in automatically.
The latter usually involves the creation of a special "remember me" cookie that is stored on your computer and that is send to the server.
If that "remember me" cookie is removed or gets corrupted or is not send to the server then the server won't remember you anymore and you need to sign in once again.

Do you mean names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox? There is a difference between remembering the name and password in the Password Manager and a "remember me" check box on a web page to log you in automatically.<br /> The latter usually involves the creation of a special "remember me" cookie that is stored on your computer and that is send to the server.<br /> If that "remember me" cookie is removed or gets corrupted or is not send to the server then the server won't remember you anymore and you need to sign in once again. * http://kb.mozillazine.org/Cookies
mitrajoon 0 solutions 13 answers

I'm talking specifically about remembering the name and PW in the PW manager. When I log on to some of my favorite sites, my login ID and password automatically appear, I only need to click on "log in". (FF asked me at some point if I wanted to save that info and I said yes.) That used to be the case with SmugMug but at some point this stopped working with SmugMug.

Note: my login ID and PW are actually in the FF PW manager. FF simply doesn't recognize them.

BTW I tried using the "remember PW" and the "saved password" add ons and they don't make a difference. I've also cleared cache, deleted sql files, uninstalled and reinstalled FF. Basically I think I've tried every suggestion ever made regarding this subject.

I'm talking specifically about remembering the name and PW in the PW manager. When I log on to some of my favorite sites, my login ID and password automatically appear, I only need to click on "log in". (FF asked me at some point if I wanted to save that info and I said yes.) That used to be the case with SmugMug but at some point this stopped working with SmugMug. Note: my login ID and PW are actually in the FF PW manager. FF simply doesn't recognize them. BTW I tried using the "remember PW" and the "saved password" add ons and they don't make a difference. I've also cleared cache, deleted sql files, uninstalled and reinstalled FF. Basically I think I've tried every suggestion ever made regarding this subject.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers

Try to remove that name and password and let Firefox ask again to save this name and password.

If necessary then use the bookmarklet to make Firefox save the name and password.

Note that Firefox won't auto-fill a saved name automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.

Try to remove that name and password and let Firefox ask again to save this name and password. If necessary then use the bookmarklet to make Firefox save the name and password. *http://kb.mozillazine.org/User_name_and_password_not_remembered Note that Firefox won't auto-fill a saved name automatically when autocomplete=off is used, so you need to double-click the empty name field to get a drop-down list.
mitrajoon 0 solutions 13 answers

I appreciate your time on this but I have tried all that. The specific article you cite has been saved to my bookmarks for a quite awhile. As I indicated above, the bookmarklet (I called it an app) doesn't work in this case.

I removed the PW and name yesterday assuming FF would ask me if I wanted to save it, that didn't happen. Today I re-added the info using the "Saved Password" add on. Again, that didn't make a difference.

Keep in mind that other sites are fine. It's just my SmugMug user name and PW that is not recognized somehow. I originally assumed it was a SmugMug issue but SmugMug tech support mentioned that a few others had reported the same issue. After going over my settings they saw nothing wrong with my setup.

Based on the dozens of emails on this issue over the years there is some setting that an apparently random group of us has that is causing this issue.

I appreciate your time on this but I have tried all that. The specific article you cite has been saved to my bookmarks for a quite awhile. As I indicated above, the bookmarklet (I called it an app) doesn't work in this case. I removed the PW and name yesterday assuming FF would ask me if I wanted to save it, that didn't happen. Today I re-added the info using the "Saved Password" add on. Again, that didn't make a difference. Keep in mind that other sites are fine. It's just my SmugMug user name and PW that is not recognized somehow. I originally assumed it was a SmugMug issue but SmugMug tech support mentioned that a few others had reported the same issue. After going over my settings they saw nothing wrong with my setup. Based on the dozens of emails on this issue over the years there is some setting that an apparently random group of us has that is causing this issue.
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157312 answers
Try this login page instead: *https://secure.smugmug.com/login?goTo=http%3A%2F%2Fwww.smugmug.com%2F
mitrajoon 0 solutions 13 answers

The link you provided takes me to the SmugMug log in page. I logged in as usual (email and PW). I then logged out and tried to sign in. Again, in order to sign in I had to type my user ID (email) and PW. So using that particular URL didn't help.

Also, I was not asked by FF to remember my info. I deleted my Log in and PW info from FF's PW Manager and repeated the process. Got the same result. Even though there is no PW info in the PW Manager, I am not asked by FF to retain it.

Repeated the login process again, this time using the bookmarklet "remember PW". For the third time, no effect. Was not asked to save my login info and when I tried to login again, had to enter all info.

FWIW, I appreciate the time you have taken on this matter.

The link you provided takes me to the SmugMug log in page. I logged in as usual (email and PW). I then logged out and tried to sign in. Again, in order to sign in I had to type my user ID (email) and PW. So using that particular URL didn't help. Also, I was not asked by FF to remember my info. I deleted my Log in and PW info from FF's PW Manager and repeated the process. Got the same result. Even though there is no PW info in the PW Manager, I am not asked by FF to retain it. Repeated the login process again, this time using the bookmarklet "remember PW". For the third time, no effect. Was not asked to save my login info and when I tried to login again, had to enter all info. FWIW, I appreciate the time you have taken on this matter.