Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox is not opening on my homepage

  • 5 replies
  • 15 have this problem
  • 6894 views
  • Last reply by smob27

more options

FireFox is opening to the last page I visited instead of to my homepage. This has been happening for about 2 days.

Chosen solution

Do you have any files in the folder that start with user? Windows may be hiding the .js extension from you. http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

Read this answer in context 👍 1

All Replies (5)

more options

I assume you haven't changed your setting for how Firefox should start up. You can double-check in this dialog: Startup, home page, tabs, and download settings.

Firefox will sometimes skip the home page and automatically restore the last session. In particular, it will do this if it thinks that it crashed before shutting down.

One way to test whether that's what happening is to have Firefox present a list of open windows and tabs after a crash instead of loading the earlier windows and tabs automatically. Note: I'm suggesting this as a diagnostic to see whether this is the problem, and not suggesting that you have to live with it forever.

There are a couple of steps to do that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste crash and pause while the list is filtered

(3) Double-click the browser.sessionstore.max_resumed_crashes preference and change the value from 1 to 0 then click OK. The preference should appear in bold, indicating that it has been customized.

Finally, your "More System Details" information shows that you have a user.js file. This can override your settings when Firefox starts up, so if you don't recall creating it yourself (or it's not a company file), you might want to remove it. This article has more information: How to fix preferences that won't save.

Any luck?

more options

Are you sure session restore is NOT on.

  • Also change Firefox => Options => General => When Firefox Starts.... to show Home Page
more options

I can't find the user.js file...I've completed the other steps (thank you, btw) and the problem persists, so i hope it's the user.js file. When I "show folder" in the profile folder, there's no user.js file. Still stuck!

more options

Chosen Solution

Do you have any files in the folder that start with user? Windows may be hiding the .js extension from you. http://windows.microsoft.com/en-us/windows/show-hide-file-name-extensions

more options

Thank you!