Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have removed the preferences file but Firefox still is not the default browser as it is already set to be. I keep getting a message saying it isn't the defaul

  • 4 replies
  • 5 have this problem
  • 3 views
  • Last reply by bgstraughan

more options

I cannot make Firefox the default browser. I have it set as the default and it is also set to remind me to make sure it is the default but each time it says it isn't. I tell it to make it default and it tells me to restart the computer. But it is still not fixed. Same thing keeps happening. It is running on a windows 7 HP laptop. Hope someone has an idea how to fix it. Thanks

All Replies (4)

more options

Have you correctly followed the Make Firefox your default browser article.

more options

I'm not sure why you would have to restart the computer just to make a browser the default browser.

  • Control Panel > Programs > "Set your default programs" (on the left)
more options

Thank you for your reply. I have done both methods for setting Firefox as the default browser but it still doesn't seem to be working. Using the Firefox method: the check box is selected for always checking if Firefox is the default and each time it comes up I get the message that is not the default browser. Select that you want it the default browser and it says I have to restart the computer. Shown in the attached pics.

I have also gone to the Windows 7 control panel as described in the post and set Firefox as the default program but it still comes up as not my default program.

Modified by bgstraughan

more options

Thank you for your reply. I have done both methods for setting Firefox as the default browser but it still doesn't seem to be working. Using the Firefox method: the check box is selected for always checking if Firefox is the default and each time it comes up I get the message that is not the default browser. Select that you want it the default browser and it says I have to restart the computer. Shown in the attached pics.

I have also gone to the Windows 7 control panel as described in another post and set Firefox as the default program but it still comes up as not my default program.