Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does FF think I want to enter text in Cuban Spanish?

more options

Whenever I restart Firefox, the first time I try to enter text into a web form, I see all my English words underlined as if they were misspellings. So I right click and go to pick the language. It is always set to Cuban Spanish! So I reset it to US English and all is well again until the next time I restart the browser. Then we seem, once again, to be back to Cuban Spanish! Why does it always think I want to enter text in Cuban Spanish? When I check Preferences, the only language pref I can find is always set to US English. I even searched prefs.js and can find nothing about Cuban Spanish there.

All Replies (8)

more options

Could you check for a user.js file with this peculiar setting? This article describes how to track it down if it exists: How to fix preferences that won't save.

more options

What languages do you have installed and what is the current locale setting?

  • Tools > Options > Content > Languages

You can check these prefs on the about:config page.

  • general.useragent.locale
  • intl.accept_languages

Note that if you visit a website that send a language code that Firefox will automatically set the dictionary to that language.

more options

jscher2000: Thanks for your reply. However I do not have a user.js file in my profile directory. I may however try the "factory reset" option described in the link you provided.

cor-el: Thanks for your reply. I do not have Tools->Options. However, I do have Edit->Preferences->Content->Languages. That has 2 entries: en-US and en. In about:config, general.useragent.locale is set to en-US. intl.accept_languages has two values, en-US and en. Bottom line, NOTHING about Cuban Spanish.

more options

I noticed in about:config a preference regarding dictionaries. You might check yours and right-click > Reset it if it has been customized.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste dict and pause while the list is filtered

(3) Examine the spellchecker.dictionary preference and Reset if necessary.

The problem from my perspective is that I don't know whether this information comes from. It may be dynamically generated based on dictionaries you have downloaded.

more options

On Windows 7 (64-bit), there is a dictionaries folder here:

C:\Program Files (x86)\Mozilla Firefox\dictionaries

Can you find the equivalent folder on your system and check whether you have any unwanted languages there?

more options

"Reset Firefox to its default state" does not seem to have made any difference. It always goes to "Spanish (Cuba)" when I right-mouse in a form field. Tested it on Facebook, so not a Cuban website. It must be significant that Spanish (Cuba) is always the first thing in the list of languages (for some reason). Otherwise, the order seems random, except that there are many variants of Spanish listed. Also Croatian and Bulgarian (I have used keyboards for all 3 languages). I tried uninstalling the "Firefox language packs" for those and restarting Firefox, but no change. Do you know where "spell check language dictionaries" for various languages, as used by Firefox, are stored?

more options

jscher2000: Thanks for that suggestion! Ok, this is getting stranger and stranger. 1. In about:config, spellchecker.dictionaries was set to es_CU. 2. I used right mouse in a form field->Languages and set it to English (US). 3. Went back to about:config. Now set to en_US. 4. Restarted Firefox. 5. Looked at about:config. Now still set to en_US. 6. Right mouse in a form field->Lanuages: Spanish (Cuba) is checked. 7. Back to about:config. Now says es_CU.

I think I found the dictionaries that are at the root of this. In /usr/lib/firefox is a symbolic link, dictionaries->/usr/share/hunspell, a directory. That contains a few .aff and .dic files and many symlinks pointing to those (including es_CU.dic and es_CU.aff). I think I've found the key and it appears to be quite gnome or Ubuntu-specific. I will see what packages those files belong to and take it from there. Thanks for all the help. -- David

more options

Good sleuthing. Hunspell is used by other open source projects including OpenOffice, so there are several possible ways that those dictionaries could have entered the system. It's just strange that Firefox would reset your preference when it discovers other dictionaries; that seems like a bug.