X
Tap here to go to the mobile version of the site.

Support Forum

Weird Audio/Embed Issue On Tumblr

Posted

Today is when I noticed this, but it may have been going on for a bit longer. Anyways...

Whenever I have tried to go through music posts, specifically ones that are YouTube embeds/originating from YouTube, (Tumblr-uploaded music and Soundcloud ones are working just fine), I will click play, and then pause the music if it sounds good, then scroll down or up to get to the next post. However, when I scroll back to the location of the post that I paused, the video will restart without me clicking. This is not happening when a post is in my Likes, Queue, or Drafts- just on my Dash, Tags, or Main Page.

In Short: Music posts from YouTube in my Dash, Tags, and Main Page/Home Page pause fine and don't restart if I don't scroll, but if I do scroll, and then scroll back up or down, they restart.

Some things of note: -I tried replicating this issue in Google Chrome, and it did not happen (hence why I am posting this here. And before anyone tells me to just use Chrome...I'd rather not have to go to an entirely different browser just to use a specific function of a specific site in a specific place). -I tried restarting my computer twice- didn't work. -I tried both resetting FireFox and starting it in Safe Mode- Again, didn't work. -Tried resetting my internet connection- Once again, no dice. -Checked both my version and my plugins. Firefox is up to date, and my plugin checker lists everything as up to date as well. - This issue does not occur if I am actually viewing videos on YouTube itself. Just Tumblr (I don't know if any other sites are experiencing this problem). -I doubt this is an issue with my computer itself, as the problem only crops up in the areas and browser listed above.

Today is when I noticed this, but it may have been going on for a bit longer. Anyways... Whenever I have tried to go through music posts, specifically ones that are YouTube embeds/originating from YouTube, (Tumblr-uploaded music and Soundcloud ones are working just fine), I will click play, and then pause the music if it sounds good, then scroll down or up to get to the next post. However, when I scroll back to the location of the post that I paused, the video will restart without me clicking. This is not happening when a post is in my Likes, Queue, or Drafts- just on my Dash, Tags, or Main Page. In Short: Music posts from YouTube in my Dash, Tags, and Main Page/Home Page pause fine and don't restart if I don't scroll, but if I do scroll, and then scroll back up or down, they restart. Some things of note: -I tried replicating this issue in Google Chrome, and it did not happen (hence why I am posting this here. And before anyone tells me to just use Chrome...I'd rather not have to go to an entirely different browser just to use a specific function of a specific site in a specific place). -I tried restarting my computer twice- didn't work. -I tried both resetting FireFox and starting it in Safe Mode- Again, didn't work. -Tried resetting my internet connection- Once again, no dice. -Checked both my version and my plugins. Firefox is up to date, and my plugin checker lists everything as up to date as well. - This issue does not occur if I am actually viewing videos on YouTube itself. Just Tumblr (I don't know if any other sites are experiencing this problem). -I doubt this is an issue with my computer itself, as the problem only crops up in the areas and browser listed above.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Unity Player 4.1.5f1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • iTunes Detector Plug-in
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

It would clever for embedded videos to have their own script to pause when they go off screen and resume when they come back on screen. But if that existed, you would think it would behave consistently when you view the same embedded video on different pages and in different browsers.

Could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

It would clever for embedded videos to have their own script to pause when they go off screen and resume when they come back on screen. But if that existed, you would think it would behave consistently when you view the same embedded video on different pages and in different browsers. Could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

Whoops, after a closer reading, I see you already tested in Firefox's Safe Mode. I'll have to recover my Tumblr password and see whether I can replicate this.

Whoops, after a closer reading, I see you already tested in Firefox's Safe Mode. I'll have to recover my Tumblr password and see whether I can replicate this.

Question owner

lol I was about to say, I thought I had said it already. Oh well, it's early and we all make mistakes.

I also asked some Firefox-using friends, and apparently the same issue has been happening with them.

lol I was about to say, I thought I had said it already. Oh well, it's early and we all make mistakes. I also asked some Firefox-using friends, and apparently the same issue has been happening with them.

Question owner

But anyways jscher2000, if you see the issue or not, let me know?

But anyways jscher2000, if you see the issue or not, let me know?
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

Could I replicate it by looking at someone else's page, or does it only occur when you are logged in and viewing your own pages? If I could view someone else's page, that would be really convenient.

Could I replicate it by looking at someone else's page, or does it only occur when you are logged in and viewing your own pages? If I could view someone else's page, that would be really convenient.

Question owner

I'm not sure if it would happen while logged out, but doing both logged out and logged in would probably be good, for experimentation's sake.

However the way I am experiencing it right now is logged in and looking in my Dashboard or the tags. If you go in your Likes, Drafts, or Queue, and try to replicate it there, it doesn't happen (or it hasn't with me). It also doesn't seem to happen if you're on someone else's page.

Just Dashboard, personal/main/whatever dashboard (the one with only your posts), and in tags on the Dashboard.

Also, I am asking around, and apparently other people are having the issue too.

I'm not sure if it would happen while logged out, but doing both logged out and logged in would probably be good, for experimentation's sake. However the way I am experiencing it right now is logged in and looking in my Dashboard or the tags. If you go in your Likes, Drafts, or Queue, and try to replicate it there, it doesn't happen (or it hasn't with me). It also doesn't seem to happen if you're on someone else's page. Just Dashboard, personal/main/whatever dashboard (the one with only your posts), and in tags on the Dashboard. Also, I am asking around, and apparently other people are having the issue too.
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

Anything you can think of to make this easier to study would help. I don't know whether the volunteers here will be able to create a page that replicates the problem.

Anything you can think of to make this easier to study would help. I don't know whether the volunteers here will be able to create a page that replicates the problem.

Question owner

Hello jscher2000

Don't know why they would be unable to create a page- it's free to do so and people usually won't follow a blank blog.

Anyways, tried to replicate it, but due to the way Tumblr now formats its tags when a user is offline, checking it is a bit difficult, as it seems to only do picture posts, and even then only a certain amount.

Hello jscher2000 Don't know why they would be unable to create a page- it's free to do so and people usually won't follow a blank blog. Anyways, tried to replicate it, but due to the way Tumblr now formats its tags when a user is offline, checking it is a bit difficult, as it seems to only do picture posts, and even then only a certain amount.

Question owner

In short, it looks like someone will have to test this out while logged in.

In short, it looks like someone will have to test this out while logged in.

Question owner

One more thing: Experimented a little- it doesn't matter if the video is paused or not. It also occurs if the video is playing as well.

One more thing: Experimented a little- it doesn't matter if the video is paused or not. It also occurs if the video is playing as well.
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

Walk me through this, please. Assume I use Tumblr once a year (ahem).

I have icons for creating Audio and Video posts; I don't see one for Music posts. It's pretty obvious how to create a video post with a YouTube URL. Audio posts with a YouTube URL did not work for me. ??

Maybe it's easier if I follow you?

Walk me through this, please. Assume I use Tumblr once a year (ahem). I have icons for creating Audio and Video posts; I don't see one for Music posts. It's pretty obvious how to create a video post with a YouTube URL. Audio posts with a YouTube URL did not work for me. ?? Maybe it's easier if I follow you?

Question owner

Hello jscher2000, sorry for the late reply, I was out. Yeah, I'll tell you what I was doing, so maybe you can follow in my footsteps. 1) I was looking through the tags on Tumblr, specifically this one, though I don't think it matters which: http://www.tumblr.com/tagged/blutengel 2) Clicked on a YouTube video (any one will do. Also, YouTube audio posts are made by actually going to the video on YT, clicking the Share button, and clicking the Tumblr icon). 3) Scrolled back down to look at other posts. 4) Scrolled back up...thus the video restarted. 5) Since I had already Liked the video (by clicking on the heart icon), I experimented by also placing it in my Queue and drafts- the problem did not occur there.

Anyways, that's that, if you want to try replicating.

Hello jscher2000, sorry for the late reply, I was out. Yeah, I'll tell you what I was doing, so maybe you can follow in my footsteps. 1) I was looking through the tags on Tumblr, specifically this one, though I don't think it matters which: http://www.tumblr.com/tagged/blutengel 2) Clicked on a YouTube video (any one will do. Also, YouTube audio posts are made by actually going to the video on YT, clicking the Share button, and clicking the Tumblr icon). 3) Scrolled back down to look at other posts. 4) Scrolled back up...thus the video restarted. 5) Since I had already Liked the video (by clicking on the heart icon), I experimented by also placing it in my Queue and drafts- the problem did not occur there. Anyways, that's that, if you want to try replicating.

Question owner

Oh yeah, I might also mention that it doesn't happen when it's in my Likes either.

Oh yeah, I might also mention that it doesn't happen when it's in my Likes either.
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

Thanks for the example.

I see: scrolling a certain distance away from the video somehow stops it (presumably a script does this), while scrolling a certain distance toward the video restarts it (annoyingly, from the beginning).

The video is set to autoplay. The reason it doesn't autoplay until after you click it is that it is hidden by a preview image. Clicking the preview image hides the image and displays the video. Stopping the video does not hide the video (or clear the autoplay). If it did, the video would not restart. However, that's not a trivial hack...

Well, after two hours poking around, I'm no closer to figuring out why behaves this way.

Thanks for the example. I see: scrolling a certain distance away from the video somehow stops it (presumably a script does this), while scrolling a certain distance toward the video restarts it (annoyingly, from the beginning). The video is set to autoplay. The reason it doesn't autoplay until after you click it is that it is hidden by a preview image. Clicking the preview image hides the image and displays the video. Stopping the video does not hide the video (or clear the autoplay). If it did, the video would not restart. However, that's not a trivial hack... Well, after two hours poking around, I'm no closer to figuring out why behaves this way.

Question owner

Hello, and thanks for your reply. It's not just that video though. For example, type in a popular band/musician/whatever that you like into the tag search at the upper right corner. 2) click on a Youtube video. 3) Repeat process that I detailed in my previous post. It's doing this for all the videos. I presume that you tried it as well, and got the same issue? I guess I'm also wanting someone else to try it, so I can see if it's one of those "just me" things.

Hello, and thanks for your reply. It's not just that video though. For example, type in a popular band/musician/whatever that you like into the tag search at the upper right corner. 2) click on a Youtube video. 3) Repeat process that I detailed in my previous post. It's doing this for all the videos. I presume that you tried it as well, and got the same issue? I guess I'm also wanting someone else to try it, so I can see if it's one of those "just me" things.

Question owner

Hey jscher2000 (and anyone else who reads and/or wants to chime in here), 1) Just uninstalled Firefox, which included getting rid of my profiles, customizations, and the like (in short, I'm starting afresh pretty much), and then re-downloaded it. Problem is still there. 2) Decided to check other sites that allow embedding, such as Facebook and Deviantart. Nope, no issue. Just Tumblr is where that issue seems to reside.

Hey jscher2000 (and anyone else who reads and/or wants to chime in here), 1) Just uninstalled Firefox, which included getting rid of my profiles, customizations, and the like (in short, I'm starting afresh pretty much), and then re-downloaded it. Problem is still there. 2) Decided to check other sites that allow embedding, such as Facebook and Deviantart. Nope, no issue. Just Tumblr is where that issue seems to reside.
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

It's not just you. I got it with other Youtube videos on "tagged" searches as well.

It's not just you. I got it with other Youtube videos on "tagged" searches as well.

Question owner

Alright. And like I said above, I tried starting over from scratch, and the problem is still there.

Is there any way that you could try that too, just so I can make sure I did it correctly?

Sorry I'm asking so much. I'm just asking because I also e-mailed Tumblr support staff, and they have an annoying tendency to blame the user before the site itself. I just want to make sure I have my bases covered.

Alright. And like I said above, I tried starting over from scratch, and the problem is still there. Is there any way that you could try that too, just so I can make sure I did it correctly? Sorry I'm asking so much. I'm just asking because I also e-mailed Tumblr support staff, and they have an annoying tendency to blame the user before the site itself. I just want to make sure I have my bases covered.
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

I'm convinced. I tested in a new profile, which is uncustomized except for having the full collection of plugins installed on the system and one extension associated with my security software. (For future reference: Profile Manager - Create, remove, or switch Firefox profiles.)

As I scroll up and down, any videos that I've unhidden stop and restart regardless of whether I pause them. What's causing this is something in Tumblr's scripts that adds and removes display:none to posts as the user scrolls the page. This triggers Firefox to stop the playback and then to start it again.

I'm convinced. I tested in a new profile, which is uncustomized except for having the full collection of plugins installed on the system and one extension associated with my security software. (For future reference: [[Use the Profile Manager to create and remove Firefox profiles]].) As I scroll up and down, any videos that I've unhidden stop and restart regardless of whether I pause them. What's causing this is something in Tumblr's scripts that adds and removes display:none to posts as the user scrolls the page. This triggers Firefox to stop the playback and then to start it again.
jscher2000
  • Top 10 Contributor
8642 solutions 70696 answers

Helpful Reply

Stopping and restarting Flash automatically when display is toggled may be unique to Firefox. Neither IE9 not Chrome 29 appears to do it on this test page: http://www.jeffersonscher.com/forumsh.../toggle_display.html. If there is a way to prevent Firefox from doing that, I'm not aware of it.

But you can use a Greasemonkey userscript (or if you prefer, a Stylish userstyle) to prevent the script from hiding videos, thus avoiding the problem. A test version is available here: http://userscripts.org/scripts/show/177648. It adds this to Tumblr pages to override the page script's addition of display:none to posts:

<style type="text/css">li.post_container > div.post_full.is_video {display:block !important;}</style>
Stopping and restarting Flash automatically when display is toggled may be unique to Firefox. Neither IE9 not Chrome 29 appears to do it on this test page: [http://www.jeffersonscher.com/forumshots/toggle_display.html]. If there is a way to prevent Firefox from doing that, I'm not aware of it. But you can use a Greasemonkey userscript (or if you prefer, a Stylish userstyle) to prevent the script from hiding videos, thus avoiding the problem. A test version is available here: [http://userscripts.org/scripts/show/177648]. It adds this to Tumblr pages to override the page script's addition of display:none to posts: &lt;style type="text/css">li.post_container > div.post_full.is_video {display:block !important;}&lt;/style>