X
Tap here to go to the mobile version of the site.

Support Forum

I have OS 10.8 and my firefox won't update. Says my system is unsupported.

Posted

I have been unable to update my firefox for ages. When I click to update, it just shows a never ending update. I am running an extremely old version (5.0.1) because when I try to install something newer, I get a not compatible message. My operating system although old, shows on the mozilla site as still being supported. Don't know what to do. I've tried suggestions written in this forum, but none work.

I have been unable to update my firefox for ages. When I click to update, it just shows a never ending update. I am running an extremely old version (5.0.1) because when I try to install something newer, I get a not compatible message. My operating system although old, shows on the mozilla site as still being supported. Don't know what to do. I've tried suggestions written in this forum, but none work.

Chosen solution

Make sure, your using MAX OS X 10.8, your SYSTEM Details show your running MAC OS X 10.5

You need MAC OS X 10.6 atleast to run the latest version of FIREFOX

If your Running MAC OS X 10.8, Download the firefox and install it freshly

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • http://www.facebook.com/fbplugin/
  • WebEx General Plugin Container Version 169
  • iPhoto6
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • Java Plug-In 2 for NPAPI Browsers

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

cant install these because they are not compatible with my VERY OLD version of firefox!!!

iamjayakumars 489 solutions 5951 answers

Chosen Solution

Make sure, your using MAX OS X 10.8, your SYSTEM Details show your running MAC OS X 10.5

You need MAC OS X 10.6 atleast to run the latest version of FIREFOX

If your Running MAC OS X 10.8, Download the firefox and install it freshly

Make sure, your using MAX OS X 10.8, your SYSTEM Details show your running MAC OS X 10.5 You need MAC OS X 10.6 atleast to run the latest version of FIREFOX *https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-x-10-5 If your Running MAC OS X 10.8, Download the firefox and install it freshly *www.mozilla.org/en-US/firefox/‎