X
Tap here to go to the mobile version of the site.

Support Forum

How to manually setup a mailbox access with security settings

Posted

I am using email on my own domain at Host Europe (Domain and Mail hosting), and it was not possible to find a setup which worked. This is because a lot of parameters can not be adjusted. But I dont want to use Outlook or Gmail, which seem to work properly, because of security reasons.

Ideas and help are welcome. Thank you in advance.

I am using email on my own domain at Host Europe (Domain and Mail hosting), and it was not possible to find a setup which worked. This is because a lot of parameters can not be adjusted. But I dont want to use Outlook or Gmail, which seem to work properly, because of security reasons. Ideas and help are welcome. Thank you in advance.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

jscher2000
  • Top 10 Contributor
3757 solutions 33319 answers

I hope a Firefox OS expert appears with a definitive answer.

What ports do you use? For IMAP over SSL/TLS, those typically would be:

  • Inbound (IMAP4): 993
  • Outbound (SMTP): 465

Do those work?

Some providers only allow 587 for outbound SMTP. This may not guarantee an encrypted connection. Ideally, if you have to use port 587 for SMTP, your provider uses the STARTTLS command to switch your mail agent to an SSL/TLS connection (and doesn't work with an unsecured connection).

Unfortunately, STARTTLS is not yet supported in the released versions of Firefox OS but there is active development on adding that in a future release. (The same might be true of support for TLS on the default unsecured inbound IMAP port, 143.)

I hope a Firefox OS expert appears with a definitive answer. What ports do you use? For IMAP over SSL/TLS, those typically would be: * Inbound (IMAP4): 993 * Outbound (SMTP): 465 Do those work? Some providers only allow 587 for outbound SMTP. This may not guarantee an encrypted connection. Ideally, if you have to use port 587 for SMTP, your provider uses the STARTTLS command to switch your mail agent to an SSL/TLS connection (and doesn't work with an unsecured connection). Unfortunately, STARTTLS is not yet supported in the released versions of Firefox OS but there is active development on adding that in a future release. (The same might be true of support for TLS on the default unsecured inbound IMAP port, 143.)
poroszd 0 solutions 1 answers

Is there any advance in this topic? I'm unable to set up an account to a custom (non-gmail) mail server with the same settings that works in Thunderbird, receiving the error message:

'Unable to establish a secure connection with "x.x.x". There may be a problem with your network or the server. [bad-security]'

(Firefox OS 1.1.0.0-prerelease)

Is there any advance in this topic? I'm unable to set up an account to a custom (non-gmail) mail server with the same settings that works in Thunderbird, receiving the error message: 'Unable to establish a secure connection with "x.x.x". There may be a problem with your network or the server. [bad-security]' (Firefox OS 1.1.0.0-prerelease)
WerWer 3 solutions 35 answers

Helpful Reply

This may be due to your email-server using a self-signed certificate or one from a CA unknown by the phone. STARTTLS on the phone does not currently handle these. There are open bugs for this and possibly a workaround for certain cases. Please have a look at the thread https://support.mozilla.org/en-US/questions/968211

This may be due to your email-server using a self-signed certificate or one from a CA unknown by the phone. STARTTLS on the phone does not currently handle these. There are open bugs for this and possibly a workaround for certain cases. Please have a look at the thread https://support.mozilla.org/en-US/questions/968211
Juanhellou 0 solutions 1 answers

Hi there! I'm alowing myself to post here having the same problem as kreativnix but using an IPower based mail account (job). Following the steps given by them on this article http://www.ipower.com/knowledgebase/b.../article.bml?ArticleID=1789, I haven't been allowed to get into my email account resolving in a "Bad Security" message; my conclusion after reading another threads is that is something about self-signed certificates. I think it might be an important issue for FFOS since a large amount of users - I'm guessing here- check work email from their phones, since we're trusting (and supporting) Mozilla using it Operative System. I'd really appreciate any help. Thanks in advance.

Hi there! I'm alowing myself to post here having the same problem as kreativnix but using an IPower based mail account (job). Following the steps given by them on this article [http://www.ipower.com/knowledgebase/beta/article.bml?ArticleID=1789 ], I haven't been allowed to get into my email account resolving in a "Bad Security" message; my conclusion after reading another threads is that is something about self-signed certificates. I think it might be an important issue for FFOS since a large amount of users - I'm guessing here- check work email from their phones, since we're trusting (and supporting) Mozilla using it Operative System. I'd really appreciate any help. Thanks in advance.

Modified by Juanhellou

Andrew
  • Moderator
287 solutions 3650 answers

Juanhellou: Would you like your image removed since your email address is shown? This is to prevent spam and to protect your privacy and security. Also, if I look at that correctly, the email adddress inserted first is a .con domain and the IMAP settings is a .com domain. Is this what you are wanting?

Juanhellou: Would you like your image removed since your email address is shown? This is to prevent spam and to protect your privacy and security. Also, if I look at that correctly, the email adddress inserted first is a '''.con''' domain and the IMAP settings is a '''.com''' domain. Is this what you are wanting?
WerWer 3 solutions 35 answers

@Juanhellou Something to double-check (I apologize, if you've already done this!): When you access your email from another email client, e.g. Thunderbird, did you check, if your email settings there correspond to what you have in FFOS? On such email clients you could also check, what kind of SSL certificate you get from the server and who signed it (for Thunderbird: Edit->Account Settings->View certificates). This could help to verify, if certificates are the actual cause of the problem.

@Juanhellou Something to double-check (I apologize, if you've already done this!): When you access your email from another email client, e.g. Thunderbird, did you check, if your email settings there correspond to what you have in FFOS? On such email clients you could also check, what kind of SSL certificate you get from the server and who signed it (for Thunderbird: Edit->Account Settings->View certificates). This could help to verify, if certificates are the actual cause of the problem.