X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't open website links

Posted

I can get on the initial website but when I click on a link it displays the page I'm trying to get on but there is no information. Ex: Alisweb library site - tried to click onto LILink link - it goes to that page but only shows a heading. It's liked it's blocked or something. How do I unblock it? I don't have this problem with internet explorer.

Chosen solution

Is this on pages opened via a secure https connection?

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • 5.1.20125.0
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • WildTangent Games App V2 Presence Detector
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Unity Player 3.1.0f4
  • NPWLPG
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Tobbi
  • Moderator
67 solutions 450 answers

Helpful Reply

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Chosen Solution

Is this on pages opened via a secure https connection?

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.

Question owner

Thank you so much! This solved the problem and I realized I'm not crazy! Is there a way to make my selection of not blocking this link permanent?

mozila2013 0 solutions 1 answers

i can solve www.mozila.org