Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The pages I visit that required to put in an ID and password does not remember them

more options

I have windows vista. I visit my regular pages and enter my ID and password and click on the box that says remember password. However, I close the page and when I open it it still asks for my ID and password, I went to tolls on the top then went to options and went to security. There is a place that says remember passwords for sites. But I can't click on it, it won't let me. But there's use a master password underneath which I can but the one I want won't let me click the box, please help

Chosen solution

hello yurdominatrix, firefox won't save your passwords when you've set it up to run in permanent private browsing mode ("never remember history" in the options' privacy panel). the login information is stored in cookies, so make sure that the websites where you want to stay logged in are allowed to set cookies and that they are not cleared when you close firefox (as this is also the case while running firefox in private browsing mode).

Enhanced Tracking Protection in Firefox for desktop

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

hello yurdominatrix, firefox won't save your passwords when you've set it up to run in permanent private browsing mode ("never remember history" in the options' privacy panel). the login information is stored in cookies, so make sure that the websites where you want to stay logged in are allowed to set cookies and that they are not cleared when you close firefox (as this is also the case while running firefox in private browsing mode).

Enhanced Tracking Protection in Firefox for desktop

more options

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

Websites remembering you and automatically log you in is stored in a cookie.

  • Create a cookie Allow exception to keep such cookies, especially for secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > Cookies: Exceptions

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception.

more options

Thank you for the suggestions. I just went to tools options privacy and marked remember history. I have no idea what cookies are so I do not want to mess with that! But I will ask someone tomorrow at school. But for now it looks like its working. If you have any more thoughts on why I need to set it to private browsing mode(which that i do not know what it means) please give me suggestions on that too! I am a bit clueless on these things. So please be patient with me!