X
Tap here to go to the mobile version of the site.

Support Forum

Problems with edx course pages/videos

Posted

Problem: Videos on the course pages appear randomly with or without Closed Captions (CC)

 activated. If CC appears activated, then everything functions normally. If CC appears 
 not activated, then the video area expands (normal) but has a light-colored background
 and does not start playing (the start/pause buttons appear, even change, but have
 no effect)

Browser:

 Using Firefox 24.0a1 and 24.0b5 (64bit): Random behaviour. Impossible to play. Tested with
 FF 16.xx (32bit), 17.xx (64bit) too.

Test:

 Go to edx.org, "View all courses", select 'edx Demo' (3 or 4 down), click 'register'
 You'll have to register to edx.org before being able to enter the course (free). 
 Then, go to Week1, Lesson1, and click any of the videos ('envelopes' at the top).
 Here, the page will block, can't select other option, and the video does not start.
 Temporarily switching to "Homework" and back enables the video.

Note: I had to edit the "Troubleshooting" info below, as it exceeded the 30,000 limit. I eliminated variables starting with 'print', which I suspect are not relevant.

Problem: Videos on the course pages appear randomly with or without Closed Captions (CC) activated. If CC appears activated, then everything functions normally. If CC appears not activated, then the video area expands (normal) but has a light-colored background and does not start playing (the start/pause buttons appear, even change, but have no effect) Browser: Using Firefox 24.0a1 and 24.0b5 (64bit): Random behaviour. Impossible to play. Tested with FF 16.xx (32bit), 17.xx (64bit) too. Test: Go to edx.org, "View all courses", select 'edx Demo' (3 or 4 down), click 'register' You'll have to register to edx.org before being able to enter the course (free). Then, go to Week1, Lesson1, and click any of the videos ('envelopes' at the top). Here, the page will block, can't select other option, and the video does not start. Temporarily switching to "Homework" and back enables the video. Note: I had to edit the "Troubleshooting" info below, as it exceeded the 30,000 limit. I eliminated variables starting with 'print', which I suspect are not relevant.

Modified by jcoppens

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Shockwave Flash 10.0 r32

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Linux/en-US/

Extensions

  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Firebug 1.12.0 (firebug@software.joehewitt.com)
  • FlashGot 1.5.5.6 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • Old Location Bar 2.1.7 ({3205B348-523A-4fac-9BC4-9939CBF583B0})
  • Sage 1.5.2 ({a6ca9b3b-5e52-4f47-85d8-cca35bb57596})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • User Agent Switcher 0.7.3 ({e968fc70-8f95-4ab9-9e79-304de2a71ee1})
  • CacheViewer 0.6 ({71328583-3CA7-4809-B4BA-570A85818FBB}) (Inactive)
  • FireFTP 2.0.16 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f}) (Inactive)
  • FlashTracer 2.3.1 ({22832dda-1de6-4443-9ab5-d34214b03347}) (Inactive)
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)
  • Live HTTP headers 0.17 ({8f8fe09b-0bd3-4470-bc1b-8cad42b8203a}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Technologies Inc. -- ATI Radeon 3000 Graphics
  • adapterDeviceID: ATI Radeon 3000 Graphics
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: ATI Technologies Inc.
  • driverDate:
  • driverVersion: 3.3.11672 Compatibility Profile Context
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon 3000 Graphics
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #FFFFCC
  • browser.display.use_document_fonts: 0
  • browser.history_expire_days.mirror: 2
  • browser.history_expire_days_min: 3
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.suggest.enabled: False
  • browser.search.update: False
  • browser.startup.homepage: http://localhost/index.php
  • browser.startup.homepage_override.buildID: 20130822154523
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.insertRelatedAfterCurrent: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.urlbar.default.behavior: 17
  • browser.urlbar.matchOnlyTyped: True
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • font.default.x-western: sans-serif
  • font.FreeType2.enable: True
  • font.minimum-size.x-western: 13
  • font.name.monospace.x-western: DejaVu Sans Mono
  • font.name.serif.x-western: Bitstream Vera Serif
  • font.size.fixed.x-western: 16
  • font.size.variable.x-western: 14
  • general.autoScroll: True
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.app.mailto: /usr/local/bin/mail.sh
  • network.protocol-handler.expose.mailto: True
  • places.database.lastMaintenance: 1377865068
  • places.history.expiration.transient_current_max_pages: 69494
  • places.last_vacuum: 1297271088
  • plugin.disable_full_page_plugin_for_types: audio/x-scpls,application/pdf
  • plugin.importedState: True
  • plugin.soname.list: libXt.so:libXext.so
  • plugin.state.java: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.disable_button.openCertManager: False
  • security.enable_java: False
  • security.warn_entering_weak: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376376092

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton
  • Top 10 Contributor
633 solutions 5205 answers

You Flash plugin is out-of-date and needs to be updated. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.


If the problem continues, please post below.

You Flash plugin is out-of-date and needs to be updated. To do this, go to the [http://mozilla.com/plugincheck Mozilla Plugin Check site]. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow ''Update'' button or a red ''Update now'' button, please update these immediately. To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure. ----------------------- If the problem continues, please post below.
kobe 441 solutions 5048 answers

Umm some problem with flash shown with the system details, it shows two flash players, make sure you dont have multiple flash player files in the mozilla plugin folder, and or clean the plugin database.

Umm some problem with flash shown with the system details, it shows two flash players, make sure you dont have multiple flash player files in the mozilla plugin folder, and or clean the plugin database. * [[Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems]] See the Reintalizing the plugin database portion.

Modified by kobe

Question owner

I appreciate both replies, but the older flashplayer is disabled, and the newer one is the last version available from Adobe (11.2.202.297)

I could probably delete the older version, but it _is_ marked as disabled in the plugin manager.

I appreciate both replies, but the older flashplayer is disabled, and the newer one is the last version available from Adobe (11.2.202.297) I could probably delete the older version, but it _is_ marked as disabled in the plugin manager.

Modified by jcoppens

Question owner

The Plugin Check site detected an old version of Java, so I installed the latest one. Logically this made little difference.

The Check site flags the Flashplayer as old, but the one offered at Adobe is the same as installed. (verion # and all).

Note that the only site where I have this problem is edX.org (see original post).

The Plugin Check site detected an old version of Java, so I installed the latest one. Logically this made little difference. The Check site flags the Flashplayer as old, but the one offered at Adobe is the same as installed. (verion # and all). Note that the only site where I have this problem is edX.org (see original post).
Wesley Branton
  • Top 10 Contributor
633 solutions 5205 answers

Firefox 24.0 has not been officially released yet. Therefore it may still contain some bugs. Please try downgrading to Firefox 23.0.1.

Firefox 24.0 has not been officially released yet. Therefore it may still contain some bugs. Please try downgrading to Firefox 23.0.1.
kobe 441 solutions 5048 answers

You could still try to delete the pluginreg.dat file in the profile folder and delete the old flash player as that causes problems anyways (see my previous post)

You could still try to delete the pluginreg.dat file in the profile folder and delete the old flash player as that causes problems anyways (see my previous post)
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158867 answers

Note that your System Details List also shows an older Shockwave Flash 10.0 r32 version.

You can find the path of all plugins on the about:plugins page.

Note that your System Details List also shows an older Shockwave Flash 10.0 r32 version. You can find the path of all plugins on the about:plugins page.

Question owner

Already deleted the older Flash plugin. It isn;t reported anymore. It makes no difference.

About the versions: I have tried 16.xx (don't remember the xx), 17.0, 24.0a1 and 24.b5. Also consider: On Aug 27th, the site worked normally, on Aug 28th, the problem appeared.

The problem might be at the edX site, but I do not get any error indication from Firefox.

Already deleted the older Flash plugin. It isn;t reported anymore. It makes no difference. About the versions: I have tried 16.xx (don't remember the xx), 17.0, 24.0a1 and 24.b5. Also consider: On Aug 27th, the site worked normally, on Aug 28th, the problem appeared. The problem might be at the edX site, but I do not get any error indication from Firefox.

Question owner

Ok. This is what FF 23.0.1 looks like on the edX page, CS169.2x, Lecture 7, freshly loaded

Ok. This is what FF 23.0.1 looks like on the edX page, CS169.2x, Lecture 7, freshly loaded

Modified by jcoppens

Question owner

(The previous screenshot was video 2 as can be seen by the selected tab).

This is (same FF), after switching to video 3 and back to video 2. I.e., the way it should look. Switching to another Lecture and back, returns to the previous screenshot.

(The previous screenshot was video 2 as can be seen by the selected tab). This is (same FF), after switching to video 3 and back to video 2. I.e., the way it should look. Switching to another Lecture and back, returns to the previous screenshot.

Question owner

Just to anticipate things, this is not an interference from some add-on. I also have the problem if I start Firefox in safe-mode.

Also, note that the video is supposed to autostart, which it does, if it appears as in the 7:38AM screenshot, but does not in the 7:31AM screenshot.

Just to anticipate things, this is not an interference from some add-on. I also have the problem if I start Firefox in safe-mode. Also, note that the video is supposed to autostart, which it does, if it appears as in the 7:38AM screenshot, but does not in the 7:31AM screenshot.

Modified by jcoppens

cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158867 answers

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Did you check the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and/or Browser/Error Console (Firefox/Tools > Web Developer;Ctrl+Shift+J) for errors?

You can also use the Live Http Headers extension to check if the video is rquested.

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)? Did you check the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and/or Browser/Error Console (Firefox/Tools > Web Developer;Ctrl+Shift+J) for errors? You can also use the Live Http Headers extension to check if the video is rquested. *Live Http Headers: https://addons.mozilla.org/firefox/addon/live-http-headers/

Question owner

Cor-el:

1) As explained in the original post, this problem appears only in the edx.org site. And I believe the only way to access the Demo page is to provide an e-mail address... As this site is promoted by large universities, I do not think there's any problem...

2) I had checked Webdeveloper - no message there. I had checked Errors, but thought they were all (many!) warnings. Filtering, I did find 6 errors. I made a screenshot - that is probably more readable than copy&paste.

3) I have LiveHTTPHeaders installed but disabled. Will re-enable after sending this and report.

Cor-el: 1) As explained in the original post, this problem appears only in the edx.org site. And I believe the only way to access the Demo page is to provide an e-mail address... As this site is promoted by large universities, I do not think there's any problem... 2) I had checked Webdeveloper - no message there. I had checked Errors, but thought they were all (many!) warnings. Filtering, I did find 6 errors. I made a screenshot - that is probably more readable than copy&paste. 3) I have LiveHTTPHeaders installed but disabled. Will re-enable after sending this and report.

Modified by jcoppens

Question owner

LiveHTTPHeaders captures _many_ events :)

In the 'Generator List' I notice that there is a GET /videoplayback?id=a507d34... event this I suspect starts the playing. In case the video does not start, there is no GET /videoplayback request.

I have the Generator events captured on disk - how do I send them? Include them here? Pastebin?

LiveHTTPHeaders captures _many_ events :) In the 'Generator List' I notice that there is a GET /videoplayback?id=a507d34... event this I suspect starts the playing. In case the video does not start, there is no GET /videoplayback request. I have the Generator events captured on disk - how do I send them? Include them here? Pastebin?