Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Linkedin app fails to open


I have tried both adaptive and marketplace, but when I click icon screen goes blank. Pressing Home key is only way out.

Additional System Details


  • User Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

More Information

  • Top 25 Contributor
  • Moderator
251 solutions 3015 answers

Helpful Reply


After reading the information provided about your issue I suggest a soft reset of the phone.

  1. Take the back cover of the phone off.
  2. Take the battery out.
  3. Take the SIM card and microSD card out (if applicable).
  4. Wait 10 seconds.
  5. Put the SIM card and microSD card back in (if applicable).
  6. Put the battery back in.
  7. Put the back cover back on.
  8. Turn the device on.
  9. Check if the issue you were having is still present.

Please report back to us if this solved your problem!

Thank you

Helpful Reply

No change on reset. When the app icon is clicked there is simply a blank screen, reloading does nothing, back button does nothing. Only way is long press Home button. Both Facebook and Twitter open without a problem. Xavier

  • Administrator
  • Moderator
66 solutions 462 answers


I'm sorry you're having this problem with LinkedIn on Firefox OS. Thanks for this report. I will look into this more (I can reproduce this on my ZTE Open) so I have filed a bug on it https://bugzilla.mozilla.org/show_bug.cgi?id=908925

Best regards, Michelle Luna