X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Missing bookmarks button on the bookmarks toolbar

Posted

On Mac OS X (10.7.5), after firefox 23.0.1 update, the orange Bookmarks button that was on the Bookmarks toolbar (next to "Most visited") disappeared.

I tried to reset firefox, and got a Bookmarks button on the Navigation toolbar back, but that is less useful (more mouse travel ^^). Also, I tried to customize the Bookmarks toolbar and can put on it a Bookmarks menu, but it's not orange (black) and, more importantly, it cannot be renamed (I used to put an empty name to save space on the toolbar).

Any ideas ? Thanks,

Modified by cyberpi

Additional System Details

Installed Plug-ins

  • Version 4.4.2.14502
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Picasa plugin.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

TJGirl 0 solutions 1 answers

Me too! I hope it's fixed soon. I never realized how much I rely on this bookmarks toolbar throughout my work day. As of right now, I can't even find a workaround.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Is this about the Bookmarks Menu button that shows the bookmarks in a drop-down list?

Question owner

@cor-el : yes.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can hide the label text with code in userChrome.css

Add code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#bookmarks-menu-button .toolbarbutton-text {display:none!important}
PhilM 0 solutions 6 answers

The Bookmarks button is supposed to appear on the right end of the Awsome bar. Mine appears betwen the search window and the green download progress arrow.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

Hi pmishler

You can open the Customize window and drag this button to the wanted position.

  • Firefox menu button > Options > Toolbar Layout
  • View > Toolbars > Customize
PhilM 0 solutions 6 answers

Helpful Reply

Thank you. That was helpful.

JustChuckle 0 solutions 1 answers

I had the same problem and tried dragging and dropping the bookmarks button several times. Problem was, I was dragging it to the wrong place... where it USED to be. I found success when I dragged it beside the minimize/re-size/quit buttons. That'll do. It's a drop down menu rather than a side bar and near where I'm accustomed to finding it. See attached screen shot.

Ciao