X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Favicon in firefox are all messed up, WHY?

Posted

I see million or more stupid threads about favicons not showing on firefox, but in other browsers work perfectly fine. This has been going for many years, and mozilla can't get it working right? What the crap? After so many people complaining about it. They won't do anything to make it work like all the other browsers. Now, that is pathetic as all can get. That is pretty much the only thing that bugs me, is they will not fix that right.

Besides that problem. I love firefox. If they are not going to fix this problem with firefox not refreshing after closing page or tab and opening it like all other browsers, then I will just never use firefox again, because there is just no excuse for after all these years to not have that work like all the other browsers for the favicon. Makes no sense for that to be default in the browser. Favicons are for a reason, and that is not putting the fix off so they won't be used by your firefox users. Mind boggling that it has gone this long without the firefox browser working right with favicons. Making us spend hours trying to get it to work, is just plain dumbest thing ever. Even with this complaint, its never going to be fixed. If they haven't fixed it yet after this many years, then it will never get fixed. I am not spending any more stupid time on something that should be default in firefox.

I see million or more stupid threads about favicons not showing on firefox, but in other browsers work perfectly fine. This has been going for many years, and mozilla can't get it working right? What the crap? After so many people complaining about it. They won't do anything to make it work like all the other browsers. Now, that is pathetic as all can get. That is pretty much the only thing that bugs me, is they will not fix that right. Besides that problem. I love firefox. If they are not going to fix this problem with firefox not refreshing after closing page or tab and opening it like all other browsers, then I will just never use firefox again, because there is just no excuse for after all these years to not have that work like all the other browsers for the favicon. Makes no sense for that to be default in the browser. Favicons are for a reason, and that is not putting the fix off so they won't be used by your firefox users. Mind boggling that it has gone this long without the firefox browser working right with favicons. Making us spend hours trying to get it to work, is just plain dumbest thing ever. Even with this complaint, its never going to be fixed. If they haven't fixed it yet after this many years, then it will never get fixed. I am not spending any more stupid time on something that should be default in firefox.

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.8 r800
  • 5.1.20513.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 915GM/GMS,910GML Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2592
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 6-6-2006
  • driverDate2:
  • driverVersion: 6.14.10.4609
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.4764']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.4764']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.check_doc_frequency: 1
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.nicerblog.com
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376447311
  • places.history.expiration.transient_current_max_pages: 33329
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1375408625

Misc

  • User JS: No
  • Accessibility: No

Question owner

Makes no sense for that NOT to be default in the browser.

Makes no sense for that '''NOT''' to be default in the browser.

Question owner

My site for one is this problem with forum. It works fine in all other browsers, but not firefox. To pull my hair out for firefox is stupid.

My site for one is this problem with forum. It works fine in all other browsers, but not firefox. To pull my hair out for firefox is stupid.
kobe 441 solutions 5048 answers

Maybe writing a bug can help?

Maybe writing a bug can help? * bugzilla.mozilla.org

Question owner

Um, maybe firefox not putting it off might help too. LOL!

Um, maybe firefox not putting it off might help too. LOL!
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40308 answers

My site for one is this problem with forum.

What's the URL for your website?

'''''My site for one is this problem with forum.''''' What's the URL for your website?
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

Hi utahman1971, if the problem is on your site, can you give the URL? Might be a simple fix.

Hi utahman1971, if the problem is on your site, can you give the URL? Might be a simple fix.

Question owner

Simple fix is firefox is the only browser that does this. I am not going to do a million things to firefox, because firefox will not fix this in any of their browser releases.

Site is http://www.nicerblog.com/forum. It is the forum that won't take the favicon in firefox. Get that firefox. All other browsers show the favicon for the forum. So I wish people would quit defending firefox for not getting this fixed. If it was, then I would not be here would I?

Simple fix is firefox is the only browser that does this. I am not going to do a million things to firefox, because firefox will not fix this in any of their browser releases. Site is http://www.nicerblog.com/forum. It is the forum that won't take the favicon in firefox. Get that firefox. All other browsers show the favicon for the forum. So I wish people would quit defending firefox for not getting this fixed. If it was, then I would not be here would I?

Question owner

Already submitted bug, and still since the beginning of firefox has this problem. Why did they put it off for so long?

Already submitted bug, and still since the beginning of firefox has this problem. Why did they put it off for so long?

Question owner

Oh, as for simple fix. Why are there threads all over google search about firefox not refreshing right, and favicons not showing either in bookmarks or next to sites title? Simple answer is mozilla won't do anything. Can't say they did if the problem still there after many years all over the internet. That is stupid to not have it fixed.

Oh, as for simple fix. Why are there threads all over google search about firefox not refreshing right, and favicons not showing either in bookmarks or next to sites title? Simple answer is mozilla won't do anything. Can't say they did if the problem still there after many years all over the internet. That is stupid to not have it fixed.

Question owner

Since, I am spending hours just getting nothing from this either. I will move to Chrome that works. I won't be back to firefox, unless they make this a default in their browser like all other browsers make it work. Having to manually fix it multiple times a day is stupid.

Since, I am spending hours just getting nothing from this either. I will move to Chrome that works. I won't be back to firefox, unless they make this a default in their browser like all other browsers make it work. Having to manually fix it multiple times a day is stupid.
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

There are two ways to get a favicon to appear for your site:

(1) link tag with rel="shortcut icon"
(2) favicon.ico in the root of your site

On your site's home page (not forum) you are using method #1:

<link rel="shortcut icon" href="http://www.nicerblog.com/wp-content/uploads/favicon.png"/>

On your forum page, you are not using method #1, so Firefox tries method #2 (http://www.nicerblog.com/favicon.ico). However, apparently the file format does not agree with it, since Firefox says the image contains errors. Internet Explorer 8 can't display it, either. When I try to save the file, I get zero bytes. So... that's what I see.

There are two ways to get a favicon to appear for your site: (1) link tag with rel="shortcut icon"<br> (2) favicon.ico in the root of your site On your site's home page (not forum) you are using method #1: &lt;link rel="shortcut icon" href="http://www.nicerblog.com/wp-content/uploads/favicon.png"/> On your forum page, you are not using method #1, so Firefox tries method #2 ([http://www.nicerblog.com/favicon.ico]). However, apparently the file format does not agree with it, since Firefox says the image contains errors. Internet Explorer 8 can't display it, either. When I try to save the file, I get zero bytes. So... that's what I see.
jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

What are you manually fixing multiple times a day?

The problem with bookmarks losing favicons is a different problem. I haven't researched that one.

Oh, when I view the forum page in Chrome, I don't get a favicon in that browser, either.

What are you manually fixing multiple times a day? The problem with bookmarks losing favicons is a different problem. I haven't researched that one. Oh, when I view the forum page in Chrome, I don't get a favicon in that browser, either.

Question owner

Really, same answers that are all over the internet that does nothing. WOW! I got that same answer on Google. Does not fix it. It should be fixed, not manually spend hours on trying to get it to work.

I do have it in the root directory of the forum. DUH! I said before and I will say it again.

ALL OTHER BROWSERS show it there. So that did nothing to help.

Really, same answers that are all over the internet that does nothing. WOW! I got that same answer on Google. Does not fix it. It should be fixed, not manually spend hours on trying to get it to work. I do have it in the root directory of the forum. DUH! I said before and I will say it again. ALL OTHER BROWSERS show it there. So that did nothing to help.

Question owner

Get it through your thick skull. Firefox is the only browser that has this problem.

Get it through your thick skull. Firefox is the only browser that has this problem.

Question owner

Done with in here. I am communicating with firefox over this. Not doing things that will not do anything to getting to where I will have to spend more hours on this, because people can just me things I already tried. If it is an answer from the search engines, then I already tried it. No more responding on this thread, because your answers are unresolved. It is a mozilla non fixed problem.

Done with in here. I am communicating with firefox over this. Not doing things that will not do anything to getting to where I will have to spend more hours on this, because people can just me things I already tried. If it is an answer from the search engines, then I already tried it. No more responding on this thread, because your answers are unresolved. It is a mozilla non fixed problem.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40308 answers

http://www.nicerblog.com/favicon.ico
You can't simply rename a favicon.PNG image as favicon.ico and expect it to work properly. Firefox will use a PNG image as the favicon, but you need a link tag with rel="shortcut icon" and the correct file name suffix.


This thread is done. When you calm down and are able to treat the support contributors with a modicum of decency feel free to start a new thread; or not.

http://www.nicerblog.com/favicon.ico <br /> You can't simply rename a ''favicon.'''PNG''''' image as '''favicon.ico''' and expect it to work properly. Firefox will use a PNG image as the favicon, but you need a link tag with rel="shortcut icon" and the correct file name suffix. This thread is done. When you calm down and are able to treat the support contributors with a modicum of decency feel free to start a new thread; or not.