Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

I wish to rollback to my previous version of Firefox.

  • 5 replies
  • 16 have this problem
  • 10252 views
  • Last reply by philipp

more options

Since this new version got updated without my consent, i have lost my add-ons which annoys me greatly.

I am getting pop-up adds again, where as the version i was running previously they did not show up.

I had my old version customised just the way i like it, and i want it back. I am unphased about "bugs, glitches and security issues" as i trust my anti-virus to do its job. I would just like the version i had back the way i had it. This new version is not good and looks like google chrome, and if i wanted chrome, i would download it

All Replies (5)

more options

Hello reddy07, you have your point and of course it is fully accepted, if we can help with anything else please tell us, we are happy for that

Install an older version of Firefox

thank you

more options

hello reddy07, if you're getting unwanted pop-up ads it sounds a bit like malware is active on your system (your anti-virus program might not be as good as you think) - could you go to firefox > help > troubleshooting information, copy the contents of that page and paste them into a forum reply here - this might give us a better understanding on what's going on...

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end side of the Search Bar ("Find Updates" button in older Firefox versions) to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.sqlite file.

more options

When will my Norton 360 software be compatible with this updated version of Mozilla Firefox? This is my sole reason for wanting to downgrade to a previous version.

more options