X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Why is my ZTE Open unable to update Firefox OS?

Posted

Everytime i hit button check for update there is an error message 'problem to download update'.

Everytime i hit button check for update there is an error message 'problem to download update'.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

More Information

Doramia 1 solutions 20 answers

ZTE open users can build 1.1, 1.2 or 1.3. The trick is, they have to build it. There is a build of 1.3 for download at this website.

ZTE open users can build 1.1, 1.2 or 1.3. The trick is, they '''have to build it.''' There is a build of 1.3 for download [https://blog.non.co.il/index.php/zte-open-phone-upgrading-to-firefoxos-1-1-how-to/ at this website].

Modified by Doramia

Doramia 1 solutions 20 answers

1.1 has already been released to ZTE open users in Spain.

1.1 has already been released to ZTE open users in Spain.
LostSon 0 solutions 7 answers

Well I am in the US and I hope it hits soon.

Well I am in the US and I hope it hits soon.
Doramia 1 solutions 20 answers

Waiting for ZTE anything is a lost cause. Mozilla, make compiled updates available!

Waiting for ZTE anything is a lost cause. Mozilla, make compiled updates available!
Andrew
  • Moderator
275 solutions 3564 answers

I have escalated this thread for attention. Thank you for your patience. Sorry for any inconvenience.

I have escalated this thread for attention. Thank you for your patience. Sorry for any inconvenience.
Doramia 1 solutions 20 answers

[274 results for I have escalated this thread for attention]

Is there a button where average users can do that? I don't like thinking our concerns are ignored until a mod presses a magic link.

[[https://support.mozilla.org/en-US/search?q=I+have+escalated+this+thread+for+attention&esab=a&product=firefox-os|Found 274 results for I have escalated this thread for attention]] Is there a button where average users can do that? I don't like thinking our concerns are ignored until a mod presses a magic link.
fleamour 6 solutions 71 answers

With major bugs.

With major bugs.
fleamour 6 solutions 71 answers

(ReleasedSpain)

(ReleasedSpain)
thecore 0 solutions 4 answers

Optimal variant- manually compile pre1.3 FF OS. And never, never, nevermore not buy any ZTE production. FF OS is very interesting project, but ZTE is $#$T@#R company. I'm tired of waiting updates ZTE. But real- manually compiled pre1.3 FF OS - very stable and normally working on ZTE Open.

Optimal variant- manually compile pre1.3 FF OS. And never, never, nevermore not buy any ZTE production. FF OS is very interesting project, but ZTE is $#$T@#R company. I'm tired of waiting updates ZTE. But real- manually compiled pre1.3 FF OS - very stable and normally working on ZTE Open.
Andrew
  • Moderator
275 solutions 3564 answers

Doramia: I understand that you have no released the update yet but I have requested some device information from you in another thread to better assist you. I myself do have a ZTE Open device and I did get an OTA update that updated me to 1.1. I understand that you are still waiting and I thank you for your patience.

Doramia: I understand that you have no released the update yet but I have requested some device information from you in another thread to better assist you. I myself do have a ZTE Open device and I did get an OTA update that updated me to 1.1. I understand that you are still waiting and I thank you for your patience.
fleamour 6 solutions 71 answers

@feer56, no 1.1 here in UK? When ZTE? When?

@feer56, no 1.1 here in UK? When ZTE? When?
postal2600 0 solutions 10 answers

I to manage to receive an update to 1.1 after pressing the update button several times. Now, as julienw mentioned, my call log doesn't work anymore because I had a call from a "anonymous" caller in the call log... No biggy, tho very annoying... The bigger problem: 3G doesn't work anymore :(.

Also, when I hit update now... guess what: error downloading updates... Again! :( ...

I guess I'll have to look again in the logcat and paste the error. For now, I forgot my cable at the office, so maybe tomorrow I'll post the logcat...

I to manage to receive an update to 1.1 after pressing the update button several times. Now, as julienw mentioned, my call log doesn't work anymore because I had a call from a "anonymous" caller in the call log... No biggy, tho very annoying... The bigger problem: 3G doesn't work anymore :(. Also, when I hit update now... guess what: error downloading updates... Again! :( ... I guess I'll have to look again in the logcat and paste the error. For now, I forgot my cable at the office, so maybe tomorrow I'll post the logcat...

Modified by postal2600

postal2600 0 solutions 10 answers

The logcat for when I press the update button and I get an error can be fpund here: https://gist.github.com/postal2600/c4c98f5c08d13470cd04 .

The interesting lines seems to me line 87 (which I remember seeing before the update as well) and 101.

Hope it helps.

The logcat for when I press the update button and I get an error can be fpund here: https://gist.github.com/postal2600/c4c98f5c08d13470cd04 . The interesting lines seems to me line 87 (which I remember seeing before the update as well) and 101. Hope it helps.
andria 0 solutions 6 answers

Helpful Reply

but.... Ebay ZTE Open will never been updated, that is certain. Now we have to buy another phone

but.... Ebay ZTE Open will never been updated, that is certain. Now we have to buy another phone
fleamour 6 solutions 71 answers

I'm pretty sure the failed update demonstrates a willingness to update platform. So c'mon how about a 1.1 Xmas present ZTE?!?

I'm pretty sure the failed update demonstrates a willingness to update platform. So c'mon how about a 1.1 Xmas present ZTE?!?
postal2600 0 solutions 10 answers

Now it shows me I have 4 updates available but when i try to download them, after about 2Mb, it disapears and nothing is updated.

The error in the logcat is this: https://gist.github.com/postal2600/7896434

The problem is the Explorer application which I've installed it before the update. I've unchecked it from the update list and the update went through.

Now it shows me I have 4 updates available but when i try to download them, after about 2Mb, it disapears and nothing is updated. The error in the logcat is this: https://gist.github.com/postal2600/7896434 The problem is the Explorer application which I've installed it before the update. I've unchecked it from the update list and the update went through.
Andrew
  • Moderator
275 solutions 3564 answers

postal2600: thanks for reporting.

WRONG_APP_STORE_ID: The update available has an ID attached to it and unfortunately it does not match the ID of the app you currently have or of the Marketplace. This is a Firefox and developer issue. You can file a bug for this or contact the developer of the app for more assistance.

Thanks!

postal2600: thanks for reporting. '''WRONG_APP_STORE_ID''': The update available has an ID attached to it and unfortunately it does not match the ID of the app you currently have or of the Marketplace. This is a Firefox and developer issue. You can file a bug for this or contact the developer of the app for more assistance. Thanks!
agentwd40 0 solutions 1 answers

Just managed to get mine updated to 1.1 today. Zte have finally released a zip on their website.

http://www.ztedevices.com/support/smart_phone/cba40ed6-d3ab-44c0-bdee-3a15803dc187.html?type=software

Hope this works for you guys too.

Just managed to get mine updated to 1.1 today. Zte have finally released a zip on their website. http://www.ztedevices.com/support/smart_phone/cba40ed6-d3ab-44c0-bdee-3a15803dc187.html?type=software Hope this works for you guys too.
bimalmdev 0 solutions 1 answers

thanks

thanks

Modified by bimalmdev

DFX2KX 0 solutions 1 answers

I can verify that the problem continues (and is, in fact worse for me) with the recent 1.1 update on this particular phone. I don't have any other FF OS phones to work with or test, though.

For me, it's doing it with the Marketplace app. Actually, that brings up a question. I've got the Simulator on my Firefox install, is there a way I can take the app from the Github repo and just push it to the phone, like anything I write for it?

I can verify that the problem continues (and is, in fact worse for me) with the recent 1.1 update on this particular phone. I don't have any other FF OS phones to work with or test, though. For me, it's doing it with the Marketplace app. Actually, that brings up a question. I've got the Simulator on my Firefox install, is there a way I can take the app from the Github repo and just push it to the phone, like anything I write for it?