X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This Connection is Untrusted You have asked Firefox to connect securely to swdlp.apple.com, but we can't confirm

Posted

This Connection is Untrusted

              You have asked Firefox to connect

securely to swdlp.apple.com, but we can't confirm that your connection is secure.

         Normally, when you try to connect securely,

sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

         What Should I Do?
         
           If you usually connect to

this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

There is no option to add exclusion. last time i check IE8 does not annoy me like firefox. how do you turn off this BS security? i have internet security program already.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

What is the URL of the page that has this problem?

One reason you might not have a button to add an Exception is if the swdlp.apple.com page is in a frame. When that happens, to add an exception, right-click the framed error page and choose This Frame > Open in a New Tab. Once there, you can add an exception. After saving that, go back to the original page and reload.


By the way, I don't think there is a setting to prevent Firefox from examining SSL certificates. If you find that you have this problem often, it could be related to a proxy. Some security products (e.g., BitDefender and ESET) have a feature to proxy your HTTPS as well as your HTTP traffic. If you think that might be an issue, there is a way to create a global exception for your security software's certificate.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

The problem here seems to be that you try to connect via a secure https connection, but that Firefox is using a normal http connection instead.

The main page seems to only have installed old server software that connects by default via RC4 128 bit or 3DES-EDE-CBC 168 bit if I disable RC4 128 bit ciphers.

Question owner

thanks for responses- IE8 allowed me to download QuickTime unimpeded.

busydad 0 solutions 1 answers

Helpful Reply

Firefox was my default browser until I did a reset Firefox today. Now I get the untrusted connection message continually. Now Firefox is unusuable! I have checked the SSL settings on ESET too.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi busydad, when you do a Reset, Firefox moves your old settings folder (old Firefox profile folder) to the desktop under the name Old Firefox Data. Hang on to that for a while in case you need to rescue files from it.

It may be that you need to copy your old certificates file from that folder to your new settings folder in order to pick up the ESET certificate. I'd have to research the specific steps for that, but I can refer you to this article as a starting point: Recovering important data from an old profile.

Or are you saying that you turned off the SSL filtering in ESET, so Firefox shouldn't be confused about the source of a site's certificate? If you expand the technical detail or click through to the Add Exception dialog, does it still show an ESET certificate or something new?

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

If it worked in the old profile then you can copy the cert8.db file in the "Old Firefox Data" folder on the desktop to the current Firefox profile folder.

Betaguy001 0 solutions 1 answers

Helpful Reply

Why is Firefox always trying to connect securely?

THAT seems to be the issue. There is no need to connect securely to Google, for example, but when a link to Google is chosen versus typing the url in directly, FF tries to connect securely and this problem surfaces.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi Betaguy001, Firefox connects to Google securely for your privacy so that your searches and results cannot be (easily) intercepted and read. If you prefer to use an HTTP connection, you can add a different Google search plugin and select it from the drop-down next to the search bar. See this post: https://support.mozilla.org/en-US/questions/970785#answer-477875

But there are many other secure sites on the web, so if you are using a product that filters SSL, you will need to fix the problem sooner or later (either by importing a certificate into Firefox to trust your product, or by turning off the filtering of secure connections).

mohammadmikaeel 0 solutions 4 answers

this problem when i change my motherbord , Happened. i solved this , by set the time & date in windows & mainbord time in bois . it's fixed.