X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Some username/password forms are not filled nor give a selection.

Posted

One some websites (most recently https://tinkercad.com) FF does not give me a selection of my saved username/password combination on the sign in screen. It works fine on most of my other sites, like a roundcube installation or any of the dozens of other sites requesting login/password, even the ones with autocomplete=off which I removed using a bookmarklet.

As I'm using both throwaway mailaddresses and randomly generated passwords, the save password function is essential for me. How can I make it work with tinkercad.com?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Citrix Receiver Plugin (Win32)
  • Content Server - WebDAV View

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Edge 2.0.4 ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AutoAuth 2.1 (autoauth@efinke.com)
  • BugMeNot 2.2 ({987311C6-B504-4aa2-90BF-60CC49808D42})
  • Content Server - WebDAV View 10.0.1 (otnpdavview101@opentext.com)
  • DownloadHelper 4.9.17 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DuckDuckGo Plus 0.2.49 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Enhanced Steam 3.7 (jid0-SmvlvxGpvCyG252KbVMqIKR79Uc@jetpack)
  • Firebug 1.11.4 (firebug@software.joehewitt.com)
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Greasemonkey 1.10 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • NoScript 2.6.6.9 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Password Reuse Visualizer 0.13 (jid1-bOHVlh4oBvBc7A@jetpack)
  • Remove It Permanently 1.0.6.10 ({1dbc4a33-ea62-4330-966c-7bdad3455322})
  • SyncPlaces 5.1.0 (syncplaces@andyhalford.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Unhide Passwords 1.2.7.0 ({2e17e2b2-b8d4-4a67-8d7b-fafa6cc9d1d0})
  • Visual Hashing 0.3 (jid1-NzIEzRc5sYX4Ww@jetpack)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'8.1500.1000.2202']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 7-28-2009
  • driverDate2:
  • driverVersion: 8.15.10.1855
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.urlbar.default.behavior: 2
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • keyword.URL: http://www.bing.com/search?FORM=UP97DF&PC=UP97&dt=072313&q=
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • network.prefetch-next: False
  • places.database.lastMaintenance: 1375343155
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104759
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1374479985

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Question owner

The problem is still there in safe mode. I've also tried clearing the offline cache and cookies as well as using an entirely new profile.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Can you try disabling all extra Addons (universal) in Firefox Button > Addons?

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

This page uses a shadow box and possibly JavaScript (AJAX) to generate and handle this form.
The built-in Password Manager may not work in cases like this.

You can use this extension to save the password, but most likely Firefox won't fill it either in that case.
But at least you can paste the password from the Password Manager.

Question owner

@Waka_Flocka_Flame: As mentioned before, I tried it even with an entirely new profile, which did not have any addons.

@cor-el: Thanks for the hint, but as I mentioned, the password DID get saved, it just isn't inserted into the form.