X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashed during youtube video play back

Posted

I have just done a complete fresh install of the latest Linux Mint 64bit with cinnamon desktop. I have not installed ANY programs other than those st up by default with the installation and obiusly a totally clean install of firefox with no plugins installed other than the defaulr set up as part of the installation of Linux Mint.

The following is from the troubleshooting page


 Application Basics
       Name
       Firefox
       Version
       22.0
       User Agent
       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       Mint Search Enhancer
       1.0
       true
       mint-search-enhancer@linuxmint.com
       Stylish
       1.0.7
       true
       {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
 Important Modified Preferences
     Name
     Value
       accessibility.typeaheadfind.flashBar
       0
       browser.cache.disk.capacity
       358400
       browser.cache.disk.smart_size_cached_value
       358400
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size.use_old_max
       false
       browser.places.smartBookmarksVersion
       4
       browser.startup.homepage
       http://www.linuxmint.com/start/nadia
       browser.tabs.loadInBackground
       false
       extensions.lastAppVersion
       22.0
       keyword.URL
       https://duckduckgo.com/?t=lm&q=
       network.cookie.prefsMigrated
       true
       network.protocol-handler.app.apt
       /usr/bin/apturl
       network.protocol-handler.app.apt+http
       /usr/bin/apturl
       network.protocol-handler.warn-external.apt
       true
       network.protocol-handler.warn-external.apt+http
       true
       places.database.lastMaintenance
       1375134698
       places.history.expiration.transient_current_max_pages
       97058
       plugin.disable_full_page_plugin_for_types
       application/pdf
       plugin.importedState
       true
       privacy.sanitize.migrateFx3Prefs
       true
       storage.vacuum.last.index
       1
       storage.vacuum.last.places.sqlite
       1375050382
 Graphics
       Adapter Description
       nouveau -- Gallium 0.4 on NV4C
       Device ID
       Gallium 0.4 on NV4C
       Driver Version
       2.1 Mesa 9.0.3
       GPU Accelerated Windows
       0/1 Basic
       Vendor ID
       nouveau
       WebGL Renderer
       nouveau -- Gallium 0.4 on NV4C
       AzureCanvasBackend
       cairo
       AzureContentBackend
       none
       AzureFallbackCanvasBackend
       none
 JavaScript
       Incremental GC
       true
 Accessibility
       Activated
       false
       Prevent Accessibility
       0
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.9.6
       4.9.6
       NSS
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSSMIME
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSSSL
       3.14.3.0 Basic ECC
       3.14.3.0 Basic ECC
       NSSUTIL
       3.14.3.0
       3.14.3.0

No crash reports have ben submitted as I was not able to get back to my desktop without re booting my PC as I was in full screen mode and Alt-Tab allowed me to tab through open applications they did not actually switch to the fore ground leaving me with the cideo paused at the point Firefox crashed. I was able to see the firefox has crashed window whilst Alt-Tabbing but not able to switch to it.

I was watching this http://www.youtube.com/watch?v=05x1Jk4rT1A youtube video in full screen mode. when firefox crashed.

I have been experiencing this a lot on my old Ubuntu installation but put it down to possible conflicts with other installed software or installed plugins. In fact I got so frustrated with this that I switched to using Google Chrome which had no issues like this whatsoever.

However I thought I would give Firefox another go on a fresh installation to see if anything had improved.

I have read many posts and seen plenty of reports of this issue but sadly no solutions go back through lots of versions of Firefox.

I'm using the default open source video drivers.

I'm going to go back to using Google Chrome as it is far more sxtable so there is no urgency to resolving this issue but maybe you can find some solution to this seemingly common problem as I have a bit of a soft spot for Firefox and am kinda sad that this issue still exists after all this time.

I am happy to try things out if it is of any help

Additional System Details

Installed Plug-ins

  • The IcedTea-Web Plugin executes Java applets.
  • Shockwave Flash 11.2 r202
  • This plugin provides integration with Cinnamon for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • DivX Web Player version 1.4.0.233
  • The Totem 3.4.3 plugin handles video and audio streams.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Helpful Reply

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Question owner

Disabling hardware acceleration had no effect whatsoever.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Do you have any crash ID now under about:crashes?

Question owner

None yet

Question owner

Ok I've got one

	927fd097-6c72-4ba3-a43a-859842130813
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

a submitted crash id starts with the prefix bp-, so submit it then try again.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

This report has been submitted:

Looks like a memory problem with garbage collection.

I also see a mention of linux-gate.so
This is not a real program, but a way to access the kernel.

Helpful Reply

Thanks cor-el If there is anything that you recommend I should do?