X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want to enable Java on one site but there is no red icon to click

Posted

I run Windows 7 and it is automatically updated. My Firefox is up to date as is Java. I want to run the PCH.com games that require Java but I see no red icon. I want to enable Java only on this site which I want to play daily. I've read the various articles and support answers but either they don't help, aren't relevant or are just confusing to a mid-level user. So, how do I work around so that I can play the dang games?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • Google Update
  • Shockwave Flash 11.8 r800
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • WildTangent Games App V2 Presence Detector
  • Facebook Video Calling Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • NPWLPG
  • Yahoo Application State Plugin version 1.0.0.7
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DoNotTrackMe 2.2.9.618 (donottrackplus@abine.com)
  • LastPass 2.0.20 (support@lastpass.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Webmail Ad Blocker 3.9.1 (gmailnoads@mywebber.com)
  • Content Blocker 13.0.1.4307 (content_blocker@kaspersky.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4307 (url_advisor@kaspersky.com) (Inactive)
  • Virtual Keyboard 13.0.1.4307 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 8-31-2011
  • driverDate2:
  • driverVersion: 8.15.10.2509
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1374887440
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 0
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.csp.enable: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1373924115

Misc

  • User JS: Yes
  • Accessibility: No
smo 45 solutions 498 answers

I am just guessing, but then again, it may help: I opened PCH home page and there's no red icon, as you reported. Possibly the home page does not need Java, so there's no reason to display the red icon.

What happens, if you go a little deeper into the site?

Question owner

When I sign into PCH and try to open any of the games they still will not appear, I've tried to open PCH from email links and by directly opening it. I still get no icon to enable JAVA. I've contacted PCH and they say contact Java who then tells me it's a problem with PCH. I went into FireFox add-on page and tried to enable Java across the browser but still nothing on PCH. I've checked that I have the latest Java and I do. Still at a loss as to what to do.

Question owner

I've downloaded the latest update for FF which added to my add-on page "JAVA (TM) Platform SE 7 U25 10.25.2.17 Next Generation Java Plug-In". Even this doesn't change the problem. I still cannot get any of the actual games on PCH.com to open. I am so lost on this. There has to be a way to get this to work. The program is set to "Always Activate".

Modified by haiweepp

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You seem to be in Private Browsing mode (browser.privatebrowsing.autostart:True).

Does it work if you leave Private Browsing mode?

MGPfls 0 solutions 11 answers

I'm having the same issues. I am just trying to go to Experience Project, Facebook and other News Sites. Taking 5 minutes to get some things loaded on my Page. My Computer is saying to Download the latest Java and when I say (Yes). It finds out I already have it. I get the (Add-On) Page and Java has its List ... (Don't Activate) or (Ask To Activate) I have (X) (Ask To Activate) and my Web Sites are not (Asking Me To Activate) or am I getting a Red Icon to Activate (Java) to my Web Sites. So What Gives? How Do I get my (Activating)? To Show and Come about? When This is not being very well Addressed! Been a problem all year, but I never been able to understand what is going on, then getting very little information as each month passes to lead me here (Now)! I Hope to get a Good Answer, before I use an Paper Mail Address and send something this way by Next Month being Very Annoyed!

Modified by MGPfls

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You either see a placeholder for the plugin on the web page where you can click to activate the plugin or you get an icon on the location bar that you can click.

Does it work if you select "Always Activate"?


If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

MGPfls 0 solutions 11 answers

Helpful Reply

To: "cor-el" When I go to (Tools > Add Ons > Page in my Browser)

Everything says: (Always Activate) But for JAVA. I don't have that Choice. I have as for 2 kinds of (JAVA) (Toolkit) & (Platform) with a Red Triangle / ! \ in them. Without having a (Always Activate) in it for my Choice. It's either (Never Activate) or Just (Ask To Activate) This is my Point. Nothing is Asking Me. If my Web Pages are not loading through (JAVA) I am not getting Firefox Browser Notification, but a Computer one. Please Up Date Java. Java not working. And nothing else can I find to Activate it. I don't have any Extensions Running. Nothing at all that I see from this. I am on (Phone Line Dial-Up Modem) and everything downloading is so slow that it seems like (JAVA) is looking for a Frequency Air Pick up than Modem downloading. (?) Plus my Adobe Flash and Shock Wave is giving me Trouble along with it, (Adobe Flash does not work for me) but my Add On's from these others are saying in the List (Always Activate) Also.

smo 45 solutions 498 answers

ignore - the answer posted in the wrong thread

Modified by smo

sgfreiman 0 solutions 1 answers

Helpful Reply

I don't think I'm in private browsing mode, but if I am, how do I leave it?

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

See:

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

Is the Java plugin present in Firefox/Tools > Add-ons > Plugins ?

If yes, that what is the setting for this plugin?