X
Tap here to go to the mobile version of the site.

Support Forum

How can one turn off the notifications in FF 22 (e.g. when you get an email on gmail) so that it doesn't override things like Growl?

Posted

Hi,

I'd like to find a way to disable the notifications on Firefox 22.0 (I'm running it on a MacBook Pro with OS X 10.7.5), especially when receiving emails on my gmail account. I used to use Growl (1.2.2; as far as I understood, newer releases have significant issues) for that kind of stuff and it was way better: it looked better and, most importantly, it could be seen from any desktop, i.e. not only on the Firefox window itself. But now it's overridden by Firefox and I found no way to avoid it...

Cheers

Hi, I'd like to find a way to disable the notifications on Firefox 22.0 (I'm running it on a MacBook Pro with OS X 10.7.5), especially when receiving emails on my gmail account. I used to use Growl (1.2.2; as far as I understood, newer releases have significant issues) for that kind of stuff and it was way better: it looked better and, most importantly, it could be seen from any desktop, i.e. not only on the Firefox window itself. But now it's overridden by Firefox and I found no way to avoid it... Cheers

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.7 r700
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6
  • 5.1.10411.0
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
4148 solutions 31251 answers

Firefox doesn't have notifications such as that. More than likely that notification is provided by an an add-on that you installed in Firefox.

See this support article:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

Firefox doesn't have notifications such as that. More than likely that notification is provided by an an add-on that you installed in Firefox. See this support article: <br /> http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

Question owner

OK. Indeed, the notification itself seems to be coming from the add-on that checks my gmail accounts (gmail checker, which was recently updated), in the sense that if I disable "Show notification popup" in its preferences, I get no notification. The thing is I still have no notification from Growl. I should also say that this option was normally enabled.

But something is weird though: I reverted to an older version of the add-on and it changed nothing. Furthermore, the notification that pops up when I receive an email looks exactly the same as the ones you get when a download is complete. Finally, as far as I can tell, the change in behaviour of all this happened when updating Firefox. And if I come back to FF 20.0.1 (chosen quite arbitrarily), I get the things the work the way it did...

All this makes me think that, although the notification comes from the add-on, there is something to understand in the way it interacts with Firefox. Is there a way to tell Firefox to stop showing notifications of any kind (either for download completion or coming for add-ons)?

Thanks for the help! I'll also try to see if it's something that the developers of the add-on are familiar with.

OK. Indeed, the notification itself seems to be coming from the add-on that checks my gmail accounts (gmail checker, which was recently updated), in the sense that if I disable "Show notification popup" in its preferences, I get no notification. The thing is I still have no notification from Growl. I should also say that this option was normally enabled. But something is weird though: I reverted to an older version of the add-on and it changed nothing. Furthermore, the notification that pops up when I receive an email looks exactly the same as the ones you get when a download is complete. Finally, as far as I can tell, the change in behaviour of all this happened when updating Firefox. And if I come back to FF 20.0.1 (chosen quite arbitrarily), I get the things the work the way it did... All this makes me think that, although the notification comes from the add-on, there is something to understand in the way it interacts with Firefox. Is there a way to tell Firefox to stop showing notifications of any kind (either for download completion or coming for add-ons)? Thanks for the help! I'll also try to see if it's something that the developers of the add-on are familiar with.
cor-el
  • Top 10 Contributor
  • Moderator
13065 solutions 119648 answers

You can set the Boolean pref dom.webnotifications.enabled to false on the about:config page to disable web notifications.

You can inspect and manage the permissions for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.


You can set the Boolean pref <b>dom.webnotifications.enabled</b> to <i>false</i> on the <b>about:config</b> page to disable web notifications. You can inspect and manage the permissions for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab. *Tools > Page Info > Permissions *https://support.mozilla.org/kb/how-do-i-manage-website-permissions ---- *https://developer.mozilla.org/en/Mozilla/Firefox/Releases/22#DOM