Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

No sound in Firefox 22

  • 7 replies
  • 1 has this problem
  • 1322 views
  • Last reply by AliceWyman

more options

Since I updated to Firefox 22 I have no sound with Firefox. I believe this might be because older versions of Quicktime have been disabled by Firefox but I have the latest version - 7.7.1 which does NOT appear to have been disabled. When I return to Firefox 21 the sound is OK again.

Does anyone else have this problem? Is there a fix?

All Replies (7)

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Thank you for you answer Tylerdowner. I have since discovered that it is only wav files that do not work, or at least one specific wav file which is the new email notification for my webmail, which is a wav file. My Applications Preferences are set to play Quicktime for wav files so I don't know why it doesn't work.

I am reluctant to follow your advice and reset Firefox because it seems I will lose all my extensions and some preferences if I do this so this would be quite extreme action as I have a lot of extensions. I am not convinced that Firefox actually needs resetting. It is only with Firefox 22 that I have the problem with. Every time I switch back to Firefox 21 it is OK again and the sound plays.

However if this problem lasts a long time and does not correct with future versions of Firefox then I will try the reset option. Thanks again.

more options

Is this is the case with all plugins or are only some plugins affected?

Does Flash work?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
more options

Thank you for your input, cor-el.

1. I tried the Safe Mode but no joy there.

2. I tested the Flash Player. It was fine.

Modified by Sun-flower

more options

Did you try the test page for the QuickTime plugin?

more options

I have tried several Quicktime test pages. Some work and some don't so I don't know if the plugin is working or not. I have the latest version.

more options

Sunflower, you started a new thread on the same problem earlier today, here,

Both threads have current replies but the new thread has more information, including the fact that the problem is only with the new mail notification wav sound in your www.Cotse.net Webmail.

I'm going to lock this thread. Please add any new information you may wish to add, here in the newer thread: