X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do you stop lists of previous comments from popping up in Facebook when you try to enter a new comment?

Posted

I have the same problem as this person but the response to him didn't have anything to do with the mobile version (even though it's right there in the title): https://support.mozilla.org/en-US/questions/961467?esab=a&as=aaq

I'm running mobile Firefox 22.0 on a Nexus 4 and recently (this week I think) Firefox has decided it would be great to list every single comment that I've made on Facebook when I go to enter text in a comment field. It's extremely annoying and aggravating since it blocks the rest of the page while you're trying to type. I've been using FF for almost 15 years now on my desktop and the last 2.5 years on my mobile phones. Never seen this kind of problem and I have scoured for a solution to no avail.

I tried clearing the cache but that didn't help. I'm hesitant to clear the data or I'll lose my bookmarks (I'm not good at backing them up and won't take the time regardless) and whatnot but oddly enough somehow FF is only around 20 Mb yet it's bloated up to almost 120 Mb for some reason. I can't even find a setting to tell it how much memory to use for temp/cache files. I don't recall it ever getting anywhere near that bloated on my Thunderbolt.

I don't recall installing any updates recently. I haven't changed any settings. Nada. It seems to only be on FB's site too as I entered some info in my bank's website to test and when I reloaded and went to enter text in to the same fields there was no "history". It just started doing it all of a sudden. If I can't figure it out soon I will have to uninstall it. Please help.

On a side note not being able to access your bookmarks without opening another tab is simply, well, stupid. Took me a little while to figure out where they were hiding. It used to be in the menu but I realize that ICS was a little while back.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

I'm assuming this is from the Form Autocomplete feature.

To clear saved entries just for that feature, you can try:

Menu > Settings > Clear Private Data

Deselect everything except "Form & Search History"

Does that work? (Article: How do I clear private data on Firefox for Android?)

There may be a way to disable the feature, let me try something...

Modified by jscher2000

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Helpful Reply

To prevent Firefox from displaying form autocomplete suggestions, you can turn off that feature using the about:config page.

In the address bar, type or paste about:config and tap the Enter/Return key.

I suggest bookmarking this for easier future access.

In the search box, type or paste formf and tap the Enter/Return key.

Scroll down to browser.formfill.enable and tap the Toggle button to switch it from true to false.

That's it. Does it work on Facebook?

The about:config preferences editor in the mobile version is similar in principle to the desktop version but many of the preferences available on the desktop version have no effect in mobile. This one I only tested on one site, but it seems to work.

Question owner

Thanks! Not sure how I missed that option. It was driving me nuts. It was the form history. I also figured out the bookmarking thing. Helps to pay attention to what shows up when you tap the address bar :P