X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox have so many unresposive script errors?

Posted

Firefox 22.0 (on Mac) seems to be a dog. It continually stops responding and gives so many "A script on this page may be busy, or it may have stopped responding" errors.

Either Facebook have done something, or there is an incompatibility between Flash, Firefox and Facebook or something. (Flash 11.7.700.225)

I have had this before with other Firefox builds - but this time it is occurring multiple times each time I am on Facebook

Thinking of trying Chrome if this keeps up - although I am reluctant to hand yet even more privacy info over to Google.

The only plugin I use is Flash. I run the default theme, and the only add-ons I have are Adblock Plus 2.2.4, Adblock Plus Pop-up Add-on 0.8 and the English (Australian) Dictionary 2.1.2

I wish each so-called 'security upgrade' came with a message that 'this version is a dog' - it is not only causing issues it is not compatible and has disable my "Easy Youtube Video Downloader 6.8"

As per the Mozilla Help I have disabled "hardware acceleration" and also changed the value for "dom.max_script_run_time" to 20 - neither helped in any way.

Far from happy Mozilla

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3023 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Helpful Reply

Thank you for your "copy and paste" reply. It is very obvious that you did NOT read my original post.

If you had you would have noticed:

a) I stated: "I run the default theme" and that

b)I stated: "I have disabled "hardware acceleration""

c)I stated: "changed the value for "dom.max_script_run_time" to 20 " (both of which are in response to the linked help article that you recommended - and neither of which did any good)

d) I also stated: "The only plugin I use is Flash" (which is the latest up-to-date version and if Firefox cannot run with Flash it is of no use as a browser)

I will try "Safe Mode" and post how that works after browsing Facebook - but it should not be necessary to do this.

I had reported similar issues with Firefox two or three builds back (Firefox 19.0.2) then the issue was fixed for a couple of builds - and now with the release of Firefox 22.0 (on Mac) it is as bad or worse than ever.

Modified by over_it

rwg215 0 solutions 2 answers

You might need at least 3 GB (gigabytes) of RAM (Random Access Memory) to get rid of script errors.

I had the same problem with my computer for many, many months, slowing down my computer to a halt. However, once I upgraded to 3GB of RAM the problem COMPLETELY disappeared. I had only 1GB of RAM in my computer prior to that.

I had tried all of the other suggested fixes as well such as resetting Firefox, uninstalling Webroot Anti virus, turning off add ons, etc. Nothing worked. However, upgrading my RAM did work.

Right now, while I am writing this, I have over 80 tabs open in Firefox (yeah...I'm interesting in a lot of topics). However there is not a single script error or Flash problem taking place. Before the RAM upgrade however, I might only have four tabs open and my computer would freeze up with script errors.

I also noticed that computers that had at least 3GB of RAM did not have the script error problem even if they were running Webroot Anti-virus.

Please let me know if this apples to you (i.e., you have less than 3 GB of RAM) and if it does and you upgrade, let me know if the upgrade works. I bought my RAM at www.crucial.com They were very good on delivery and service. The website will even scan your computer and tell you what type of RAM you need and instructions on how to install it.

How much RAM do you have?

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

John99
  • Top 25 Contributor
  • Moderator
624 solutions 8068 answers

over_it

Not sure where you got the advice about

and also changed the value for "dom.max_script_run_time" to 20 - neither helped in 

Apparently not from a reply to your question here. Although both that and disabling Hardware Acceleration were suitable trouble shooting ideas.

It may help anyone assisting you to know the exact messages that you get from the unresponsive scripts.


rwg215

Probably rather an over generalisation. More memory often does help. And it may help to minimise the number of open tabs.

Release notes are often rather over optimistic when stating minimum specs, as everyone is after good performance not minimal performance. The memory requirement is for a minimum of 512MB


You can hardly expect every letter of a reply to be always manually typed. We are nearly all just other users of Firefox helping one-another.