Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF22 How do I get rid of the icons, to have only text, in my bookmarks toolbar?

  • 3 replies
  • 2 have this problem
  • 17 views
  • Last reply by kiwiallan

more options

Just recently, for reasons unknown and not having done an upgrade, I now have both icons and text showing on my FF22 Bookmarks Menu – up till now it has been only text (my preference).

I have had until now – and continue to want – icons showing on my Navigation Toolbar, and text only on my Bookmarks Toolbar ... but I can't get this in 'Customise settings'.... which gives me this result:

'Text' - only text on both toolbars 'Icons' - icons on the Nav. T/B; icons+text on the Bookmarks T/B 'Icons + Text' - icons + text on both toolbars.

I see some advice on how to get rid of favicons/icons, but nothing helpful specifically about customing only the Bookmarks T/B to just text.

Thanks for any help anyone can provide.

– Allan

Modified by kiwiallan

All Replies (3)

more options

The Deiconizer extension you have been using is broken. It first broke in Firefox 20, but now it's really broken.

Please see this thread: How do I keep the icons out of my Bookmarks Toolbar (tried Bookmarks Deiconizer) even after downloading files?

more options

Add code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item .toolbarbutton-icon { display: none !important; }
more options

Thanks cor-el and jscher 2000.

Done – and the result is just as I had hoped for. Appreciate your prompt advice.

Modified by kiwiallan