Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why, everytime I upgrade Firefox and then go to Facebook, am I told my Firefox version is an old one and poses security problems?

  • 3 replies
  • 3 have this problem
  • 179 views
  • Last reply by John99

more options

I keep upgrading Firefox and know, from my list of programs, that it's the latest version. But when I click on my Facebook account, it tells me, repeatedly, that I have an out of date version of Firefox, which poses a security risk. It's driving me mad!

All Replies (3)

more options

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

more options

your useragent (the information the browser sends to websites to identify its version) - apparently mistakenly - shows you're on firefox version 3.5. probably some sort of toolbar or adware has overwritten it. please refer to this article in order to reset the user-agent settings in firefox: Websites say that Firefox is outdated or incompatible even though it's the latest version

more options

Consider whether you need Fast Browser Search and either uninstall it permanently, or at least uninstall it and try to install the latest version. The latest version should not corrupt your User Agent string. (Let us know if it does)

Modified by John99