Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I re-enable "Remember Passwords" after disabling it.

  • 10 replies
  • 40 have this problem
  • 13869 views
  • Last reply by Jer

more options

I have seen a lot of answers here that don't appear to understand the real problem. The key here at one time I chose to DISABLE the reminder on the pop up. The "Do you want Firefox to remember this password" box doesn't pop up anymore.

All history has been cleared, all sites and passwords have been cleared. Under "Security" tab "remember passwords for sites box" is checked and under "Privacy" tab "Always use private browsing mode" is disabled.

The last time this happened, I uninstalled/re-installed Firefox. Is that the only solution?

All Replies (10)

more options

It sounds as though you might have checked one or both of these, but just in case:

(1) Password site exceptions list:

orange Firefox button (or Tools menu) > Options > Security

Click the Exceptions button to the right of "Remember passwords for sites" and remove the site if it's listed there.

(2) Site permissions page

In a new tab, type or paste about:permissions in the address bar and press Enter. Can you find the site and change its Store Passwords permission to Allow?


An alternate way of clearing history for a site that clears site-specific details in more places is as follows:

Open the Library dialog to your history using Ctrl+Shift+h or History > Show All History

Right-click a history entry for the site and choose Forget About This Site -- note that this also will remove any bookmarks for the site.

more options

Thank you for your response but, neither of these helped with the problem. I have seen other questions about this topic. I would think there would be an easy, well known solution to this. I guess once you select the "disable reminder" option on the pop-up box that asks you if you'd..."like Firefox to remember this password" you can't go back and enable it, you have to uninstall/re-install.

more options

Generally speaking, uninstalling and reinstalling Firefox doesn't change a site-specific setting. Or are you saying that Firefox will not prompt you to save a password on ANY site, whether you've visited before or not?

more options

To see whether the problem is related to data stored in your Firefox settings, a quick test is to try out a new Firefox profile.

Exit Firefox and start up in the Profile Manager as described in this article:

Profile Manager - Create, remove or switch Firefox profiles

In creating a new profile, I recommend using the default location suggested, and to avoid data loss, not choosing any existing folder location.

Does Firefox offer to save passwords in the new profile?

You can switch back to your regular profile by exiting Firefox and starting up in the Profile Manager again. I recommend backing up all your profiles before deleting any of them, just in case something goes wrong in that process.

more options

Here's what happened as best as I can remember. Maybe someone repeat this to see if the same thing happens. In the pop up box that asks you if you'd "like Firefox to remember this password" there is an option to disable, the box will no longer pop up and ask you if you'd like to remember passwords. How to you re-enable this once you have selected "disable".

more options

After doing "something," now the only place the "remember password" box isn't opening up is in yahoo mail.

more options

Yahoo! mail might be a special case; check out this thread from over the weekend: Saved username and passwords no longer works on Yahoo Mail.

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Websites remembering you and automatically log you on is stored in a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Make sure that you do not run Firefox in Private Browsing mode.

Do not use Clear Recent History to clear the "Site Preferences" and the "Cookies" as this doesn't take exceptions into account, but removes all specified data.

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

more options

Thanks for all the help! Tried everything, Yahoo still an issue, I'll keep tinkering around and see what happens.

more options

I have same problem, but only with a new yahoo user. My old yahoo user ids work fine in, but one Yahoo user I added will not prompt to save password. Other sites will prompt to save password, the Mozilla site did fine. I have run in safe mode and the results were the same. Autofillforms is True. I am on version 22 of Firefox. I did just update to Ver 22, So the problem, with me, is just new Yahoo users and also when I change a Yahoo user password, it doesn't prompt me anymore if I want to update. I guess you could say it is a Yahoo problem, but then again i didn't have the problem prior to Ver 22. This all started because I like to change passwords every 30 - 60 days.

I should add, password changes made to Gmail and Facebook did get prompted to update new password. So I guess we know where the problem is?