X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Getting a 502 Bad Gateway - nginx on 1 website only

Posted

Using Firefox 22 I am getting a "502 Bad Gateway - nginx" only on some pages on forum at http://forums.azbilliards.com/index.php Only happens in Firefox---- no problems with IE or Chrome cleared cache and restarted pc,, no help,,, only started this on Saturday.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • VLC media player Web Plugin 2.0.6
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Helpful Reply

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Helpful Reply

Safe mode did not help,, still got the error.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Question owner

This seemed to work. Thanks for the help

iceman21 0 solutions 15 answers

I have this issue on one web site as well and only by doing the above answer 'forget about this site' works. I have tried every other option and I mean every other option. The 502 bad gateway problem for me started 2 weeks ago, but the difference for me is that I get it using IE10 as well! I have spoken to the web site director who replied to me by saying yes others have this issue as well and it is being looked at. It is not a serious issue for me, just a nuisance, it affects me by not being able to log off of a site, just logged in all of the time unless I do the 'forget about this site' in the history bit. My affected site for reference is the AVForums site, a very good site by the way for people who like to discuss I.T issues.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.


Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

iceman21 0 solutions 15 answers

Thank you for such a detailed reply, I appreciate it. I had tried most of the things that you have suggested and yes I did the full malware scan amongst others. Whilst I did these scans I did not think that my system was infected for 2 reasons, the first was no decrease in performance and the second reason was that other people who use this particular web site also have the same problem. I believe that it is an issue with this site and will be fixed shortly as I was informed. For the record I had also tried earlier versions of Firefox to no avail. I am however confused that it appears that others if I am reading these posts correctly have similar issues with different web sites, now that is a puzzle. I think that I will watch this forum closely and look out for the developments.