X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't Make Spellcheck Work

Posted

Last week I got a new computer and therefore had to reinstall Firefox. I can't get the spell checker to work. Here are a couple of screen captures. I couldn't figure out how to post a picture so I'm giving a link to the picture. The top is the menu that shows spell checking is active and the bottom one shows it isn't checking. The English (US) dictionary is the one being used.

http://img850.imageshack.us/img850/4089/dvhj.png

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • 5.1.20125.0
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:


You can't attach a screenshot to the first post that starts a thread, but you can do that in subsequent replies.

Helpful Reply

here's the screenshot.

Question owner

Going into Safe Mode did not change anything.

As stated in my original post, my dictionary is English US

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You need to check the right-click context menu in the text area and look in the Language sub menu.

Helpful Reply

That's how I know what dictionary it's using.

speedracer1957 0 solutions 1 answers

I've done everything you suggested on this page. Made sure the English dictionary was loaded, started in Safe mode, and made sure it was enabled. It still doesn't work. When I right-click on the red underlined word I do not get a menu with suggestions or a menu that says anything about languages.

purplequeennl 0 solutions 1 answers

I have been having this problem too. I read this thread and I first went and installed the dictionary add on (even though it should already be added, I installed it again). Then in the text box, I right clicked and selected 'Check spelling' and suddenly all the incorrect words were highlight with the red-underline.

I have no idea why mine stopped using it, but now it is working.

Modified by purplequeennl