Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fortinet SSL VPN Client plugin is not installed on your computer or it is not up-to-date. (It is also possible that your browser setting blocks the running of t

  • 8 replies
  • 71 have this problem
  • 1 view
  • Last reply by LBANKS

more options

I do have this client installed and it is not disabled. It worked until I upgraded firefox to version 22.How do I get this to work with the new version?

I do have this client installed and it is not disabled. It worked until I upgraded firefox to version 22.How do I get this to work with the new version?

All Replies (8)

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

Thanks for the reply. I went in to the site and the only ones that needed update were adobe reader and google earth. The fortinet plugin was listed but it was listed as unknown. When I get a chance, I am going to check my laptop that does work. I want to see what version of firefox my laptop has. I suspect that going to the latest version of firefox caused this plugin to not work.

Do you have any other suggestions? Thanks Dave

more options

I am having the same issue. I have a laptop with a fresh install of Firefox 22 and I get the message that the Plugin is not installed. I followed the link shows unknown. I checked on other PC that had Firefox 21 and it was working fine. I soon as I upgraded it said that I need to install the plugin.

other things I have tried... uninstalling and re-installing. Disabled hardware acceleration. uninstalled and re-installed Forticlient.

Your assistance is very much appreciated.

more options

I suspect that plugin may need to be updated or fixed for Firefox 22. The Plugin Check page is really only concerned with the most popular plugins out there, the ones that are most vulnerable to being exploited and have the largest user base - like Flash, Java, Adobe Reader, QuickTime, and ReaPlayer.

You may want to post in the Fortnet support forum.

more options

In have the same problem since version 22. When i check de update of the plugin all is installed correctly. Please say me what to do ?

more options

I had the same problem and I solved it by restoring WIndows 7 to an earlier state. Obviously while doing so, Firefox 22 was deleted and Firefox 21 was put back. The VPN is working like a charm again!!

more options

According to Fortinet


This a known bug related to Firefox issue. SSl vpn client plugin's would not work if you are running Firefox version higher then 20 Reference to bug id (0211153).The purposed workaround at this time would be to download stand alone sll vpn client.Please see the link given below for downloading stand alone ssl vpn.> download sslvpnclient.msi

Regards Auns Yasin Fortinet TAC Engineer

If you have installed it when trying to use Firefox you can use that one. Also if it gets stuck at 98% see the following link.

This worked for me. Thanks for the support and good luck to everyone else.

Modified by aquamand

more options

I had the same problem, I just found that adding my VPN web site ( to the Compatibility View Settings found under the tools pull down in Internet Explorer fixed the problem. I don’t know if it’s a permanent fix, but it seems to be working ok for now.