X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get mp3 files to stream?

Posted

I installed Firefox on a new HD. Before when I clicked on a website mp3 audio file, it opened the file in the default player and streamed it in. This is what I prefer. But now, it automatically downloads the file and I must select it to play it. How do I change that to be as before?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 2.6.0.20130418072822 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 8300 GS
  • adapterDescription2:
  • adapterDeviceID: 0x0423
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-14-2007
  • driverDate2:
  • driverVersion: 6.14.11.5828
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372542330
  • places.history.expiration.transient_current_max_pages: 53638
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars
  • Top 10 Contributor
412 solutions 4871 answers

Could you provide the website url

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can open about:config via the location bar and set the media.windows-media-foundation.enabled pref to false to disable the built-in HTML5 media player.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

That file is send as Content-Type: audio/mpeg

So you need to have a media player that can handle this MIME type.

You can open the about:plugins page via the location bar to check that.

  • Tools > Options > Applications

You can delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.