X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Multiple problems since 22.0 update

Posted

Firefox updated itself yesterday. Before the update it had remembered my choice of different zoom levels for websites, including different zoom levels for different pages in websites. Now every page I go to in one website is changed when I either enlarge or decrease the text size on one page. It is annoying as hell to have to constantly change with CTRL/+ or /- every time on pages on a particular site. The larger size on all sites is annoying and I am constantly having to decrease the zoom level.

In order to be able to open a bookmark in a new window as I was able to in 21.0 I had to uncheck open new window in new tab instead. Why did 22.0 change my settings without asking? Now when I click a link in a site it always opens in a new window. Most annoying. I have to always right click to open in a new tab instead of new window. Never had a problem in 21.0.

The site for my TV listings no longer displays properly and is unusable in Firefox.

I want to go back to 21.0 if these bugs cannot be worked out.

Have poor eyesight and this new update has made working on the computer very difficult, totally frustrating, and much more time consuming. I have a 23" widescreen monitor set at 1920 X 1080 that properly displays all other software.

Please help.

Chosen solution

You can set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 (current default value is -1.0) to restore the behavior of previous Firefox versions.
If you need to adjust the dimensions of icons on toolbars the adjust the value of this pref in steps of 0.1 or 0.05 starting with 1.0.

Use this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing the layout.css.devPixelsPerPx pref.


Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Google Update
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.20125.0
  • NPWLPG

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • Print Edit 9.3 (printedit@DW-dev)
  • Quick Translator 1.0 ({5C655500-E712-41e7-9349-CE462F844B19})
  • ReminderFox 2.1.1 ({ada4b710-8346-4b82-8199-5de2b400a6ae})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WOT 20130515 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-12-2012
  • driverDate2:
  • driverVersion: 9.17.10.2932
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.interval: 100000
  • browser.startup.homepage: http://www.ctvnews.ca/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.loadInBackground: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372432776
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed.show_once: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1371655986

Misc

  • User JS: No
  • Accessibility: No
Microrobot 10 solutions 117 answers

To fix the open in new windows. Click the Firefox button on the top left corner. Next go click options and go to General. Change to your liking. Also go to Tabs and select options to your liking.

xxraiser 0 solutions 2 answers

Helpful Reply

sorry

Modified by xxraiser

Microrobot 10 solutions 117 answers

(Removed ink)

Scroll down to English and hit download for the first button

Modified by Tyler Downer

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6640 answers

xxraiser, please start a new thread.

SueWitch, this is because Firefox is now respecting window's DPI settings.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi SueWitch, to expand on Tylerdowner's reply, Firefox previously did not automatically zoom the content area for high-DPI displays, and now it does. For example, if you set your Windows display to increase font sizes (e.g., 125% font size) Firefox zooms the content area by the same amount.

If this is too large in general, you can use an extension to downsize the content area. For example, you could install Default FullZoom Level and set it to 90% and see whether that strikes a good balance. You can still use Ctrl+ and Ctrl- to adjust from there as needed.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Firefox uses the about: protocol to access built-in about: pages that you can open via the location bar just like you open web pages.


If you do not keep changes after a restart or otherwise have problems with preferences, see:

Question owner

Microrobot, when FF 22.0 first started I tried right clicking on a bookmark to open it in a new window. All the options apart from OPEN were greyed out. Went to Tools, Options, Tabs and immediately unclicked to open new windows in a new tab instead. That was the only way I could open the bookmark in a new window. (I watch/listen to General Hospital while reading email). After that every link I clicked opened in a new window instead of replacing the page I was on. So I had to go back and click to check Open new windows in a new tab instead, to stop that happening.

I always turn off the computer each day. Now after restarting FF however, even with that box checked I am able to right click to open in a new window and a new window does open. Links I click will open in the same tab unless I right click to open in a new Window. So I guess that was a hiccup? Thanks for the info, but I had been there already.

Question owner

Jscher2000, I do have my Windows 7 set at 125%, without that everything is too small to read without a magnifying glass. All us older folk do that and most do not know how to ask for help, there are going to be a lot of angry FF users!! It seems from everything I have read it is just us hard of seeing who have chosen the 125% option that are having the problems. It would have been better for FF to have given us the option of using the new feature or not.

Some websites contain such tiny text that I have to use CTRL+ so many times to be able to read, others the text is so large CTRL- is the way to go. It is so frustrating. We should not have to install add-ons to reduce the text size. Will give your suggestions a whirl, although have read elsewhere that it did not solve the problem for a user. Thanks for the link.

Given how many people are having problems, I think I'll wait a while to see if a fix is made available in the near future. So many people are depending on me to find a really easy solution for them, most are not computer literate enough to look for answers or fix the problem themselves. I have tried hitting CTRL 0 and it does not reduce the size of the page content to the size it was in FF 21. How on earth does Mozilla expect senior citizens who are using their first ever computers to deal with this change?

This was the first time Firefox updated and I did not receive an email telling of the changes. Was there one? Usually when Firefox updates we are also taken to a page with information about the changes, that did not happen either this time.

Question owner

cor-el, sorry I am confused about what your suggestions should fix. Is it for adjusting the size of the content? Or for FF remembering my size preferences on different sites?

Did follow your first link about protocol_links but there is no text on that page. Is it only visible in FF safe mode?

Question owner

Waka_Flocka_Flame, I read those threads, boy lots of folk are having the same problem. Am trying to find the easiest fix for all the golden oldies I have to help. Nothing seems that easy so far. Will keep reading the newer posts in those threads. Thanks for posting them.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi SueWitch, Ctrl+0 will reset your content size to 125%. To reduce it, you can press Ctrl- or hold Ctrl and use the mouse scroll wheel.

Question owner

jscher2000, that is not working for me. On this thread Ctrl 0 jumps the text up two sizes! Also for one site that worked perfectly in 21 here is what happens in 22. I do hope trying to add this screen shot works. The link is

http://tvlistings.canoe.ca/tvlistings/ZCGrid.do?aid=canoe&loginRedirectReq=true

Modified by SueWitch

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

Note that you can add extra steps to the available zoom values.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi SueWitch, Ctrl+0 will increase the size if you previously decreased it. It will reset the display to Firefox's default. However, it's possible this could be modified by an add-on.

Regarding the TVListings site, it looks correct with JavaScript disabled, but if I enable scripts the top section does not center like the lower section. I'd have to delve deeply into their scripts to find the problem and time does not permit today.

attentiondesign 0 solutions 4 answers

Well that's totally annoying and very impractical for web designers! How am I supposed to see the "real" size of the pages in FF now? I compare between browsers and since the other ones don't do this, it's not an equal comparison. I don't want to set my Windows 7 DPI down to 100% and squint at everything else. Please someone remove this new stupid setting!!

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi attentiondesign, two topics here: (1) what you see, and (2) what visitors see.

Your Settings

I suggest setting your global scaling within Firefox back to 96ppi. This probably will make the font in the chrome area (menus, toolbars, and tabs) too small. Therefore, I suggest the following approach:

Step 1: Install the Theme Font & Size Changer extension.

Then click its icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This combination will give you the familiar view you had in Firefox 21 and earlier, but that's not necessarily what others will see.

Your Site

The baseline DPI has changed for many Firefox users on newer versions of Windows from 96ppi to 120ppi (100% to 125%) and there probably will be some with higher levels as well. On average the default "zoom level" on your site likely will be higher for Windows users than before. However, different users have always had different zoom preferences depending on their display so "real" and "normal" have not really been in your control for a while now...

It might be interesting to learn what zoom levels your typical visitor is using. Firefox has a property of the window object named window.devicePixelRatio you can use to gather than information. (As far as I can tell, the property isn't supported in other browsers.) For example, in the following page I'm using it to compute the actual screen dimensions from the dimensions reported by the JavaScript screen object:

http://dev.jeffersonscher.com/resolution.html

You can use Ctrl+ and Ctrl-, or Ctrl and the mouse wheel, to see how it varies with the zoom level. In theory, you could log this value. (I think capturing a value at the start of a session and keeping track of the final value during the session could be interesting.)

Modified by jscher2000

Eric Geller 0 solutions 1 answers

jscher2000: Thank you so much for alerting me to the Theme Font & Size Changer add-on. I had done the about:config fix for page text, but couldn't figure out how to increase the size of "chrome" text.

marv6 0 solutions 53 answers

I tried the layout.css.devpixilsperpx setting to 1.0 and it does not help much. Why cannot firefox use the same values it had in 21.0, where everything was ok for me. I kept trying to change the values and one time the text got so small I needed a magnifying glass to re set it. I gave up and went back to 21.0. Hope you fix this with the next update. We should not have to keep changing settings to get the correct size, when it was just fine in 21.0.

marv6 0 solutions 53 answers

I agree with some of the other comments that this is too much of a problem to fix every time I go on the internet and have to downsize the text to make it easier to read.

Modified by marv6