X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't play wav files on website

Posted

I was having a problem with my address bar so I uninstall Firefox and reinstalled the latest copy downloaded from Mozilla.

The download worked but I noticed that on one site I maintain that has a wav file on it I can no longer hear the file playing. I know it worked fine this morning before doing to uninstall/upgrade so the site is fine that I know.

I just assume it is a plug in that is missing but question is which plug in would be required to play wav files. I did find a post in the forums that lead to a trouble shooting page on the site and did download the Windows Media player plug in but that does not seem to have resolved this issue.

So what plug in will I need to play wav files? I did try videos on youtube and such and those work fine as do the help videos here on site.

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.0.3.13724
  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • Unity Player 4.1.2f1
  • Kalydo Player Plugin
  • 5.1.20125.0
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.2
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Question owner

Oh forgot also I have the VLC plug in also from my VLC player but even that isn't helping.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

A lot of plugins like WMP and QT and RP and VLC can be used to play wav file.
You only need to make sure that you specify a MIME type (content type) that the plugin supports like type="application/x-mplayer2" to use WMP or another plugin that supports this MIME type.

You can see the supported MIME types on the about:plugins page.

Question owner

Well I know I installed the QuickTime plug in also and it says wav is supported in the page you suggested above but for some reason it just won't play but I had a webmaster friend of mine test and it worked for her and I know before the reinstall it worked fine for me also just acted up after the reinstall

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Question owner

Do I need a system restart between as I deleted it and then reopened FF but still nothing. The file was recreated when I reopened FF that I know but still not sound from the website.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Question owner

At the moment I can't because of negotiations.

I do know though that the code is fine as I had a friend that I work with test it and she said the code is fine nothing on the page itself is messed up. I know last night it worked fine also and I did test the page in Explorer just to see and it worked fine in explorer. So is definitely an issue with my fire fox for sure!!

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Can you then post the code that is used or in case of a script, the generated code via View Selection Source?

Helpful Reply

<embed src="file link" hidden=true autostart=true volume=100 loop=false></embed>

this is the code minus the file name. As I said it's not the code cause it worked fine even this morning before I redid FF and my friend still is telling me it is playing fine.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You need to include an attribute to specify a content type like I wrote above to make this work.
Without a content type it will only work if there is a plugin that supports the file extension and that is usually only the QuickTime plugin.
type="application/x-mplayer2" is usually the safest to specify the WMP or another plugin that supports this MIME type.

<embed src="file link" hidden=true autostart=true volume=100 loop=false type="application/x-mplayer2"></embed> 

Question owner

Like I said it's not the code as even the mod you added did not resolve the issue. If it was merely that little bit then last night the code would not have worked. Plus as I said a friend tested it for me earlier and she reported it worked fine.

Question owner

I noticed tonight that my QuickTime was giving me this error 46 something about active x control not working. I tried reinstalling QuickTime and also iTunes but no good. I know VLC player has a wav plug in is there a way to make the VLC plug in the default wav plug in for Firefox?

I know on my own computer it's already the default wav player.

If QuickTime is corrupted is there a way to fix that so it works with Firefox as seems that could be my issue?!?!?

Question owner

I think I figured it out. Firefox says this version of QuickTime is out of date

QuickTime Plug-in 7.7.2

But this is the current download from apple from the official QuickTime site. so there is no way it can be out of date being their latest version. Most likely either Firefox has moved ahead of QuickTime in this regards of Firefox is lagging behind but somebody is behind. That said is there a version of QuickTime compatible with Firefox 22.0?????

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

On Mac the plugin block should only affect QT 7.7.0 and lower.

  • Bug 837377 - Plugin block request: QuickTime 7.7.2

Modified by cor-el

Question owner

Well my case on a windows system and I forgot to come back to update but even updating did not work must have been an old copy I had an installed by mistake during one of the attempts to get this fixed.

I think part of the issue is I get this error 46 Active X can't be found and seems to do with something in the registry not being able to open it, but what doesn't make sense at all is when I check the Firefox options it is saying that my VLC player is the plug in being used but it won't play the sound and in the options I don't even have a QuickTime option even though QuickTime does appear in my plug in list as active.

RozFruchtman 0 solutions 1 answers

I have the same problem on two computers. Both systems have Windows 7 Professional (64)

Originally one computer was automatically updated by FireFox, Would NOT play wav after that.

Laptop played fine.

THEN Firefox automatically updated on my Laptop and now Wav files DO NOT play with FireFox. Plays fine on Chrome and IE.

How does one STOP the autoupgrade?

FireFox is becoming a real nuisance.

Roz Fruchtman

Helpful Reply

This makes it sound more like it's a firefox issue rather then a specific system issue. I know I have quicktime and everything installed after my reinstall of the latest version but with you it should have just been an upgrade where your older versions plug ins would still be properly associated with firefox so if it played before it should play afterwards but where it doesn't it makes it seem like a bug in the newest version!

And I agree I have used firefox for long time now as I personally hate IE and Chrome forget it I tried it one afternoon and could not get rid of Chrome fast enough but FF is slowing getting to be an annoyance.

Modified by scottish2