X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

When i want open Facebook.com Firefox shows SSL error

Posted

i installed a fresh Windows 8 and Firefox 21. now when i want open Facebook.com Firefox shows this error:

Secure Connection Failed

An error occurred during a connection to www.facebook.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

 The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
 Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • IDM CC 7.3.50 (mozilla_cc@internetdownloadmanager.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • X-notifier 3.3.2 ({37fa1426-b82d-11db-8314-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 8400 GS (Microsoft Corporation - WDDM v1.2)
  • adapterDescription2:
  • adapterDeviceID: 0x0422
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16384
  • driverDate: 6-21-2012
  • driverDate2:
  • driverVersion: 9.18.13.286
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 8400 GS (Microsoft Corporation - WDDM v1.2) )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 348160
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.checkDX10: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372118211
  • places.history.expiration.transient_current_max_pages: 45145
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Can you access Facebook via a normal http connection?


Check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can also check your security software (firewall).

See also:

Question owner

My problem not fixed. Google Chrome opens facebook.com. on previous installed windows i didn't have this problem in Firefox.

Jingol 0 solutions 1 answers

Check your SSL settings

   On the menu bar, click on the Firefox menu and select Preferences...
   Select the Advanced panel.
   Click the Encryption tab.
   Verify that Use SSL 3.0 and Use TLS 1.0 are check marked.
       If both boxes are check marked, this section does not apply. You can skip to the next section.
       If both Use SSL 3.0 and Use TLS 1.0 are not check marked, check mark both of them. 
   Close the Preferences window 

Try to access a secure site again. If it still doesn't work, continue in the next section.