Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox keep redirecting me?

  • 4 replies
  • 24 have this problem
  • 6956 views
  • Last reply by jscher2000

more options

I have a MacBook Pro. OS X 10.8.4

After I open Firefox and type a website to navigate to, it initially opens the page but then immediately redirects to another page. Sometimes it redirects to Lycos.com, or another random advertisement page. Other times it redirects to an all grey page with a notice saying my Java is out of date, which it is not, as I have made sure through my software update. Along with this problem, there is a portion of the browser (lower left hand corner) that seems to be blocked by an invisible object. I say an invisible object because the cursor changes to a finger cursor as if there is a link or click-able ad, however I have tried clicking the area and nothing happens, not even when right clicking.

I really love Firefox and prefer using it over Safari but these issues have really tainted my experience with the browser.

Somebody please help!!!!

All Replies (4)

more options

Go to Firefox > Help > Troubleshooting Info > and hit Open Profile Directory, delete a file named user.js

Modified by kobe

more options

You also can check for nonessential and/or unrecognized add-ons on the following page:

Tools menu > Add-ons > Extensions category

If in doubt about what an extension is or does, or whether you need it, disable it. Then restart Firefox using one of the handy links on that page and see whether you notice any difference.

more options

This never helped as there was not an option after I opened the troublshooting info to open profile directory.

more options

Hi iambdwilson, sorry, the Troubleshooting Information screen changes depending on your OS. On Mac, the button to view your current profile folder is called "Show in Finder".

But it's very unlikely that such a dyanamic behavior is caused by a setting in your user.js file. I suggest investigating your add-ons.

To quickly see whether any of your extensions is relevant, you could try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?