X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google Play tab not loading on Firefox

Posted

Hi,

Ever since I updated to the current version of Firefox, the 'My Library' tab on Google Play does not load properly. I have been in touch with their help desk, and have tried multiple steps, including:

1. Clearing cache and history. 2. Uninstalling and reinstalling Flash player 3. Uninstalling add-ons from Ad aware and AVG Antivirus 4. Disabling and reanabling add-ons from the Add-ons Manager, while only enabling Flash Player 5. Uninstalling and reinstalling Firefox. 6. Launching Firefox in Safe mode

None of these fix the issue. If it were a problem with the Flash plugin, I would expect none of the tabs to work. But it's only that single tab that does not load on Firefox. These work well on IE9. At this point, I do not know of any other steps to troubleshoot the issue. Any help would be greatly appreciated.

Thanks Prashanth

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Amit Kumar Thakur 83 solutions 863 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

jscher2000
  • Top 10 Contributor
2349 solutions 20824 answers

Does it not load at all, or is there content missing, bad layout, broken buttons, etc.? (I only have the link under Music, so that's the only one I've tested.)

Helpful Reply

The content is missing. Instead of the Artists being displayed, this is what I get When I open the same in IE, I get all the Artists, sorted as folders...

Helpful Reply

Amit,

All my plugins (Flash, the one that matters) is upto date. I tried disabling all other plugins on both laptops, but it doesn't help. I would assume that an outdated plugin would cause issues on any browser, but this seems to be Firefox specific.

jscher2000
  • Top 10 Contributor
2349 solutions 20824 answers

Do you allow cookies for google.com? In the past, there have been some issues with some sites not being able to use DOM storage (local browser-based storage) if they were not allowed to set cookies at the base domain level (in this case that would be google.com).

To review your Google cookie settings, you can check any of these:

(1) Site permissions tab (while viewing a page on the site)

  • right-click and choose View Page Info > Permissions
  • Alt+t (open the classic Tools menu) > Page Info > Permissions

For maximum compatibility, you want Allow, but Allow for Session also should work.

(2) about:permissions page

You may see slightly different information if you type or paste about:permissions in the address bar and press Enter.

Question owner

I do allow cookies for google. Attached is the permissions page. It is weird that this issue has propped up so suddenly, when it was working fine a few months ago. Nothing has really changed, other than the usual FF updates. The fact that it is not working on two different laptops points to something FF specific too...

jscher2000
  • Top 10 Contributor
2349 solutions 20824 answers

I don't have any other ideas at the moment.

Firefox 22 is now available. Can you try it and see whether it helps with this?

If Help > About Firefox > Check for Updates doesn't pick it up, you can get it here: https://www.mozilla.org/en-US/firefox/fx/#desktop

Question owner

I have updated to the latest version, but these issues still persist... Any other ideas that I can try out? Why is it that this is the only tab that's not loading properly?

jscher2000
  • Top 10 Contributor
2349 solutions 20824 answers

As a test of how Firefox runs "uncustomized," could you create a new Firefox profile. In addition to bypassing current add-ons and custom settings, it should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager as described in this article:

Use the Profile Manager to create and remove Firefox profiles

Any time you want to switch profiles, exit Firefox and return to this dialog.

Note: I recommend using the default location suggested, and to avoid data loss, not pointing the new profile to any existing folder that contains files.

Does the site work as expected in the new profile?

Question owner

I tried creating a new profile, deleting my default profile and copying the default profile to the newly created profile. None of them work... I am thinking of rolling back on Flash and seeing if that fixes the issue. This does not seem to be Flash specific, as other Flash applications work, and all other tabs on Google play seem to be working. I only have Java and Shockwave Flash plugins enabled too... This is pretty perplexing, at this stage...

jscher2000
  • Top 10 Contributor
2349 solutions 20824 answers

By any chance, did you test the new profile before copying any possible damaged files into it to see whether it worked "out of the box"?


For Flash, this is some standard guidance that addresses the most common issues. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?