X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

not displaying correctly

Posted

A number of different websites are having issues where the pictures aren't loading, and there are large blocks of white space on the screen. I have no idea why this is, but I have tried the solution steps that were listed on the help page, I tried restarting in safe mode, and disabled adblock. Some web pages are fine, but others are broken. Take a look at this screenshot: http://imgur.com/CeyR5MM

Examples: beautifulpeople.com, myfitnesspal.com, mail.aim.com

Oddly enough, these websites display BETTER using IE6 than in Firefox 21! I have no idea what the problem is, I hope you guys can help. Thank you!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • 5.1.20125.0
  • Next Generation Java Plug-in 1.6.0_39 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Yahoo Application State Plugin version 1.0.0.7
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Application Basics
Name
Firefox
Version
21.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.4
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
ChatZilla
0.9.90
true
{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}
Image Search Options
2.0.2
true
{4a313247-8330-4a81-948e-b79936516f78}
Java Quick Starter
1.0
true
jqs@sun.com
facepaste
2.6
false
facepaste.firefox.addon@azabani.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
51200
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
614400
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.history_expire_days.mirror
60
browser.history_expire_days_min
28
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.search.useDBForOrder
true
browser.startup.homepage
http://en-us.start.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official
browser.startup.homepage_override.buildID
20130511120803
browser.startup.homepage_override.mstone
21.0
browser.tabs.autoHide
true
browser.tabs.loadInBackground
false
browser.tabs.onTop
false
browser.tabs.warnOnClose
false
dom.disable_window_flip
false
dom.event.contextmenu.enabled
false
dom.mozApps.used
true
dom.w3c_touch_events.expose
false
extensions.lastAppVersion
21.0
gfx.direct2d.disabled
true
layers.acceleration.disabled
true
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
5
network.http.proxy.version
1.0
places.database.lastMaintenance
1371491407
places.history.expiration.transient_current_max_pages
87220
places.last_vacuum
1339716047
plugin.disable_full_page_plugin_for_types
application/pdf
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
Microsoft XPS Document Writer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
0
print.print_unwriteable_margin_left
0
print.print_unwriteable_margin_right
0
print.print_unwriteable_margin_top
0
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_pagedelay
500
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11.00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8.50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1.00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
false
print.printer_Microsoft_XPS_Document_Writer.print_to_file
true
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.offlineApps
true
privacy.item.offlineApps
true
privacy.sanitize.migrateFx3Prefs
true
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.enable_ssl2
true
security.OCSP.disable_button.managecrl
false
security.OCSP.signingCA
Builtin Object Token:IPS CLASE1 root
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 8800 GTS 512
Adapter Drivers
nv4_disp
Adapter RAM
Unknown
Device ID
0x0600
DirectWrite Enabled
false (0.0.0.0)
Driver Date
10-16-2010
Driver Version
6.14.12.6099
GPU #2 Active
false
GPU Accelerated Windows
0/2 Basic
Vendor ID
0x10de
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce 8800 GTS 512)
AzureCanvasBackend
skia
AzureContentBackend
none
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.6
4.9.6
NSS
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSSMIME
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSSSL
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSUTIL
3.14.3.0
3.14.3.0

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96656 answers

Try to disable hardware acceleration in Firefox.

Question owner

Hardware acceleration is already disabled when I checked. Thanks for the suggestion though

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96656 answers

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

I tried clearing the cache again, and I deleted all cookies from the sites that have issues for me, it hasn't helped at all. I tried FF safe mode again, and the websites display the same as they do in normal mode, so still broken. It doesn't matter if I use private browsing or regular browsing either. I would try rebooting the machine into safe mode, but I can't do that right now. Is there anything else I can try?

This problem has been going on for months, and I've tried everything I can think of. I even created a new user account on the PC and went to FF on that, the problem still occurs!

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

To see whether it is related to your Firefox settings, could you create a new Firefox profile. In addition to bypassing current extensions and custom settings, it should have completely fresh settings databases and a fresh cache folder.

Close Firefox and start up in the Profile Manager as described in the following article:

Use the Profile Manager to create and remove Firefox profiles

A few tips on the Profile Manager:

  • Any time you want to switch profiles, close Firefox and return to this dialog.
  • I recommend using the default folder location suggested for your new profile (to avoid data loss, do not use any existing folder location).
  • Before deleting anything, it's a good idea to make a backup first.

Do the sites display correctly in the new profile?

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Also, could you review your color display settings on the following tab:

orange Firefox button (or Tools menu) > Options > Content

In the Fonts & Colors section, click the Colors button and make sure you have a checkmark for "Allow pages to choose their own colors."

Question owner

The sites finally work correctly in the new profile, and I checked on my original profile for the color setting. I found that box was already checked, so that couldn't have been the problem.

Now that we know it's a profile issue, what do you think might be causing the problem on my original profile? I'd just use the new profile, but obviously I'd like to keep my saved passwords and settings.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi addy81, if you like research, you could review your prefs.js file and look up any preferences that seem as though they might be relevant. You can find that file here:

Help > Troubleshooting Information > "Show Folder" button

Over time, this file tends to grow, so if time is short, you could consider the following: You can migrate your bookmarks and saved passwords to a new profile by using the "Reset" feature. If you would like to try that, check out this article for the details: Reset Firefox – easily fix most problems. (Slow loading right now for some reason?)

Reset copies your existing profile folder to the desktop and renames it Old Firefox Data, so if something essential turns out to be missing after the reset, you should be able to recover it from that folder.

snoopkatt 0 solutions 1 answers

Okay. After reading TONS of information of this (and all of it was unhelpful), I decided to test the CSS. The issue I have found is that when the CSS property "Opacity" value is set to < 1, large swaths of the printable area within firefox AND IE (internet explorer) do not render them correctly.

Check ALL CSS properties. Find opacity values which are < 1. Either:

  Delete them
  Comment Them Out /*opacity: 0.95; */ 
  Change the Opacity value to 1. opacity: 1;
  remove access to that external CSS File.
muddergrad 0 solutions 3 answers

I am having the exact same problem as described here... The examples given above (Examples: beautifulpeople.com, myfitnesspal.com, mail.aim.com) only show a list of links on my browser and I can't figure out what's wrong...

I have tried clearing my cache, clearing history, removed all cookies, flushed the DNS, turned off the "Use hardware acceleration when available", turned off all my added plugins, I reset FF, and tried creating a New Profile but when I follow the steps here https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles it simply opens up FF.

I have no idea what else to do... Where is the CSS that snoopkatt talked about above? That may help me out... As a side note, I have the same issue with Internet Explorer, Safari, and Google Chrome... Could it be something else entirely?

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi muddergrad, since you have the same issue in all browsers, have you considered whether your security software or privacy software is filtering what appears in all your browsers? This could be done either by intercepting all your browsing and blocking some files from being retrieved, or using an add-on that appears in all browsers. Hard to say anything more specific without digging around your system.

By the way, when creating a new profile, you need to fully exit out of Firefox first or the Profile Manager won't display and you'll just get a new window with your home page.

In Firefox testing in Safe Mode could help diagnose whether it is caused by an extension. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

muddergrad 0 solutions 3 answers

Tried using the safe mood with the add-ons disabled but saw no difference. I'm starting to think it may be my internet provider. I tried using a different computer through my internet connection and it had the same issue.

Sometimes, when I keep pressing refresh it will work but not always. Do you have any ideas?

muddergrad 0 solutions 3 answers

I think I figured it out... After some searching online I found that the DNS could be the problem so I changed my computer's DNS to Googles and everything seems to be working now. Hopefully it continues. Thanks for the help.