X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox hangs when scripts run, works fine with Javascript off

Posted

Turning Javascript off makes firefox work like normal. Other browsers have no issue. This started acting up on me about 4-5 days ago. Quite annoying to not be able to run firefox with javascript on. Is there a way to reinstall javascript?

I have tried safe mode, resetting firefox, reinstalling firefox, disabling addons, changing profiles, it really comes down to javascript being turned off fixes it for me. So despite being fairly computer savvy, I have no idea what is causing this. I ran Microsoft security essentials, a few malware/spyware utilities, checked hijackthis. I cannot find the issue. Firefox likely submitted 50+ crash reports.

bp-2be6c833-69ea-45e3-bdb9-a77422130617

is one crash report, I tried to get one of the earlier ones to see if that would help, not sure if this one will, I have plenty of them. But I'll load a page or a couple of pages and firefox will hang, it won't crash outright, but I end up using Task manager to close it.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

More Information

Application Basics
Name
Firefox
Version
21.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20130511120803
browser.startup.homepage_override.mstone
21.0
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
dom.w3c_touch_events.expose
false
extensions.lastAppVersion
21.0
gfx.direct3d.checkDX10
false
javascript.enabled
false
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
NVIDIA GeForce 9800 GT
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM
512
Device ID
0x0614
Direct2D Enabled
true
DirectWrite Enabled
true (6.2.9200.16492)
Driver Date
1-18-2013
Driver Version
9.18.13.1106
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID
0x10de
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce 9800 GT )
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.6
4.9.6
NSS
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSSMIME
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSSSL
3.14.3.0 Basic ECC
3.14.3.0 Basic ECC
NSSUTIL
3.14.3.0
3.14.3.0

jscher2000
  • Top 10 Contributor
2356 solutions 20867 answers

Helpful Reply

Thank you for the crash link. When I scroll down and look at related bugs, all of them seem to mention Flash.

This is some standard guidance that addresses the most common issues with the Flash player. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

jscher2000
  • Top 10 Contributor
2356 solutions 20867 answers

JavaScript is part of Firefox and there's no separate installation.

Are you getting the slow script dialog or does everything just come to a halt without any messages?

There is a JavaScript compiler in Firefox that is optional and can be disabled. But then Firefox's Safe Mode would have worked normally, so if that didn't help, it's probably not relevant.


Could you try disabling the JavaScript debugger? I think it was just turned on in Firefox 21. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste devt and pause while the list is filtered

(3) Double-click devtools.debugger.enabled to toggle its value from true to false. It should turn bold. (I don't know whether this takes effect immediately or after a restart.)


There are add-ons to manage which sites can use JavaScript, which might be helpful as a short term coping strategy or a lifestyle (I'm in the second category). In particular, you could consider using the NoScript extension. More information: http://noscript.net/

Helpful Reply

I apologize, I'm a knucklehead, I thought I tried the hardware acceleration a few times, but it seems I didn't try properly or something as that seemed to fix it. The good news is my hair should grow back from all the ones I pulled out trying to figure this out over the past few days. Thanks for your calm, patient, and understanding responses.

jscher2000
  • Top 10 Contributor
2356 solutions 20867 answers

If that takes care of all the problems, that would be amazing. I'll keep my fingers crossed for you.

StephAub 0 solutions 3 answers

I have the same problem, and have tried your suggestions: - disabling hardware graphics acceleration in Firefox has no effect - disabling javascript as indicated (in about:config) : no more freeze. - enabling javascript and disabling devtools.debugger : still freeze, however in some pages the freeze is less important (shoter).

The page i used for tests : www.colissimo.fr (on this page disabling debugger has no effect)

Disabling javascript is not a solution at all, as in that case for example i can't access to outlook (hotmail) !.....

Note : i'm with Firefox 25.0 on Win7 64bits

Is there any other solution ???

jscher2000
  • Top 10 Contributor
2356 solutions 20867 answers

Hi StephAub, is the problem on that specific page (http://www.colissimo.fr/)? I don't see anything special about that page. I assume you have tried the usual for when a particular page is not behaving well:

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page.


As a test, could you disable the Flash Player plugin and try the problem pages again? On the Add-ons page (Ctrl+Shift+a) set Shockwave Flash to "Never Activate".

StephAub 0 solutions 3 answers

Hi jsher ! thanks a lot for quick and efficient answer. I have good news : - when deactivating shockwave add-on as you indicated (i have 11.9.900.117) i don't have the freeze anymore on this page ! - if i re-activate shockwave add-on: problem is back. - i also tried to refresh page as you indicated (with shockwave activated) : same freeze.

3 additional comments: - i have this freeze issue on different pages (not only the one indicated). So i will check with other pages now with shockwave deactivated - this freeze duration (on this page) is 5 minutes, but within these 5 minutes i have from time to time "the hand" again (but it is so short that i can't do any other action on firefox until freeze end, i.e. after 5 minutes). - i had the same pb with previous release of shockwave add-on.

jscher2000
  • Top 10 Contributor
2356 solutions 20867 answers

Hi StephAub, were you able to disable the Protected Mode of the Flash Player plugin earlier? Although in theory this feature provides valuable security benefit, it remains a bit buggy and simply doesn't work well on all systems.

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

StephAub 0 solutions 3 answers

Hi Jscher, no i hadn't been able to disable protected mode of the flash player plugin - i didn't find how to do that.

But it seems i have finally solved my pb with complete uninstall of flash (by uninstall of Adobe products) then re-install . I have now shockwave flash plugin 11.9 r900 - so slightly different than the one i had before - and i don't have freeze any more .... at the moment.

so i cross fingers.... in any cases, thanks for your help.